Pls help? Catalyst 2950 SW stops at switch: Prompt...

Unanswered Question
Aug 30th, 2008
User Badges:

Dear All experts,


I have regular problems with Cisco Catalyst 2950 Series Switches. Since last 2 years I have found 5- 6 times the same problem.


Switch in a working condition suddenly stops and status of syst led is blinking. rest of LED are off. And Switch stops at switch: prompt.


I had changed the IOS from EA4 to EA8 but yet the same problem exist.


How xcan I resolve this problem pls guide me.


I am attaching the Captured file containg the discussed problem.




Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
satish_zanjurne Sun, 08/31/2008 - 23:51
User Badges:
  • Silver, 250 points or more


Hi Dipesh,

Is is same switch or different switches ??


Although you have mentioned it is "switches" still to confirm !!!

satish_zanjurne Sun, 08/31/2008 - 23:57
User Badges:
  • Silver, 250 points or more

have you tried changing the switch ??

Also if any logs are generated, kindly attach the logs also.

Dipesh Patel Mon, 09/01/2008 - 08:02
User Badges:

No,


Model is same .....


This Switch I have replaced ......


I have attached one Docs describe the problem .......


I mean to say this problem was occured in Past also. At that time I have raise RMA.


At this time also same problem occured thats why i am trying to troubleshoot it.


If you can suggest me something for the same pls ......




mahmoodmkl Tue, 09/02/2008 - 01:17
User Badges:
  • Gold, 750 points or more

Hi


Check for the mode button if it is pressed accidently.



Thanks

Mahmood

Dipesh Patel Wed, 09/03/2008 - 09:15
User Badges:

Dear Mehmood,


No it's not ..... I have Checked it. The faylty Switch I have replaced and checked everything.


Even Today other location Switch ( Same Model ) has the same problem occured - This time also i have replaced wth other Switch.i---- Now I have two switch with the same problem to solve......


So pls guide me.....



awafe Tue, 09/02/2008 - 02:04
User Badges:

Hello Dipesh..To reload the contents of flash means that the switch lost power.If you changed the switch, did you change the power cord.I have seen some power cords that lose the connections inside the moulded plastic plugs and recepticles and become intermittent.

If they reconnect multiple times in start, it will cause the switch to go into recovery mode. Thanks..Rod Lloyd.

Dipesh Patel Wed, 09/03/2008 - 09:26
User Badges:

Dear Sir,


I have installed another switch at location with the same powercord and its working.


Today also another Switch with the same model has same problem.


I am again Describing todays problem:


NW down on the Site - Device location when I visited I found syst LED is blinking - When I take Sw on console, it shows switch: prompt.


I have rebooted than also it stops at switch: prompt.


I have reload and pressed MODE button than I found init_flash , Load_Helper and boot option. I do that ...than I got switch> prompt but as I reload the switch again it stops at switch: prompt.


Action taken : At site I have Installed spare switch and made NW live.


In faulty Switch I have formtted Flash and NVRAM - loaded new IOS and Configured. and boot the switch but again the same problem


It shows error like this :::::::::::::::::::::::::::::::::::::;



The system has been interrupted prior to initializing the


flash filesystem. The following commands will initialize


the flash filesystem, and finish loading the operating


system software:



flash_init


load_helper


boot



switch:

+++++++++++++++++++++++++++++++++++++==


Pls help me if you can .......


It's serious problem for me now ......


Reply soon .......

Dipesh

awafe Tue, 09/02/2008 - 02:26
User Badges:

Hello again Dipesh..

Have you tried disabling the Express Setup Mode.This problem is documented in Cisco bug ID CSCee75743.

Thanks..RL.

Dipesh Patel Wed, 09/03/2008 - 10:55
User Badges:

Dear Sir,


Yes I have seen the bug .... But it describe that due to this bug configuration was deleted itself.


but in my case configuration deleted + switch do not comes up it stops at switch: prompt.


I can not get switch> prompt.


I m online right now if u r pls reply ....

glen.grant Wed, 09/03/2008 - 13:55
User Badges:
  • Purple, 4500 points or more

Is the config register correct on the switch , should be 0x2102.

STEVE DUE Wed, 09/03/2008 - 15:47
User Badges:

kind of sounds like you dont have a bootable image on your flash. have you tried when it comes up to type boot and hit inter? If the image is good it should boot, if it is not you will be returned to the same prompt. I know you have put new ios on them, do they have enough flash to accept the new version?

Dipesh Patel Wed, 09/03/2008 - 20:30
User Badges:

Dear Sir,


I have Copied the iOS after formating the Flash: and hence there is no question of Space.


And IOS is also valid but some thing happens to it ?


IS theere due to POWEr Supply problem ?


means cause of this problem ?


Pls reply




Dipesh Patel Wed, 09/03/2008 - 20:27
User Badges:

in this Model of Switch Config Reg value is 0xF and can't be changed.


I can not find any command to change Config Register in Switch.

satish_zanjurne Wed, 09/03/2008 - 21:55
User Badges:
  • Silver, 250 points or more

Hi Dipesh,


1.Unlike other Catalyst switches, there is no config-register command on the 2950 or 2955. You cannot change the configuration register value from the default.


2.The 2950/2955 automatically searches for a valid software image to boot from, even if a boot system statement is not set. Cisco recommends that you set the boot statement as a precaution. The command to set a boot system statement is boot system flash:


3.Check if switch boot mode is set to manual using following commands.


In ROMMON mode

use "set" command

In normal mode

use "show boot" command


if MANUAL_BOOT=yes in ROMON

or Manual Boot : yes in normal mode


4.Change the Manual Boot vlaue to No using following command


In ROMMON mode


switch: set MANUAL_BOOT no


Verify again using "set"


then use "boot" command


switch: boot flash:c2950-xxxxx.bin


In Normal Mode


use


Switch(config)#no boot manual

Switch#write memory


Switch#show boot


reload the switch.


HTH..rate if helpful..



Dipesh Patel Thu, 09/04/2008 - 00:40
User Badges:

Dear Sir,


I have done everything what u said .....


But my prob was not resolved yet ....


I am attaching 2 Files which contains all the process captured.


Pls ...


Dipesh



Attachment: 
arupbiet2006 Thu, 09/04/2008 - 01:29
User Badges:

hi dipesh ,

could you tell me what kinds of program is running in 2960 switch.



Dipesh Patel Thu, 09/04/2008 - 02:06
User Badges:

Dear Sir,


not 2960 its 2950 ...Different types of Application programme are running ...like Mail , Industrial Application software .....and all....


Dipesh

Dipesh Patel Thu, 09/04/2008 - 02:36
User Badges:

Dear arupbiet,


I have a problem in Switch Cisco Catalyst 2950 So can not configure Config Register.



satish_zanjurne Thu, 09/04/2008 - 02:36
User Badges:
  • Silver, 250 points or more


Hi,


While in ROMMON mode don't use = sign

just use below command


"switch: set MANUAL_BOOT no "


Although i saw the output in which you set manual boot to no in global config mode..


Try setting it in ROMMON as i have mentioed above.



HTH..rate if helpful..

Dipesh Patel Thu, 09/04/2008 - 02:56
User Badges:

Dear Sir,


I have done as you said as follows :


switch: set

BOOT=flash:c2950-i6q4l2-mz.121-22.EA4.bin

MAC_ADDR=00:07:4F:12:1D:C0

MANUAL_BOOT=no

MODEL_NUM=WS-C2950C-24

MODEL_REVISION_NUM=B0

MOTHERBOARD_ASSEMBLY_NUM=73-5750-08

MOTHERBOARD_SERIAL_NUM=FAB0537B3H5

POWER_SUPPLY_PART_NUM=34-0971-01

POWER_SUPPLY_SERIAL_NUM=DAB05320V0S

SYSTEM_SERIAL_NUM=FAB0538W03U



but again the same problem on reboot .....


stops at switch:

Actions

This Discussion