WLC 4404 5.1.151.0 - custom web-auth bundle

Unanswered Question
Aug 31st, 2008

Ultimately the user needs to see a custom "splash page" without having to authenticate. I have successfully installed a custom web-auth bundle that appears when the WLAN Web Policy is enabled, but without any authentication, there is no access to the outside.


Is what I'm trying to accomplish possible in some other way?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Scott Fella Sun, 08/31/2008 - 13:46

You created a splash page that the user has to hit an accept button of some sort, but will not enter a username and password. So in the WLC you have WebAuth using passthrough I suppose. What do you mean there is no access to the outside? Does users get the webauth page when he or she opens up a browser?


With WebAuth, the WLC needs to resolve the homepage of the users prior to the user getting the splash page you created. Clarify your setup and what you are trying to acomplish from the user end.

wwbishop2 Sun, 08/31/2008 - 15:33

Thanks for the reply. Ultimately I want all end users to be redirected to a specific home page, without clicking apply, or supplying a username and password.


I got around this by installing a custom web bundle of the page I want the users to see, but having to click the accept button before any traffic can pass through it (i.e. VPN clients, email, or any non-web browser application) is what I'm trying to avoid. I would rather the user just simply be redirected to a page without having to do anything on their end.



Scott Fella Sun, 08/31/2008 - 16:10

You will not be able to do this unless you use some 3rd party hotspot utility. The main reason you should have an accept button is to be able to display a terms and conditions for users to read if they wish. This will protect you from an legal troubles. You can try to write a script on the html page (you can keep the page blank and hide everything) that will activate the accept button, that way you can redirect them to your web page.


Try to add this to your html page:



setTimeout("submitAction()",20);



Hope this helps... just make sure you keep you html page blank.... by setting the background and text to white or any color of your choice.

Actions

This Discussion

 

 

Trending Topics - Security & Network