Catalyst 4006 SPANTREE Error

Unanswered Question
Aug 31st, 2008
User Badges:

I have a Catalyst 4006 L3 switch with Catalyst 2950 cascaded to it. All of sudden the following error massage started appearing on L3 switch. I have not made any changes to any switch. Whats causing this error? Some users lost network connectivity during this period.



%SPANTREE-2-RX_BLKPORTPVID: Block 3/1-2 (agPort 14/1) on rcving vlan 102 for inc peer vlan 22

%SPANTREE-2-RX_1QPVIDERR: Rcved pvid_inc BPDU on 1Q port 3/1-2 (agPort 14/1) vlan 102


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
satish_zanjurne Sun, 08/31/2008 - 23:42
User Badges:
  • Silver, 250 points or more


Are you sure that nobody has made any changes on the peer switch ??


It seems that vlan configuration is mismatched, on peer switch or this switch.

avilt Mon, 09/01/2008 - 00:37
User Badges:

I am very sure, no body made the changes as I am the only administrator. The L3 switch has sent logs to syslog server for one second period only.

During this period some users lost connectivity but connectivity got restored automatically.

There is no log for Port consistency restore OR Port Unblock.

Thanks

Giuseppe Larosa Mon, 09/01/2008 - 11:46
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Avil,

I've seen this kind of error in our network some times.

Usually it can happen during a port state transition.

I see this is a port-channel made of ports 3/1-2, how is trunking configured with negotiation or set to on ?

I would suggest to check the log files on both devices to see if any port has made an up/down.

STP BPDUs sent out a 802.1Q trunk contains info about which vlan they are associated so the peer switch compares the received tag with the BPDU vlan field and if they don't match this error is issued.


It was a temporary problem.

If it happens more times in a few days you need to investigate it.


Hope to help

Giuseppe

avilt Mon, 09/01/2008 - 16:51
User Badges:

Thank You Giuseppe. The network has been running for the past 4 years. Trunking on 3/1 and 3/2 is set to Dot1Q. Catalyst 2950 is cascaded into L3 switch. Pls find the attached configurations.


Thank You.



Attachment: 

Actions

This Discussion