Getting SQL Errors when running Store Procedures in DB Read

Unanswered Question
Sep 1st, 2008
User Badges:

We are using UCCX Premium 5.0.2 database functionality. We have tested to do normal DB Read and use select statement and it's fine. However, when I tried to use store procedures function by the following query.


exec sp_name $param1 , $param2 , $param3


I always goes to the SQL Error brand in the DB Read steps.


I have tried other combination of the query for example.


exec @returnCode = sp_name @Param1 = $param1 , @Param2 = $param2 , @Param3 = $param3


But it also didn't work.


Does anyone has experiences in using store procedures in UCCX 5.0 version?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
BCOLE2007 Tue, 09/02/2008 - 09:32
User Badges:
  • Bronze, 100 points or more

Using the CRS Java bean steps, stored procedures are not supported out of the box, but a few things can be done to use them, looks like you are using SQL server... Couple options


a)create a custom Java class accessing the Stored Procedure, there are some good threads out here on custom java classess, this probably has the best 'take away' learn a useful skill while solving your problem.


b)if possible write the SQL of the underlying stored procedure and code the rest of it using CRS steps, you may learn some more CRS scripting as well as SQL


c)keep looking at the threads out here, I have seen some posts on older versions of IPCC using the DBRead and DBGet, it may work for SQL Server


Blair

*Please rate useful posts

Actions

This Discussion