asdm image command not working on FWSM

Unanswered Question
Sep 1st, 2008

Hi all,

I m trying to enable ASDM on FWSM but the commands are not there to enable it.....

FWSM(config)# asdm ?

configure mode commands/options:

group Associate object group names with interfaces. Warning: This option

is designed for use solely by ASDM. Do not manually configure this

option.

history Enable/Disable Device Manager data sampling

location Associate an external network object with an interface. Warning:

This option is designed for use solely by ASDM. Do not manually

configure this option.

exec mode commands/options:

disconnect Specify ASDM session id to be disconnected after this keyword

FWSM(config)# asdm

Firewall(config)# asdm image disk0:/asdm.bin command is not seen on FWSM... need assistance for the same.. Here are some more information which can help you all in guiding me...

FWSM# dir flash:

Directory of flash:/

2 -rw- 5632060 <no date> asdm

1 -rw- 6037560 <no date> image

3 -rw- 4984 <no date> startup-config

No space information available

FWSM#

What i can see is in dir command its not showing date or the space available on flash. Is there any bug????

FWSM# sh version

FWSM Firewall Version 3.2(2)

Device Manager Version 5.2(1)F

Compiled on Thu 16-Aug-07 14:40 by dalecki

FWSM up 8 days 15 hours

failover cluster up 8 days 15 hours

Hardware: WS-SVC-FWM-1, 1024 MB RAM, CPU Pentium III 1000 MHz

Flash SMART CF @ 0xc321, 20MB

0: Int: Not licensed : irq 5

1: Int: Not licensed : irq 7

2: Int: Not licensed : irq 11

The Running Activation Key is not set, using default settings:

Licensed features for this platform:

Maximum Interfaces : 256

Inside Hosts : Unlimited

Failover : Active/Active

VPN-DES : Enabled

VPN-3DES-AES : Enabled

Cut-through Proxy : Enabled

Guards : Enabled

URL Filtering : Enabled

Security Contexts : 2

GTP/GPRS : Disabled

BGP Stub : Disabled

VPN Peers : Unlimited

Serial Number: SAD12140839

Running Activation Key: 0x00000000 0x00000000 0x00000000 0x00000000

Configuration last modified by enable_15 at 07:14:19.230 UTC Sun Aug 31 2008

FWSM#

--- Piyush

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (2 ratings)
Loading.
JORGE RODRIGUEZ Mon, 09/01/2008 - 08:55

Piyush,

Is http enable?

if not try enabling

firewall(config)#http server enable

assuming you have configured inside interface and have ip connectivity to the fw allow inside host to access asdm

firewall(config)#http inside_ip mask

seems your asdm image is in flash, when you issue the above try from PC https://fw_ip_address

if it does not load

try

firewall(config)#asdm image ?

firewall(config)#asdm image flash:/image_name

then try again from pc https://fw_ip_address

http://www.cisco.com/en/US/docs/security/fwsm/fwsm32/asdm52f/release/notes/asdm521f.html

Let us know how it works out

Rgds

Jorge

piyush_singh Tue, 09/02/2008 - 05:25

Jorge,

My issue got resolved, thanks for your valuable time.. but was just worried why

firewall(config)#asdm image flash:/image_name

asdm image command doesnt work on FWSM & also when i do a dir flash: i cannot find asdm version & file type or date...

FWSM#dir flash:

Directory of flash:/

2 -rw- 5632060 asdm

1 -rw- 6037560 image

3 -rw- 4984 startup-config

No space information available

FWSM#

& ya the commands which i used were:

http server enable

http A.B.C.D netmask Name of interface

---- Piyush

piyush_singh Tue, 09/02/2008 - 06:20

Jorge, it was just 2 commands which resolved the issue...

http server enable

http A.B.C.D netmask Name of interface

& then you can try from your pc with url https://

but i m still stuck y the command asdm image is not working for FWSM & the files in flash are shown differently..

FWSM# dir flash:

Directory of flash:/

2 -rw- 5632060 asdm

1 -rw- 6037560 image

3 -rw- 4984 startup-config

No space information available

You can see in above output its showing no space information available for flash & not even the file types present in flash ie asdmxxx.bin

-- Piyush

JORGE RODRIGUEZ Tue, 09/02/2008 - 08:07

have you entered activattion keys yet? not that this could issue on files dates but worth a try since your first post seems no running activation keys, perhaps some other netpro could comment on this one..

Jorge

robertson.michael Tue, 09/02/2008 - 08:18

Hi Piyush,

FWSM 3.2 does not use the 'asdm image' command because you can only have one version of ASDM loaded on the flash at a time. Thus, it would be redundant to specify the ASDM image name. This is why you must save the ASDM image file as "asdm" on the flash and this file is overwritten each time you load a new version onto the flash.

The same is true for FWSM image files. There is no 'boot system' command because you can only have one FWSM image loaded onto the flash at any given point in time (called "image").

-Mike

piyush_singh Mon, 10/06/2008 - 10:29

But still i m not able to see space information available onto FWSM flash

FWSM#dir flash:

Directory of flash:/

2 -rw- 5632060 asdm

1 -rw- 6037560 image

3 -rw- 4984 startup-config

No space information available

FWSM#

Actions

This Discussion