C6k--L3(lacp)--JuniperEX4200 running ospf

Unanswered Question
Sep 1st, 2008

HI

I am trying to run Layer3 with LACP Port-channels from C6k--L3(lacp)--JuniperEX4200 running ospf. It comes up in EXSTART state so deb ip osp adj and see Juniper sending mtu of 1482. Since 1482 is not support on Cisco, I hard-code mtu on both Cisco and Juniper to 1500 but no good so tried on cisco interface "ip opsf mtu-ignore" and still no good. If I take out port-channel and use a normal Layer 3 physical interface or just use L2 port-channel or L2 trunks, it works but I rather have it working with L3 LACP. For simplicity, I only use one physicaly interface for the port-channels right now.

Aug 28 16:19:46.430: OSPF: Send DBD to 10.0.38.6 on Port-channel98 seq 0xE6E opt 0x42 flag 0x7 len 32

Aug 28 16:19:46.430: OSPF: Retransmitting DBD to 10.0.38.6 on Port-channel98 [7]

Aug 28 16:19:47.270: OSPF: Rcv DBD from 10.0.38.6 on Port-channel98 seq 0xA0873C6 opt 0x42 flag 0x7 len 32 mtu 1486 state EXSTART

Aug 28 16:19:47.270: OSPF: First DBD and we are not SLAVE

I ABOVE REPEATS ITSELF FOR MULTIPLE TIMES AND THEN BELOW BUT WILL EVENTUALLY RESTART TRYING TO NEIGHBOR UP and GO THROUGH THE WHOLE CYCLE AGAIN:

Aug 28 16:21:21.431: OSPF: Killing nbr 10.0.38.6 on Port-channel98 due to excessive (25) retransmissions

Aug 28 16:21:21.431: OSPF: 10.0.38.6 address 192.168.98.1 on Port-channel98 is dead, state DOWN

Aug 28 16:21:21.431: %OSPF-5-ADJCHG: Process 1, Nbr 10.0.38.6 on Port-channel98 from EXSTART to DOWN, Neighbor Down: Too many retransmissions

Cisco's config:

interface Port-channel98

description TO-JUNIPER-LAYER3-SWITCH-TEST

ip address 192.168.98.2 255.255.255.252

logging event spanning-tree status

logging event bundle-status

logging event trunk-status

load-interval 30

interface GigabitEthernet1/35

description TO-JUNIPER-LAYER3-SWITCH-TEST

no ip address

logging event link-status

logging event spanning-tree status

logging event bundle-status

logging event trunk-status

load-interval 30

carrier-delay msec 0

channel-group 98 mode active

router ospf 1

log-adjacency-changes

passive-interface default

no passive-interface Vlan2

no passive-interface GigabitEthernet1/35

no passive-interface Port-channel98

network 10.0.0.0 0.0.255.255 area 0

network 10.1.0.0 0.0.255.255 area 0

network 192.168.98.0 0.0.0.3 area 98

Relevant Juniper configs:

ge-0/0/46 {

ether-options {

802.3ad ae2;

ae2 {

mtu 1500;

aggregated-ether-options {

lacp {

passive;

}

}

unit 0 {

family inet {

address 192.168.98.1/30;

protocols {

ospf {

area 0.0.0.98 {

area-range 10.0.98.0/23;

interface ae2.0;

interface ge-0/0/46.0;

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Mon, 09/01/2008 - 10:17

Hello Tony,

I would try to use

int po98

ip mtu 1482

to see if MTU mismatch can be solved

Hope to help

Giuseppe

aamercado Mon, 09/01/2008 - 19:06

As I noted in my post, I already did this and it is not supported.

Thx

Giuseppe Larosa Mon, 09/01/2008 - 22:18

Hello Tony,

I thought you had tried to use mtu 1482 inside port-channel so I was thinking of ip mtu 1482.

Best Regards

Giuseppe

Actions

This Discussion