Problem with isdn

Unanswered Question
Sep 1st, 2008
User Badges:

Hi

I have the problem with interconnection of the router cisco 2800 with the Fleet 77(inmarsat)by BRI port.

The router display error messages that I can not understand.


debug isdn error command returns the following error message:


*Jan 1 01:10:15.527: ISDN BR1/0 SERROR: L2_Go: at bailout DLCB is

L2: sapi 0 tei 65 ces 255 ev 0x0

*Jan 1 01:10:15.539: ISDN BR1/0 SERROR: L2_Go: at bailout DLCB is

L2: sapi 0 tei 65 ces 255 ev 0x0


By activating the debug isdn q921 I have the following message:

*Jan 1 01:13:35.471: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=31 nr=2

1

*Jan 1 01:13:36.143: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=32 nr=2

1

*Jan 1 01:13:36.155: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=33 nr=2

1


At wiring there is no problem, the BRI interface is well mounted and recognized:


R-2800#show interfaces brI 1/0

BRI1/0 is up, line protocol is up (spoofing)

Hardware is BRI

Description: **** Connexion France Telecom ****

Internet address will be negotiated using IPCP

MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, loopback not set

Keepalive not set

Last input 00:00:00, output 01:24:47, output hang never

Last clearing of "show interface" counters 02:38:20

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/16 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 96 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

5618 packets input, 86817 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

18 packets output, 144 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 unknown protocol drops

0 output buffer failures, 0 output buffers swapped out

3 carrier transitions


when I make a test call my error message below:

*Jan 1 03:24:03.219: ISDN BR1/0 **ERROR**: host_disconnect_ack: Unfound B-chann

el on Disconnect_Ack call id 0x8008


To help me below the configuration implemented on my router:


service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname R-2800

!

enable secret 5 ********

!

!

ip subnet-zero

ip dhcp excluded-address ip_adress

ip dhcp excluded-address ip_address

!

ip dhcp pool Pool_DHCP

network ip_address 255.255.255.0

default-router ip_gateway

!

ip name-server 193.252.234.1

isdn switch-type vn3

!

!

!

interface GigabitEthernet0/0

ip address ip_gateway 255.255.255.0

no ip directed-broadcast

shutdown

!

interface BRI1/0

description **** Connexion France Telecom ****

bandwidth 128

ip address negotiated

no ip directed-broadcast

ip nat outside

encapsulation ppp

no keepalive

dialer string "90667#"

dialer hold-queue 10

dialer-group 1

isdn switch-type vn3

isdn tei-negotiation first-call

ppp authentication pap callin

ppp pap sent-username inmarsat password 7 000D1D0B054918071B

!

ip nat inside source list 1 interface BRI1/0 overload

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 BRI0

!

access-list 1 permit ip_address 0.0.0.255

dialer-list 1 protocol ip permit

!

line con 0

password Total2008

transport input none

stopbits 1

line vty 0 4

password ********

login

!

end



Thanks for your help



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Mon, 09/01/2008 - 08:47
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Gatien,

a very useful command for ISDN is:


sh isdn status


it shows the L1, L2, L3 real status


the correct L2 state is MULTIPLE_FRAME_ESTABLISHED


post the output of sh isdn status


Hope to help

Giuseppe

pointenoire Mon, 09/01/2008 - 09:22
User Badges:


Hi,

Thanks for you answer.


isdn statur ordering me back this:


Global ISDN Switchtype = vn3

ISDN BRI1/0 interface

dsl 8, interface ISDN Switchtype = vn3

Layer 1 Status:

ACTIVE

Layer 2 Status:

Layer 2 NOT Activated

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 8 CCBs = 0

The Free Channel Mask: 0x80000003

when I run the same command for a test call that ultimately fail (isdn test call ) I have this:

R-2800#sh isdn status

Global ISDN Switchtype = vn3

ISDN BRI1/0 interface

dsl 8, interface ISDN Switchtype = vn3

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 255, Ces = 1, SAPI = 0, State = ESTABLISH_AWAITING_TEI

Layer 3 Status:

0 Active Layer 3 Call(s)

CCB:callid=8003, sapi=0, ces=1, B-chan=1, calltype=DATA, hdlctype=HDLC-T

RUNK

Active dsl 8 CCBs = 1

The Free Channel Mask: 0x80000002



Giuseppe Larosa Mon, 09/01/2008 - 09:37
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Gatien,

the interface is stucked at L2 :

ESTABLISH_AWAITING_TEI


it is waiting for a TEI value to be assigned by the switch port.


If you can try to shut the BRI and after a while to reenable it.

If not enough if you can you need to reload the router.


use debug isdn q921 to see what happens during your attempts


Hope to help

Giuseppe

Richard Burts Mon, 09/01/2008 - 09:39
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Gatien


Thank you for the additional information. When I saw in the first isdn status output that layer 2 was NOT Activated, then I thought that this was the problem. But then I remembered this line in your config:

isdn tei-negotiation first-call

which seems to indicate that it will not negotiate TEI until the first call. So the output of isdn status after attempting a call becomes the important one to look at. And it indicates:

State = ESTABLISH_AWAITING_TEI

I believe that this indicates some difficulty in negotiation between your router and the provider ISDN switch. Can you verify with your provider that the switch type is correct and whether there is any special setup required to communicate with their switch?


HTH


Rick

Giuseppe Larosa Mon, 09/01/2008 - 10:01
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Rick,

Actually Gatien is using a satellite device so the vn3 switch type could be wrong it is fine in France when connecting to France Telecom.

I would suggest to verify the switch type supported on the satellite receiver Fleet 77 BRI port


Hope to help

Giuseppe

Richard Burts Mon, 09/01/2008 - 10:35
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Giuseppe


Thank you. Using satellite is a detail that I had not picked up. I believe that we both agree that the issue at this point is a failure to negotiate TEI with the switch.


HTH


Rick

pointenoire Mon, 09/01/2008 - 22:41
User Badges:

Hi all

Thank you for your suggestions.But I can not understand why I have this error permanently:

R-2800#debug isdn error

R-2800#ter mon

*Jan 1 04:25:47.094: ISDN BR1/0 SERROR: L2_Go: at bailout DLCB is NULL

L2: sapi 0 tei 66 ces 255 ev 0x1

*Jan 1 04:25:49.534: ISDN BR1/0 SERROR: L2_Go: at bailout DLCB is NULL

L2: sapi 0 tei 67 ces 255 ev 0x0

*Jan 1 04:25:49.550: ISDN BR1/0 SERROR: L2_Go: at bailout DLCB is NULL


And when I do tests of Appeal, I have this message:

*Jan 1 03:24:03.219: ISDN BR1/0 **ERROR**: host_disconnect_ack: Unfound B-chann

el on Disconnect_Ack call id 0x8008


Thanks for help

Giuseppe Larosa Tue, 09/02/2008 - 11:11
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Gatien,

the problem should be an ISDN switch type mismatch.

With the wrong switch type configured the BRI will try to use all possible TEI values: you see TEI 66 then TEI 67 but without any success.

When you use ISDN test command it fails because layer2 is not fine so no available B channel is found.

You need to find out what type of ISDN switch is the Fleet 77 BRI port and to configure the router port accordingly.

You may need to reload the router when changing ISDN switch type.


Hope to help

Giuseppe

pointenoire Wed, 09/03/2008 - 03:28
User Badges:

Hi


I close my provider inmarsat clear to me that the type of switch is isdn basic-net3, this change has not corrected the problem.

I still have the same error messages

Thanks for you help

adrienbomble Wed, 09/03/2008 - 07:15
User Badges:

Hi,

I'm working with pointenoire.


The switch type was confirm as correct by the provider. => basic-net3


During deb isdn q921 we can see that Receiver Ready final (RRf) sapi messages are missing and don't know why.


*Jan 3 06:52:46.327: ISDN BR1/0 Q921: User RX <- RRp sapi=0 tei=64 nr=0

*Jan 3 06:52:46.599: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=81 nr=97

*Jan 3 06:52:47.363: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=82 nr=97

*Jan 3 06:52:47.379: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=83 nr=97

*Jan 3 06:52:47.391: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=84 nr=97

*Jan 3 06:52:47.595: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=85 nr=97

*Jan 3 06:52:48.587: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=86 nr=97

*Jan 3 06:52:49.583: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=87 nr=97

*Jan 3 06:52:52.447: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=88 nr=97

*Jan 3 06:52:52.467: ISDN BR1/0 Q921: User RX <- RR sapi=0 tei=65 nr=98

*Jan 3 06:52:53.559: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=89 nr=98

*Jan 3 06:52:54.551: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=90 nr=98

*Jan 3 06:52:56.379: ISDN BR1/0 Q921: User RX <- RRp sapi=0 tei=64 nr=0

*Jan 3 06:52:57.395: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=91 nr=98

*Jan 3 06:52:57.407: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=92 nr=98

*Jan 3 06:52:57.423: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=93 nr=98

*Jan 3 06:52:59.523: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=94 nr=98

*Jan 3 06:53:00.515: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=95 nr=98

*Jan 3 06:53:06.439: ISDN BR1/0 Q921: User RX <- RRp sapi=0 tei=64 nr=0

*Jan 3 06:53:07.427: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=96 nr=98

*Jan 3 06:53:07.439: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=97 nr=98

*Jan 3 06:53:07.455: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=98 nr=98

*Jan 3 06:53:07.475: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=99 nr=98

*Jan 3 06:53:10.455: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=100 nr=98

*Jan 3 06:53:11.451: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=101 nr=98

*Jan 3 06:53:13.439: ISDN BR1/0 Q921: User RX <- INFO sapi=0 tei=65, ns=102 nr=98


Giuseppe Larosa Wed, 09/03/2008 - 12:07
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Adrien,

have you reloaded the router after changing the isdn switch type ?

I'm afraid it is a necessary step.


Hope to help

Giuseppe

Actions

This Discussion