Cisco Netflow and required IOS image

Answered Question
Sep 1st, 2008

Hi Team Netpro -

I am in the process of preparing documents regarding the deployment of Netflow version 5 for some 20 sites worldwide . I would like to know what IOS images can support this technology . Currently some of our routers are running the following IOS Images:

(C7200-SPSERVICESK9-M), Version 12.4(6)T, RELEASE SOFTWARE (fc1)

(C2800NM-SPSERVICESK9-M), Version 12.4(6)T, RELEASE SOFTWARE (fc1)

(C3845-SPSERVICESK9-M), Version 12.3(11)T10, RELEASE SOFTWARE (fc4)

(C3825-SPSERVICESK9-M), Version 12.4(6)T2, RELEASE SOFTWARE (fc1)

(C7200-IS-M), Version 12.4(7), RELEASE SOFTWARE (fc6)

Do you think we still need an IOS upgrade or not ?

Thank you in advance .

Jay

I have this problem too.
0 votes
Correct Answer by JORGE RODRIGUEZ about 8 years 4 months ago

In addition to information provided by previous poster, I do not believe you need to upgrade with the current images you have running, most SPSERVICES k9 images 12.4 versions support netflow.

I also suggest to go over this link as well as the link provided before me.

http://www.cisco.com/en/US/docs/ios/12_4/netflow/configuration/guide/onf_gsg.html#wp1043332

you may verify in features lookup here in feature navigator http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp

another easy way to verify is by typing a question mark at cli without actually entering the command on the routers.

exmaple for this bellow very basic netflow script on a router place a question mark without actual placing command

interface

ip route-cache ?

ip route-cache flow

router(config)#ip flow-export ?

router(config)#ip flow-export version ? <-- should show all the versions supported 1,5,9, etc..

router(config)#ip flow-cache timeout ?

router(config)#ip flow-top-? <--- for top talkers sub-commands

ip flow-export destination

ip flow-export version 5

ip flow-cache timeout active 1

ip flow-cache timeout inactive 15

ip flow-top-talkers

top 10

sort-by bytes

(C3845-SPSERVICESK9-M), Version 12.3(11)T10, RELEASE SOFTWARE (fc4) < --- this one should also be able to support netflow

PLS rate any helpful post if it helps

Rgds

Jorge

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
JORGE RODRIGUEZ Mon, 09/01/2008 - 20:19

In addition to information provided by previous poster, I do not believe you need to upgrade with the current images you have running, most SPSERVICES k9 images 12.4 versions support netflow.

I also suggest to go over this link as well as the link provided before me.

http://www.cisco.com/en/US/docs/ios/12_4/netflow/configuration/guide/onf_gsg.html#wp1043332

you may verify in features lookup here in feature navigator http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp

another easy way to verify is by typing a question mark at cli without actually entering the command on the routers.

exmaple for this bellow very basic netflow script on a router place a question mark without actual placing command

interface

ip route-cache ?

ip route-cache flow

router(config)#ip flow-export ?

router(config)#ip flow-export version ? <-- should show all the versions supported 1,5,9, etc..

router(config)#ip flow-cache timeout ?

router(config)#ip flow-top-? <--- for top talkers sub-commands

ip flow-export destination

ip flow-export version 5

ip flow-cache timeout active 1

ip flow-cache timeout inactive 15

ip flow-top-talkers

top 10

sort-by bytes

(C3845-SPSERVICESK9-M), Version 12.3(11)T10, RELEASE SOFTWARE (fc4) < --- this one should also be able to support netflow

PLS rate any helpful post if it helps

Rgds

Jorge

jocampo35116 Mon, 09/01/2008 - 20:22

Hi Jorge -

Thank you for your reply . I have also tried this approach and was able to verify that all the existing IOS can support netflow .

Thank you very much for you help .

Respectfully ,

Jay

Actions

This Discussion