HSRP Ignoring Coup

Unanswered Question
Sep 2nd, 2008
User Badges:
  • Bronze, 100 points or more

I'm trying to track a WAN interface with HSRP.


Router HSRP config. is as follows.


Active Router(GW01)

-------------------

interface FastEthernet0/0.20

encapsulation dot1Q 20

ip address 2.2.2.2 255.255.255.0

standby 1 ip 2.2.2.1

standby 1 priority 105

standby 1 preempt delay minimum 60

standby 1 track Serial0/0



Standby Router(GW02)

--------------------


interface FastEthernet0/0.20

encapsulation dot1Q 20

ip address 2.2.2.3 255.255.255.0

standby 1 ip

standby 1 preempt

-----------------


Active router sends a lower priority (95) as soon as it tracks the failure of the WAN interface.


I see the following HSRP debug messages(debug standby on Active router) saying that the coup was ignored.


GW01: Sep 1 15:04:31: HSRP: Fa0/0.20 Grp 1 Hello out 2.2.2.2 Active pri 95 vIP 2.2.2.1

GW01: Sep 1 15:04:31: HSRP: Fa0/0.20 Grp 1 Coup in 2.2.2.3 Standby pri 100 vIP 2.2.2.1

GW01: Sep 1 15:04:31: HSRP: Fa0/0.20 Grp 1 Ignoring Coup (100/2.2.2.3 < 105/2.2.2.2)


What does this actually mean and why does it happen?


Many thanks for sharing your ideas and experiences.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mahmoodmkl Tue, 09/02/2008 - 01:12
User Badges:
  • Gold, 750 points or more

Hi


U need to include below


standby 1 track Serial0/0 20

i.e how much u want the priority to be decreased when the serial0/0 goes down.


Thanks

Mahmood

rsgamage1 Tue, 09/02/2008 - 01:17
User Badges:
  • Bronze, 100 points or more

Hi,


According to my understanding the default(10) would be good enough to achieve the required functionality.



mahmoodmkl Tue, 09/02/2008 - 01:24
User Badges:
  • Gold, 750 points or more

Hi


interface FastEthernet0/0.20

encapsulation dot1Q 20

ip address 2.2.2.3 255.255.255.0

standby 1 ip

standby 1 preempt


according to u r config u r missing the


standby 1 ip


or its a typo.


Thanks

Mahmood



rsgamage1 Tue, 09/02/2008 - 01:36
User Badges:
  • Bronze, 100 points or more

You don't need to have it specified manually.


The standby router can learn it from the Active router.


Here's the corresponding output of show standby fyi.


FastEthernet0/0.20 - Group 1

State is Standby

Virtual IP address is 2.2.2.1 (learnt)


Note that it is learnt from the active HSRP router.


HTH

Actions

This Discussion