ISDN BRI

Answered Question
Sep 2nd, 2008

Hi,

I have ISDN BRI line that keeps getting up in regulary intervals (every hour). It is not initiated by interesting traffic (I configured deny any any in access list). Does anybody knows how to fix this?

This is config:

interface BRI0/3/0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

isdn point-to-point-setup

isdn static-tei 0

no cdp enable

ppp authentication chap

!

interface Dialer1

ip unnumbered Loopback0

encapsulation ppp

dialer pool 1

dialer idle-timeout 600 either

dialer enable-timeout 1

dialer string xxxxxxxx

dialer load-threshold 200 either

dialer-group 1

no cdp enable

ppp authentication chap

ppp multilink

!

access-list 150 deny ip any any

dialer-list 1 protocol ip list 150

This is debug output (debug isdn q931, error and debug dialer packets, events :

*Sep 2 14:23:37.912: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/3/0, TEI 0 changed to up

*Sep 2 14:23:38.456: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/3/0, TEI 0 changed to down

*Sep 2 14:23:38.456: ISDN BR0/3/0 Q931: L3_ShutDown: Shutting down ISDN Layer 3

*Sep 2 15:26:14.500: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/3/0, TEI 0 changed to up

*Sep 2 15:26:15.045: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/3/0, TEI 0 changed to down

*Sep 2 15:26:15.045: ISDN BR0/3/0 Q931: L3_ShutDown: Shutting down ISDN Layer 3

Thanks,

A

Correct Answer by Richard Burts about 8 years 5 months ago

Antonio

I have not seen this command used very much:

isdn static-tei 0

can you tell us why you need it here?

If you remove that line does the behavior change?

HTH

Rick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
spremkumar Tue, 09/02/2008 - 09:22

Hi

Can you remove the command isdn point-to-point from the isdn bri interface and check.

You can make use of no isdn point-to-point command to achieve the same.

regds

Antonio_1_2 Wed, 09/03/2008 - 04:10

Hi,

I removed isdn point-to-point from the interface configuration but Interface still goes up and down every hour

*Sep 3 11:15:50.765: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/3/0, TEI 0 changed to up

*Sep 3 11:15:51.310: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/3/0, TEI 0 changed to down

*Sep 3 11:15:51.310: ISDN BR0/3/0 Q931: L3_ShutDown: Shutting down ISDN Layer 3

*Sep 3 12:18:27.402: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/3/0, TEI 0 changed to up

*Sep 3 12:18:27.947: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/3/0, TEI 0 changed to down

*Sep 3 12:18:27.951: ISDN BR0/3/0 Q931: L3_ShutDown: Shutting down ISDN Layer 3

*Sep 3 13:21:04.059: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/3/0, TEI 0 changed to up

*Sep 3 13:21:04.608: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/3/0, TEI 0 changed to down

*Sep 3 13:21:04.608: ISDN BR0/3/0 Q931: L3_ShutDown: Shutting down ISDN Layer 3

*Sep 3 14:23:40.664: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/3/0, TEI 0 changed to up

*Sep 3 14:23:41.205: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/3/0, TEI 0 changed to down

*Sep 3 14:23:41.205: ISDN BR0/3/0 Q931: L3_ShutDown: Shutting down ISDN Layer 3

spremkumar Wed, 09/03/2008 - 04:52

Hi

can you post the full configuration of your router and also can u try doing isdn debug q921/q931 and paste the output.

Try q921 or q931 in a single instance and capture the output.

regds

Antonio_1_2 Wed, 09/03/2008 - 06:16

Hi, Here is the debug output (q921 and 1931)

ep 3 15:59:14.269: ISDN BR0/3/0 Q921: L2_EstablishDataLink: sending SABME

Sep 3 15:59:14.269: ISDN BR0/3/0 Q921: User TX -> SABMEp sapi=0 tei=0

Sep 3 15:59:14.297: ISDN BR0/3/0 Q921: User RX <- UAf sapi=0 tei=0

Sep 3 15:59:14.297: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/3/0, TEI 0 changed to up

Sep 3 15:59:14.838: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/3/0, TEI 0 changed to down

Sep 3 15:59:14.842: ISDN BR0/3/0 Q931: L3_ShutDown: Shutting down ISDN Layer 3

And here is whole configuration:

version 12.4

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

service password-encryption

!

hostname xxxxx

!

boot-start-marker

boot-end-marker

!

no aaa new-model

!

clock timezone CET 1

clock summer-time CET-SUMMER recurring last Sun Mar 2:00 last Sun Oct 3:00

!

!

ip cef

!

!

no ip domain lookup

ip host router1 2015 10.0.1.0

ip host router2 2017 10.0.1.0

ip host router3 2005 10.0.1.0

!

isdn switch-type basic-net3

!

username user01 password 7 047C05075E2FdD4f01

!

interface Loopback0

ip address 10.0.1.0 255.255.255.255

!

interface FastEthernet0/0

ip address 10.20.4.196 255.255.255.224

duplex auto

speed auto

!

interface FastEthernet0/1

shutdown

!

interface BRI0/3/0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

isdn static-tei 0

no cdp enable

ppp authentication chap

!

interface Async0/0/0

no ip address

encapsulation slip

!

interface Async0/0/1

no ip address

encapsulation slip

!

interface Async0/0/2

no ip address

encapsulation slip

!

interface Async0/0/3

no ip address

encapsulation slip

!

interface Async0/0/4

no ip address

encapsulation slip

!

interface Async0/0/5

no ip address

encapsulation slip

!

interface Async0/0/6

no ip address

encapsulation slip

!

interface Async0/0/7

no ip address

encapsulation slip

!

interface Async0/0/8

no ip address

encapsulation slip

!

interface Dialer1

ip unnumbered Loopback0

encapsulation ppp

dialer pool 1

dialer idle-timeout 600 either

dialer enable-timeout 1

dialer string xxxxxxxx

dialer load-threshold 200 either

dialer-group 1

no cdp enable

ppp authentication chap

ppp multilink

!

interface Dialer2

ip unnumbered Loopback0

encapsulation ppp

dialer pool 1

dialer idle-timeout 600 either

dialer enable-timeout 1

dialer string xxxxxxxxx

dialer load-threshold 200 either

dialer-group 1

no cdp enable

ppp authentication chap

ppp multilink

!

interface Dialer3

ip unnumbered Loopback0

encapsulation ppp

dialer pool 1

dialer idle-timeout 600 either

dialer enable-timeout 1

dialer string xxxxxxxx

dialer load-threshold 200 either

dialer-group 1

no cdp enable

ppp authentication chap

ppp multilink

!

router eigrp 1

passive-interface default

network 10.0.1.0 0.0.0.0

network 10.20.4.192 0.0.0.31

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 10.20.4.217 200

ip route 10.0.1.6 255.255.255.255 Dialer1

ip route 10.0.1.8 255.255.255.255 Dialer2

ip route 10.0.1.11 255.255.255.255 Dialer3

!

no ip http server

!

access-list 150 permit tcp any 10.0.1.0 0.0.0.255

access-list 150 permit icmp any 10.0.1.0 0.0.0.255

dialer-list 1 protocol ip list 150

!

control-plane

!

!

line con 0

login local

line aux 0

line 0/0/0 0/0/15

session-timeout 20

exec-timeout 0 0

no exec

transport input all

transport output all

stopbits 1

line vty 0 4

session-timeout 10

exec-timeout 60 0

password 7 04560E221DfE

login local

transport input all

!

scheduler allocate 20000 1000

ntp clock-period 17208329

ntp source FastEthernet0/0

ntp server 10.20.4.217

!

end

regards,

Correct Answer
Richard Burts Wed, 09/03/2008 - 09:10

Antonio

I have not seen this command used very much:

isdn static-tei 0

can you tell us why you need it here?

If you remove that line does the behavior change?

HTH

Rick

Antonio_1_2 Thu, 09/04/2008 - 06:45

Hi Rick,

I removed static TEI and it seems that interface doesn't go up anymore.

I put it in a configuration because it was recommended by the Telco for their type of ISDN switch.

Thanks,

A

Richard Burts Thu, 09/04/2008 - 08:47

Antonio

I am glad that you got your problem resolved. It is a bit odd that the telco would recommend this command and then it turns out that it creates a problem for you.

Thank you for using the rating system to indicate that your problem was resolved (and thanks for the rating). It makes the forum more useful when people can read a problem and can know that a response was successful in resolving the problem.

The forum is an excellent place to learn about Cisco networking. I encourage you to continue your participation in the forum.

HTH

Rick

Actions

This Discussion