FM 3.3.1c Install Failure PostgreSQL security blocking

Unanswered Question

I have tried a plethora of ways to simply get a lab environment setup related to a pair of MDS9124 switches I have. I want to get the GUI up and running for demos but can not get fabric manager to load. I have tried many times and several versions but to no avail. I am hoping I am simply missing something quick. I did much googling and no hits related (or the ones I found I tried, such a shortening path directory).

OS: Windows 2003 EE 32bit SP2 running AD

Firewall: ICA and Firewall not installed

Other DB on server: MS SQL 2005 MSDE

Version: FM 3.3.1c (

Java: jre-6u7-windows-i586-p-s

******Error *************

C:\Documents and Settings\Administrator>java.exe -Xmx512m -jar "C:/MDS3-31c/softwa



2008-09-02 14:42:35,718 [ INFO] OS: Windows 2003

2008-09-02 14:42:35,718 [ INFO] Patch Level: Service Pack 2

2008-09-02 14:42:35,718 [ INFO] Version: 5.2

2008-09-02 14:42:35,718 [ INFO] JVM Vendor: Sun Microsystems Inc.

2008-09-02 14:42:35,718 [ INFO] JVM Version: 1.6.0_07

2008-09-02 14:42:35,718 [ INFO] jar:file:C:\Documents and Settings\JeremeyWise\.


Dll path: C:\DOCUME~1\JEREME~1\LOCALS~1\Temp\1\\MDSInstall.dll

2008-09-02 14:42:35,859 [ INFO] Install folder: C:\Program Files\Cisco Systems\M

DS 9000

2008-09-02 14:42:35,859 [ INFO] Existing installation folder: C:\Program Files\C

isco Systems\MDS 9000

2008-09-02 14:43:05,890 [ INFO] META-INF/MANIFEST.MF

2008-09-02 14:43:05,890 [ INFO] sme322oracleupgrade.sql

2008-09-02 14:43:05,890 [ INFO] sme322pgupgrade.sql

2008-09-02 14:43:05,906 [ INFO] ejb3-interceptors-aop.xml

2008-09-02 14:43:05,906 [ INFO] fmserver-ds.xml

2008-09-02 14:43:05,906 [ INFO] jboss-log4j.xml

2008-09-02 14:43:05,906 [ INFO] jboss-service.xml

2008-09-02 14:43:05,906 [ INFO] jbossmq-destinations-service.xml

2008-09-02 14:43:05,906 [ INFO] login-config.xml

2008-09-02 14:43:05,906 [ INFO] oracle-jdbc2-service.xml

2008-09-02 14:43:05,906 [ INFO] oracleclean.sql

2008-09-02 14:43:05,906 [ INFO] oraclesetup.sql

2008-09-02 14:43:05,906 [ INFO] oracleupgrade.sql

2008-09-02 14:43:05,906 [ INFO] persistence.xml

2008-09-02 14:43:05,906 [ INFO] postgres-jdbc2-service.xml

2008-09-02 14:43:05,921 [ INFO] postgrescreate.sql

2008-09-02 14:43:05,921 [ INFO] postgresql_sol_big.conf

2008-09-02 14:43:05,921 [ INFO] postgresupgrade.sql

2008-09-02 14:43:05,921 [ INFO] quartz-service.xml

2008-09-02 14:43:05,921 [ INFO]

2008-09-02 14:43:05,921 [ INFO] jar:file:/C:/MDS3-31c/software/m9000-fm-3.3.1c.j


2008-09-02 14:43:06,203 [ INFO] postgres-win/install.bat

2008-09-02 14:43:06,203 [ INFO] postgres-win/pg_hba.conf

2008-09-02 14:43:06,203 [ INFO] postgres-win/postgresql-8.2-int.msi

2008-09-02 14:43:06,718 [ INFO] postgres-win/postgresql-8.2.msi

2008-09-02 14:43:06,734 [ INFO] postgres-win/postgresql.conf

2008-09-02 14:43:06,734 [ INFO] postgres-win/README.TXT

2008-09-02 14:43:06,796 [ INFO] postgres-win/upgrade.bat

The command completed successfully.

2008-09-02 14:43:14,578 [FATAL] Install encountered a problem. Failed to start

PostgreSQL. A security software agent may be blocking PostgreSQL from installing


An installation log can be found at C:\Documents and Settings\JeremeyWise\.cisco


2008-09-02 14:43:14,578 [FATAL] Failed to start PostgreSQL. A security software

agent may be blocking PostgreSQL from installing.

******End Error **************

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
user_4444 Tue, 09/02/2008 - 23:45

I noticed that the setup is running from "Administrator" profile and putting the Log into "Jeremey". Does the Jeremey account exist in the Local Admin group? I have had problems with Windows Firewall when installing Fabric Manager before, turn that off and put to Disabled.

stephen2615 Thu, 09/04/2008 - 15:01

Sort of related to this.

I had so many issues that I gave up and used Oracle Express. We have a super strict security policy that made the Postgres installation almost impossible. Oracle Express went on like a charm and I can't figure out why it is not used in the first place.


stephen2615 Fri, 09/05/2008 - 17:23

I don't believe it is supported.

Oracle is extremely easy to install compared to the major headaches I had with Postgres which I never was able to get on thanks to our group policies.


The login was all as my account which is a domain admin.

I just forgot to "clean up the posting" to protect the not-so innocent.

I do not even have a firewall installed. When I go to firewall (under adminstrative tools) it says it is not installed and I have to install ICA to get firewall to work on Windows 2003 R2 32bit.

rudy8347310 Sun, 09/07/2008 - 16:52

I encounter many issue with FM installation that reported similar error.

The issue had to do with the password you supplied. You need to specify a strong password for your DB Password.

Try following password: p4ss$#w0rd for a test, or you can change it to some other similar type.

hope this help. cheers

KevinBeaulieu Mon, 09/15/2008 - 11:29

I agree it is probably a password security issue. We ran into the same issue and used Pass#Word123 for the DB and it worked fine.

Thank you.

I used a 12 character password with mixed numbers and letters so I did not consider that an issue and have time / patience to test.

I tried setting MSI executions to not check security (registry change based on trying a postgresql standalone install with verbose logging) but that proved fruitless. I tried several attempts to track if it was a file creation perm issue vs a Service rights issues and was not able to pin anything down useful.

I ended up installing the Oracle Express DB :( Issue is now I have two DB engines (already installed MS SQL Express for VMWare and IBM System Director and don't care to rebuild all the data into new Oracle express)

One interesting thing I found during the CISCO FM install instructions is that it changes the TCP port number from 8080 default to 8012.

Why the random change? (only thing I can think of is to avoid stepping on other TCP listener applications on 8080 which would have failed the installer anyway.


This Discussion



Trending Topics: Storage Networking