Problem with CM after upgrading from 4.0.19 -> 4.1.1

Unanswered Question
Sep 2nd, 2008

I upgraded my Edge-WAE and Core-WAE from 4.0.19 to 4.1.1 and it was successful

However, after upgrading the CM, I got the message "service temporarily unavailable" when access the web page.

The console showed: "Stopping the service 'cms_cdm' because it is restarting too often."

When I quried the CMS service, I got:

CMS services information :

Service cms_httpd is running

Service cms_cdm is not running

What may be the problem?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Zach Seils Wed, 09/03/2008 - 01:09

Hi Brian,

Can you please verify that the Enterprise license is enabled on the CM? The command is 'sh lic'. If not, please enable it with the command 'license add Enterprise'.



jkeeffe Wed, 09/03/2008 - 12:20

I had the same problem and opened a TAC case. It seems that others are reporting the same trouble when using the CM GUI to upgrade the CM. For some reason it doesn't back up the database correctly and it gets corrupted, causing the cms_cdm to crash and then shut down.

I was told to roll back to 4.0.19, de-register all the non-CM devices using a forced de-register, then from the CM CLI, ftp the new 4.1.1 image over, reload, and re-register all the devices.

Luckily my setup was in the lab and not production. There may be a better/another way to do it, but that's the way I got it done.

Zach Seils Wed, 09/03/2008 - 12:34


Thanks for the post. The defect id is CSCsu12325. The release notes contain a workaround, or you can contact Cisco TAC for a script if you have already upgraded.



kmr Wed, 09/03/2008 - 18:23

Opened my TAC case for this defect and engineer said there is no script and essentially I'd have to rebuild or restore from a previous database backup if I failed to perform backup before upgrading. I was sent instructions for manually restoring database. One of the instructions is to perform 'no cms enable' on the CLI. My WASS CM says 'no debug' is the only 'no' command available.

UPDATE - 'no cms enable' or 'cms enable' is only available in 'configure terminal' mode

kmr Wed, 09/03/2008 - 19:01

I had a database dump file from 06-26-08. I restored that database, was prompted that the database was not the correct version and would be upgraded. Reloaded WAAS CM. cmd_httpd nor cms_cdm started. Resarted cms services 'cms enable' (see above), copied running-config to startup-config per instructions in CLI after starting cms service. Able to access the GUI on the WAAS CM.


This Discussion