Dead air when external caller rings in

Unanswered Question
Sep 4th, 2008

Hi all,

We have a strange issue where if an external caller rings in, and the internal phone goes off hook, the user hears dead air for a couple of seconds before the RTP stream is established. The external caller hears ring back and then the RTP stream cuts through in both directions.

This used to work and only in the last week has this happened. No changes made on the network or voice side at all during this time.

Setup is H.323 gateway with CM 4.2(3).

Phones running SCCP and are part of a hunt group where the external DDI is being mapped to a hunt pilot and makes all the phones on site ring.

This site has a local breakout with the CM being at a remote HO.

Call flow is "local" from local gateway to local IP phones.

Things we have tried:

Set clocking to external clock source.

Remove progress_ind setup enable 3 from the voip dial-peers.

Relevant snippets of config are attached.

Cheers,

H

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
hesham.moussa Thu, 09/25/2008 - 07:09

Just to close this chapter, looking at the SCCP traces, it seems that the CM was awaiting an ack from the phones varying in times lapsed before receipt from 500 msec to 1000 msec.

A look at the phones showed that they were configured for auto duplex and auto speed but the switchport was configured for auto duplex but fixed 100 Mbps speed. Even though negotiation on the phone was at 100 FDX, there were no errors, carrier transitions, etc, it seems that the fixed port speed was causing an issue which was proved by the fact that changing the switchport speed to auto fixed the delay issue.

Actions

This Discussion