MSDP peering issue when using VRF-lite

Unanswered Question
Sep 4th, 2008

Hi,

I am having an issue bringing up an MSDP peering between two directly connected 6504s ,each box has its own vrf and the msdp config resides within each vrf on the two boxes.

The MSDP peering addresses are reachable from both VRFs however the peerings stay down.

Does anyone have any comments on where my mistake is ;

some of the config and output is below ;

Router A config ;

interface Loopback200

description **** loopback for MSDP peering ****

ip vrf forwarding rtes-a

ip address 13.13.13.13 255.255.255.255

ip pim dense-mode

ip msdp vrf rtes-a peer 12.12.12.12 connect-source Loopback200

ip msdp vrf rtes-a cache-sa-state

ip route vrf rtes-a 12.12.12.12 255.255.255.255 xxx.75.32.2

interface Vlan218

ip vrf forwarding rtes-a

ip address xxx.75.32.1 255.255.255.224

ip pim state-refresh origination-interval 10

ip pim dense-mode

load-interval 30

Router A

sh ip msdp vrf rtes-a pe

MSDP Peer 12.12.12.12 (?), AS ?

Description:

Connection status:

State: Listen, Resets: 0, Connection source: Loopback200 (13.13.13.13)

Uptime(Downtime): 1d19h, Messages sent/received: 0/0

Output messages discarded: 0

Connection and counters cleared 1d19h ago

SA Filtering:

Input (S,G) filter: none, route-map: none

Input RP filter: none, route-map: none

Output (S,G) filter: none, route-map: none

Output RP filter: none, route-map: none

SA-Requests:

Input filter: none

Peer ttl threshold: 0

SAs learned from this peer: 0

Input queue size: 0, Output queue size: 0

-------------------------------

Router B

interface Loopback200

description **** Loopback for MSDP peering ****

ip vrf forwarding rtes-b

ip address 12.12.12.12 255.255.255.255

ip pim dense-mode

interface Vlan218

ip vrf forwarding rtes-b

ip address xxx.75.32.2 255.255.255.224

ip pim state-refresh origination-interval 10

ip pim dense-mode

load-interval 30

ip route vrf rtes-b 13.13.13.13 255.255.255.255 xxx.75.32.1

ip msdp vrf rtes-b peer 13.13.13.13 connect-source Loopback200

ip msdp vrf rtes-b cache-sa-state

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jonathanpc Thu, 09/04/2008 - 06:01

Hello Devang,

I am not able to enter this command (the IOS doesnt allow it) ;

6504-rtes-A(config)#ip msdp vrf rtes-a ?

cache-rejected-sa Store rejected SAs from all peers

cache-sa-state Configure this system to cache SA state

default-peer Default MSDP peer to accept SA messages from

description Peer specific description

filter-sa-request Filter SA-Requests from peer

keepalive Configure keepalive parameters for a peer

mesh-group Configure an MSDP mesh-group

originator-id Configure MSDP Originator ID

peer Configure an MSDP peer

redistribute Inject multicast route entries into MSDP

sa-filter Filter SA messages from peer

sa-limit Configure SA limit for a peer

shutdown Administratively shutdown MSDP peer

timer MSDP timer

ttl-threshold Configure TTL Threshold for MSDP Peer

6504-rtes-A(config)#

But I can give you ;

6504-rtes-A# show ip rpf vrf rtes-a 12.12.12.12

RPF information for ? (12.12.12.12)

RPF interface: Vlan218

RPF neighbor: ? (xxx.75.32.2)

RPF route/mask: 12.12.12.12/32

RPF type: unicast ()

RPF recursion count: 0

Doing distance-preferred lookups across tables

6504-rtes-A#

FYI the IOS I am running is 122-18.SXF13

My peering remains down on one side and in a listen state on the other.

I am puzzled by this because I thought that if MSDP has connectivity (which is does for me) then it should bring the peering up , unless I am mistaken.......

Regards

Jonathan

devang_etcom Thu, 09/04/2008 - 06:17

Hi,

can you please configure remote-as in msdp configuration:

ip msdp vrf rtes-b peer 13.13.13.13 connect-source Loopback200 remote-as

do this on both the router, as in your first post you can see there MSDP peer is not able to find the AS number of other peer so do that please.

regards

Devang Patel

jonathanpc Thu, 09/04/2008 - 06:35

Hi Devrang,

I have configured this but I still have the same problem. IMHO it doesnt need an AS number as both peers are within the same domain. But thanks anyway for the post. See the output below after the command was configured.

6504-rtes-b#sh ip msdp vrf rtes-b peer

MSDP Peer 13.13.13.13 (?), AS 100 (configured AS)

Description:

Connection status:

State: Down, Resets: 0, Connection source: Loopback200 (12.12.12.12)

Uptime(Downtime): 00:00:34, Messages sent/received: 0/0

Output messages discarded: 0

Connection and counters cleared 00:00:34 ago

Elapsed time since last message: 1w1d

Local Address of connection: 0.0.0.0

Local Port: 0, Remote Port: 0

sh ip msdp vrf rtes-a pe

MSDP Peer 12.12.12.12 (?), AS 100 (configured AS)

Description:

Connection status:

State: Listen, Resets: 0, Connection source: Loopback200 (13.13.13.13)

Uptime(Downtime): 00:01:24, Messages sent/received: 0/0

Output messages discarded: 0

Connection and counters cleared 00:01:24 ago

Elapsed time since last message: 1w2d

Local Address of connection: 0.0.0.0

Local Port: 639, Remote Port: 0

Harold Ritter Thu, 09/04/2008 - 08:38

Jonathan,

Try doing a "clear ip msdp vrf rtes-b peer 13.13.13.13" on router B and see if it gets rid of the issue.

Regards

jonathanpc Thu, 09/04/2008 - 08:43

Hi,

Thanks for your post. I have tried that command and it does not change the problem for me.

When I debug I see the peering going from a down to a listening state and then restarting again after 30 seconds and this repeats.

Something that is worth noting is that this issue does not occur when VRFs are involved (i.e when i do everything from the global table) however for this design i need vrfs.

Harold Ritter Thu, 09/04/2008 - 11:32

Hi Jonathan,

You are welcome. Could you try configuring the MSDP session on the physical interface address rather than the loopback interface IP address.

Regards

jonathanpc Sat, 09/06/2008 - 13:03

Hi,

I tried this also, but this does not solve the issue. I have now resolved the issue with the help of the Cisco TAC.

After exhaustive troubleshooting we ran out of logical options and decided to go for an IOS upgrade (from patch 13 to 14).

Its a bit of a weird one because I upgraded one of the boxes and the problem cleared (which is really weird considering the 2nd box was still on the old code). Meaning on that version of code there is compatibilty issue between two MSDP peers running the same version !.

Anyways the issue is now solved.

Thanks to all engineers who took the time to consider my issue.

devang_etcom Sat, 09/06/2008 - 14:20

Does it means IOS was the main issue?

Which ios you was using and which IOS do you have now?

regards

Devang Patel

Actions

This Discussion