2960-24TC-L GLC-GE-100FX duplex setting

Unanswered Question
Sep 4th, 2008
User Badges:

After installing a GLC-GE-100FX SFP module in a new switch running 12.2(44)SE, I notice that the Gi0/1 interface no longer allows changing duplex. I've not found any information online to describe this as a limitation. Can anyone explain this?


Here are the tranceiver properties:

Diagnostic Monitoring is not implemented.

Name : Gi0/1

Administrative Speed: auto

Administrative Duplex: auto

Administrative Auto-MDIX: on

Administrative Power Inline: N/A

Operational Speed: 100

Operational Duplex: half

Operational Auto-MDIX: on

Media Type: 100BaseFX SFP

Configured Media: auto-select

Active Media: sfp


But clipping the response from a help command in interface configuration mode, note duplex is not listed:

<snip>

description Show interface description

etherchannel Show interface etherchannel information

<snip>

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Marwan ALshawi Thu, 09/04/2008 - 06:21
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

Gbit and above already dose fulldplex !

triaton Thu, 09/04/2008 - 10:27
User Badges:

Yes, a Gigabit interface SHOULD be full, but this is negotiating to half duplex, thus the problem.


GigabitEthernet0/1 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 0022.0c03.xxxx (bia 0022.0c03.xxxx)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive not set

Half-duplex, 100Mb/s, link type is auto, media type is 100BaseFX SFP

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00


glen.grant Thu, 09/04/2008 - 12:46
User Badges:
  • Purple, 4500 points or more

It is a 100 meg fiber sfp. It may just be a code bug , never heard of a fiber being half duplex. It may just be a bug in how the switch is displaying the interface.

triaton Fri, 09/05/2008 - 04:34
User Badges:

I wish it were just a display issue. As noted, the other end of the link is a WS-X6324-100FX-MM card in a 6509. That iinterface when left auto negotiates 100-half, and when set to full duplex, shows a duplex mismatch, so the 100FX SFP is not negotiating full and I don't see a way for it to be set full duplex.

rduke Mon, 09/08/2008 - 05:54
User Badges:

Ran into this problem where I used to work. It is kind of goofy, but has to do with the media type being set to auto. Hard code the media type and it will work. From Cisco's documentation see below:


When the media type of a dual-purpose uplink port is auto-select, you cannot configure the speed and duplex settings. The interface auto-negotiates with its link partner. To configure the speed and duplex parameters, select the media type as either rj45 or sfp by using the media-type {rj45 | sfp} interface configuration command


FYI, some Cisco switches like the 24 port 100FX 3550 do not support 100/half duplex. They only support full and do not auto negotiate. You have to hard code the duplex.


Hope this helps,

Randy

Actions

This Discussion