Private VLANs and Trunk Ports

Unanswered Question
Sep 4th, 2008

I have an access device which for some reason requires each connection to have its own vlan. Behind this I have a Cisco Catalyst 3750G switch. I need to set up the switch so that multiple vlans on this access device can use the same subnet. I believe the way to do this is using private vlans, but as I have never used private vlans, I am not sure if I am doing this right.

Here's the config I've got so far:

vlan 55

name server-network

private-vlan primary

private-vlan association 501

private-vlan association 502

!

vlan 501

private-vlan community

!

vlan 502

private-vlan community

!

interface GigabitEthernet1/0/26

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 55,501,502

switchport mode trunk

switchport nonegotiate

!

vlan 55 works through the access device, but vlan 501 does not. All of the documentation for private vlans involves them assigned to individual access ports. Is there any reason this should not work?

Thanks,

-Ben

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
simontibbitts Thu, 09/04/2008 - 13:13

Hi Ben.

Try this config

vlan 55

private-vlan primary

vlan 501

private-vlan community

vlan 502

private-vlan community

!

interface FastEthernet0/0

switchport mode private-vlan host

switchport private-vlan host-association 55 501-502

If that doesn't work then you can just map the individual pVLANs under the vlan55 interface if you have one?

Simon

netopia Thu, 09/04/2008 - 13:45

How do you map the pVLANs under the vlan55 interface?

Ultimately I've got to have several bundles of vlans on different subnets as well as a management vlan a single interface.

simontibbitts Fri, 09/05/2008 - 02:21

Hi,

configuration is below

interface vlan55

private-vlan mapping 501-502

Simon

cisco_lad2004 Fri, 09/05/2008 - 20:00

u also need to ensure PVLAN are defined on both switches.

If u the Primary VLAN is defined on SW1 as L3 SVI, then you trunk your VLAN assiciation to SW2. then SW2 must have the PVLAN defined as they were in SW1.

HTH

Sam

Actions

This Discussion