Quick Config Check, on Cisco 1841

Unanswered Question
Sep 4th, 2008

Ok, so I'm migrating from an older Cisco 2501 router to a Cisco 1841 router and was hopeing you kind folks could glance at my config to make sure it's ok.

Old Config off 2501:

Building configuration...

Current configuration:

!

version 11.1

service slave-log

service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname SiteA2501

!

clock timezone EST -5

enable password 7

!

ip subnet-zero

ip domain-list **.ads

ip domain-list **.com

ip dhcp-server 10.1.1.50

ip dhcp-server 10.1.1.17

!

stun peer-name 10.4.0.1

stun protocol-group 9 basic

location Chapin, SC 29036

!

interface Loopback0

ip address 10.4.0.1 255.255.0.0

!

interface Ethernet0

ip address 10.1.1.110 255.255.0.0

ip helper-address 10.1.1.50

ip helper-address 10.1.1.17

no ip mroute-cache

no ip route-cache

!

interface Serial0

description SiteB point-to-point T1 CH 1-23

ip address 10.2.1.110 255.255.0.0

ip helper-address 10.1.1.50

ip helper-address 10.1.1.17

no ip mroute-cache

no ip route-cache

!

router rip

network 10.0.0.0

!

ip host SiteB 10.3.1.110

ip domain-name ellettnt.ads

ip name-server 10.1.1.26

ip name-server 10.1.1.27

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.1.120

ip route 10.3.0.0 255.255.0.0 10.2.1.111

ip route 10.9.0.0 255.255.0.0 10.1.1.120

ip route 10.20.0.0 255.255.0.0 10.1.1.120

ip route 10.30.0.0 255.255.0.0 10.1.1.120

ip http server

logging console critical

logging trap notifications

logging 10.1.1.40

!

snmp-server community public RO

snmp-server chassis-id 02112359-SiteA 2501

banner motd ^C

This is an official computer system of **. It is for authorized users only. Unauthorized users are prohibited. Users (authorized or unauthorized) have no explicit or implicit expectation of privacy. ^C

!

line con 0

password 7

login

line aux 0

transport input all

line vty 0 4

password 7

login

line vty 5 15

password 7

login

!

end

SiteA2501#sh int serial 0

Serial0 is up, line protocol is up

Hardware is HD64570

Description: SiteB point-to-point T1 CH 1-23

Internet address is 10.2.1.110/16

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 150/255

Encapsulation HDLC, loopback not set, keepalive set (10 sec)

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 2/75/71211 (size/max/drops); Total output drops: 80933

Queueing strategy: weighted fair

Output queue: 0/64/80933 (size/threshold/drops)

Conversations 0/13 (active/max active)

Reserved Conversations 0/0 (allocated/max allocated)

5 minute input rate 43000 bits/sec, 102 packets/sec

5 minute output rate 913000 bits/sec, 139 packets/sec

293312335 packets input, 1327698136 bytes, 41 no buffer

Received 3110006 broadcasts, 0 runts, 0 giants

10137 input errors, 817 CRC, 64 frame, 7 overrun, 574 ignored, 193 abort

339084900 packets output, 141211984 bytes, 0 underruns

0 output errors, 0 collisions, 99 interface resets

0 output buffer failures, 0 output buffers swapped out

30 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

SiteA2501#

I attached the new config due to character limitations.

For the most part I've carried everything over with the exception of a few things. Thanks for your help!

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
Edison Ortiz Thu, 09/04/2008 - 14:03

I recommend enabling mroute-cache and route-cache under the interfaces.

Process switching is very CPU intensive. Fast switching will dramatically improve router speed.

HTH,

__

Edison.

brenteverett Fri, 09/05/2008 - 04:49

I've been thinking about enabling it on the ethernet interface that connects it to our LAN however I'm a little nervous about enabling it on the T1 link (serial 0/0/0). It's been difficult finding information about that command / service but most of the config's I've found for it point to point T1's that have it turned off (on the other end is an Avaya device). I may just have to play with it and see what happens. Thanks for your reply.

Edison Ortiz Fri, 09/05/2008 - 05:09

but most of the config's I've found for it point to point T1's that have it turned off

It was a default behavior on previous IOS versions. Newer IOS versions and Best Practice recommendations have these setting turned on.

You want to maximize the speed on these routers and having process-switching enabled isn't going to help.

__

Edison.

brenteverett Fri, 09/05/2008 - 05:40

I noticed on the 1841 when I ran the "no ip route-cache and no ip mroute-cache" commands it also disabled CEF, I guess that's a default characteristic? I still don't know that I fully understand what the difference between the 3 routing methods are (CEF, fast switching, process switching). Most of the info I've found assumes you already know it. I need a "Dummies" guide to router switching :)

Edison Ortiz Fri, 09/05/2008 - 06:15

CEF is the most optimal option but you need to start by enabling fast-switching first.

__

Edison.

Actions

This Discussion