executeSQLUpdate Errors

Unanswered Question

All,


I hope someone can help me. I am trying to run a AXL/SOAP executeSQLUpdate to update the Display on Phones. I know that Informix doesn't support JOINS for Update statements, and I have tried several alternatives to get this working to no avail.


Here is the Update for my script:



<axlapi:executeSQLUpdate sequence="1" xmlns:axlapi="http://www.cisco.com/AXL/API/1.0" xmlns:axl="http://www.cisco.com/AXL/1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.cisco.com/AXL/API/1.0 axlsoap.xsd">

<sql> Update DeviceNumPlanMap SET DeviceNumPlanMap.display = \'test\' FROM NumPlan, DeviceNumPlanMap WHERE NumPlan.DNOrPattern = \'3301\' AND DeviceNumPlanMap.fknumplan = NumPlan.pkid </sql> </axlapi:executeSQLUpdate>';


The \'test\' and \'3301\' will eventually be replaced by variables that I extract from a CSV file.


I get a syntax error when I run the command.


Any help will be greatly appreciated.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion