Config EoMPLS problem

Unanswered Question
Sep 6th, 2008
User Badges:

dear all !


I've configred EoMPLS. I've got a problem with it: VC status always down but neighbour is up.


diagram is :

R3--(f1/1)--(f0/0)--R1--(E1/1)--(E1/1)--R2--(f0/0)--(f1/1)--R4


Configuration:

router 1:


mpls label protocol ldp

pseudowire-class abc

encapsulation mpls

!

interface Loopback0

ip address 1.1.1.1 255.255.255.0

!

interface FastEthernet0/0

ip address 172.16.0.1 255.255.255.0

duplex half

!

interface Ethernet1/1.10

encapsulation dot1Q 10

xconnect 2.2.2.2 10 pw-class abc

remote circuit id 10


mpls ldp router-id Loopback0 force


Router2:


mpls label protocol ldp

pseudowire-class abc

encapsulation mpls


interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface FastEthernet0/0

ip address 172.16.0.2 255.255.255.0

duplex half

!

interface Ethernet1/1.10

encapsulation dot1Q 10

xconnect 1.1.1.1 10 pw-class abc

remote circuit id 10

!

mpls ldp router-id Loopback0 force


show command

R1#show mpls l2transport vc 10 detail

Local interface: Et1/1.10 up, line protocol up, Eth VLAN 10 up

Destination address: 2.2.2.2, VC ID: 10, VC status: down

Output interface: unknown, imposed label stack {}

Create time: 00:01:06, last status change time: 00:01:02

Signaling protocol: LDP, peer 2.2.2.2:0 up

MPLS VC labels: local 18, remote 19

Group ID: local 0, remote 0

MTU: local 1500, remote 1500

Remote interface description:

Sequencing: receive disabled, send disabled

VC statistics:

packet totals: receive 0, send 0

byte totals: receive 0, send 0

packet drops: receive 0, seq error 0, send 389


please give me some advices !


thanks all.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
shivlu jain Sun, 09/07/2008 - 22:44
User Badges:
  • Silver, 250 points or more

You are using encapsulaton MPLS, it means your path should be mpls enabled. But from your config I am seeing one mistake the interface e1/1 are using as bakbone interfaces and mpls ip and mplas label protocol should be configured on the interfaces. But in your config these are missing.


regards

shivlu


pocketldq Sun, 09/07/2008 - 23:17
User Badges:

I'm terrible sorry shivlu. the exactly diagram like this:

R3--(f1/1)--(E1/1)--R1--(f0/0)--(f0/0)--R2--(E1/1)--(f1/1)--R4


thanks for your reply.

Giuseppe Larosa Mon, 09/08/2008 - 09:21
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Lai,


verify the correct signaling and forwarding for MPLS LSPs


R1: sh mpls forwarding 2.2.2.2


R2: sh mpls forwarding 1.1.1.1


R1:e1/1.10 must connect to the CE router and not to the backbone

R2:e1/1.10 must connect to the CE router and not to the backbone


this can work if there are L2 switches in the middle able to connect different subifs to different vlans.


these are L2 VPN access links not backbone links even if connected back to back.


Hope to help

Giuseppe


Actions

This Discussion