MGCP Registration issues with CUCM 6.1.2

Unanswered Question
Sep 7th, 2008
User Badges:

Hello All,


I am trying to register MGCP with Call Manager, though the configuration is straight forward and did many a times in the past as well, may be i am missing something or something else.


I have UCM 6.1.2 & 3825 as Router,


This is what i have configured on the GW.


<Host-Name>#show run | inc mgcp

ccm-manager fallback-mgcp

ccm-manager mgcp

mgcp

mgcp call-agent <CM-IP> service-type mgcp version 1.0

mgcp dtmf-relay voip codec all mode out-of-band

mgcp profile default


As the setup is new, the router came with domainname as yourdomain.com, however i have already removed this command.


this is what i see in show ccm-manager



ATVG-DC-1#show ccm-manager

MGCP Domain Name: <HostName>

Priority Status Host

============================================================

Primary Backup Ready X.X.X.X

First Backup Registering with CM X.X.X.X

Second Backup None


Current active Call Manager: None

Backhaul/Redundant link port: 2428

Failover Interval: 30 seconds

Keepalive Interval: 15 seconds

Last keepalive sent: 08:15:08 UTC Sep 7 2008 (elapsed time: 00:45:11)

Last MGCP traffic time: 09:00:02 UTC Sep 7 2008 (elapsed time: 00:00:16)

Last failover time: 09:00:02 UTC Sep 7 2008 from (10.1.102.10)

Last switchback time: 08:59:32 UTC Sep 7 2008 from (10.1.102.11)

Switchback mode: Graceful

MGCP Fallback mode: Enabled/ON

Last MGCP Fallback start time: 08:17:09 UTC Sep 7 2008

Last MGCP Fallback end time: None

MGCP Download Tones: Disabled

TFTP retry count to shut Ports: 2


FAX mode: cisco

Configuration Error History:


Debug MGCP events


On the call manager there i have given similar hostname of the GW in the <Domain Name field>


Is there something i need to do more to make mgcp registered with ccm?


Frnds please help!!





Thanks, ~Daljeet




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jaime Valencia Sun, 09/07/2008 - 06:53
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

you might be missing something in there, maybe the backhaul to CCM, doublecheck all the config


How to Configure MGCP with Digital PRI and Cisco CallManager

http://www.cisco.com/en/US/tech/tk1077/technologies_configuration_example09186a00801ad22f.shtml


MGCP Gateway Registration Failure with Cisco CallManager

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a00805a316c.shtml


HTH


java


if this helps, please rate

daljeetsingh1_2 Sun, 09/07/2008 - 06:56
User Badges:

Hello Java,


Thanks for replying to the post,


We arent using PRI, we are using FXO lines to PSTN, and which are yet to configure.


So you think i should configure FXO ports in CCM as well? to make mgcp registered to cucm?


Many Thanks, Daljeet

daljeetsingh1_2 Sun, 09/07/2008 - 06:54
User Badges:

Hi all,

I removed all the config from the GW and ccm, and tried to add again, i just issued two commands this time


###

ccm-manager config server 10.1.102.10

ccm-manager config

###

IP being my UCUM ip, and both my routers got the remaning config downloaded from the CM TFTP.


which is


ccm-manager redundant-host 10.1.102.11

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.1.102.10

ccm-manager config

!

mgcp

mgcp call-agent 10.1.102.10 service-type mgcp version 0.1

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!


and i am also attaching the cucm gw page as well. for you to verify if there is any host name conflict.


Still i am unable to see any change.


I am also pasting show ccm-manager output.


ATVG-DC-1#show ccm-manager

MGCP Domain Name: ATVG-DC-1

Priority Status Host

============================================================

Primary Registering with CM 10.1.102.10

First Backup Backup Ready 10.1.102.11

Second Backup None


Current active Call Manager: None

Backhaul/Redundant link port: 2428

Failover Interval: 30 seconds

Keepalive Interval: 15 seconds

Last keepalive sent: 08:15:08 UTC Sep 7 2008 (elapsed time: 03:15:56)

Last MGCP traffic time: 11:30:42 UTC Sep 7 2008 (elapsed time: 00:00:22)

Last failover time: 11:30:12 UTC Sep 7 2008 from (10.1.102.10)

Last switchback time: 11:30:42 UTC Sep 7 2008 from (10.1.102.11)

Switchback mode: Graceful

MGCP Fallback mode: Not Selected

Last MGCP Fallback start time: 08:17:09 UTC Sep 7 2008

Last MGCP Fallback end time: 09:36:30 UTC Sep 7 2008

MGCP Download Tones: Disabled

TFTP retry count to shut Ports: 2


Configuration Auto-Download Information

--More-- =======================================

Current version-id: 1220765318-62424f6c-162b-41ed-8cfe-2a88b68a057f

Last config-downloaded:00:00:00

Current state: Waiting for commands

Configuration Download statistics:

Download Attempted : 1

Download Successful : 1

Download Failed : 0

TFTP Download Failed : 0

Configuration Attempted : 1

Configuration Successful : 1

Configuration Failed(Parsing): 0

Configuration Failed(config) : 0

Last config download command: New Registration

FAX mode: cisco

Configuration Error History:

ATVG-DC-1#


Please look into this frnds.


Many Thanks



Tommer Catlin Sun, 09/07/2008 - 09:43
User Badges:
  • Green, 3000 points or more

Here is the other problem... if your router can not resolve the host name of your CUCM, then MGCP will not work. That is why I always go back to IP addresses for the CUCM server names (not actual hostnames, but you can change them to IP) When you do this, and restart the CUCM service, all MGCP registrations will be done through IP address. when your router calls into CUCM for MGCP information, it will respond back with IP MGCP information, not hostname MGCP information.


Make sure you have ccm-manager config in your router

do a no mgcp, then mgcp. This will force MGCP registration.


cheers,



daljeetsingh1_2 Sun, 09/07/2008 - 10:56
User Badges:

Thanks man, so you mean to say i should change ip address in the CUCM server instead of ATVG-DC-1 i should put ip address and do i need to change the hostname to ip addres of VG as well or will it work with the current hostname?


I would request if you can answer me for this as well, my life will be easy if it works by tomorrow :)


Thanks a ton!! Cheers

Tommer Catlin Sun, 09/07/2008 - 11:24
User Badges:
  • Green, 3000 points or more

You tell with MGCP what your Router/CUCM is using. If you put in the IP address of the CUCM in the Router, then save it, and the next time you do a Sho run, you see the CUCM has changed the Hostname instead of IP, the CUCM are using hostnames in the server names.


First question is, is this the first MGCP router on your network and CUCM? If it is, you are probably using hostnames in the CUCM server names (System, CUCM)


You have two choices:

change to IP addresses in the CUCM server names

OR

Make sure your MGCP router can resolve the hostname of the CUCM.

daljeetsingh1_2 Sun, 09/07/2008 - 23:01
User Badges:

Yes this is the green feild implementation and there are couple of cucm's and routers which needs to be configured.


Yes we were using hostnames in cucm under system cucm, but i changed those to IP's while i was troubleshooting this mgcp issue.


if i put ip host command in the GW's for resolving cucm's hostname's with ip's ..will it work ?



daljeetsingh1_2 Mon, 09/08/2008 - 05:49
User Badges:

Hello,


Problem got resolved after i configure all the endpoints in the CUCM and did no mgcp and mgcp.


Thanks guys for looking into it.


Cheers!!

Actions

This Discussion