Cat 4500 Redundancy

Unanswered Question
Sep 7th, 2008

All,

I have a 4507 R as core , but I would like to add another one as failover for the existing one. Besides the fact that they have to be the same , what is to be done exactly . Does anyone know step-by-step?

Thanks,

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
JORGE RODRIGUEZ Sun, 09/07/2008 - 11:24

Edison as usual your info is always Gold !!

Wanted to provide in some additional info in case OP wants to add a second 4507R chassis .

You can have dual collapse core

implementation, you have options of implementing HSRP and/or GLBP, but initially you can start looking at hsrp to provide active/standby architedture to start with and look into glbp later, with current 4507R

you can 802.1q trunk and etherchannel the two gigabit ports off the sup engine via fiber at each core and work on hsrp group between the two switchs svi interfaces.

etherchannel is not required but u should look into it.

If you have single sup you then do not have hsrp which then will make the implementation even esier utilizing your current SVI ip address as the hsrp address so that you do not have to chnage hosts with new defaul gateway.

Have a look here - high availability guides,

http://www.cisco.com/application/pdf/en/us/guest/netsol/ns431/c649/ccmigration_09186a008093b876.pdf

HSRP

http://www.cisco.com/en/US/tech/tk648/tk362/tk321/tsd_technology_support_sub-protocol_home.html

Configuring trunking and etherchanneling

http://www.cisco.com/en/US/products/hw/switches/ps4324/prod_configuration_examples_list.html

LAN switching configs

http://www.cisco.com/en/US/products/hw/switches/ps4324/prod_configuration_examples_list.html

this is example created from examples from abouve links

example for one vlan ( both primary/secondary cores A and B)

1- create l2 vlan 2, set vtp parameters

2- create 802.1q trunk (obtional)--> and etherchannel group

3- create L3 SVI interfaces e.i vlan2

4- assign ports vlan memebrship to access ports

COREswitchA

vlan database

vtp domain cisco

vtp server

vtp password cisco

vlan 2 name test

interface Port-channel 1

switchport trunk encapsulation dot1q

switchport mode dynamic desirable

no shutdown

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-4094

switchport mode dynamic desirable

channel-group 1 mode desirable

no shutdown

interface GigabitEthernet0/2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-4094

switchport mode dynamic desirable

channel-group 1 mode desirable

no shutdown

interface vlan2

ip address 10.0.0.1 255.255.255.0

standby 1 ip 10.0.0.3

standby 1 preempt

standby 1 priority 110

standby 1 authentication vlan2

standby 1 timers 5 15

no shutdown

and so on....

CoreswitchB

vlan database

vtp domain cisco

vtp server

vtp password cisco

vlan 2 name test

interface Port-channel 1

switchport trunk encapsulation dot1q

switchport mode dynamic desirable

no shutdown

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-4094

switchport mode dynamic desirable

channel-group 1 mode desirable

no shutdown

interface GigabitEthernet0/2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-4094

switchport mode dynamic desirable

channel-group 1 mode desirable

no shutdown

interface vlan2

ip address 10.0.0.2 255.255.255.0

standby 1 ip 10.0.0.3

standby 1 preempt

standby 1 authentication vlan2

standby 1 timers 5 15

no shutdown

etc..

Default gateway for internal hosts will be 10.0.0.3

and so on...

HTH

Jorge

Actions

This Discussion