EBGP Backup Route Not working Properly

Unanswered Question
Sep 7th, 2008
User Badges:

I have a Route with 2 serial links connected to the same ISP. One is a T3 and one is a T1. The T3 is the Primary Link and the T1 is the Secondary Link. I have floating static route configured as well as MED to set a higher metric for the Secondary T1 backup Link. I want the Secondary link to become active when ever the primary one is not available but, whe I bring down the Primary link both links go down. Please look at my config below to tell me what I have done wrong. Thanks.


hostname ISP

!

!

memory-size iomem 10

ip subnet-zero

!

!

no ip domain-lookup

!

ip cef

!

call rsvp-sync

!

!

!

interface FastEthernet0/0

ip address 200.200.100.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

ip address 200.200.1.1 255.255.255.0

no fair-queue

serial restart-delay 0

clockrate 56000

!

interface BRI0/0

no ip address

encapsulation hdlc

shutdown

!

interface Serial0/1

ip address 200.200.2.1 255.255.255.0

serial restart-delay 0

clockrate 56000

!

!

router bgp 100

no synchronization

bgp log-neighbor-changes

network 200.200.1.0

network 200.200.2.0

network 200.200.100.0

neighbor 200.200.1.2 remote-as 200

neighbor 200.200.2.2 remote-as 200

no auto-summary

!

ip classless

ip http server

!

!

!

dial-peer cor custom

!

!

line con 0

line aux 0

line vty 0 4

login

!

end



hostname SanJose1

!

!

memory-size iomem 10

ip subnet-zero

!

!

no ip domain-lookup

!

!

call rsvp-sync

cns event-service server

!

!

!

interface FastEthernet0/0

ip address 192.168.1.33 255.255.255.224

duplex auto

speed auto

!

interface Serial0/0

ip address 200.200.1.2 255.255.255.0

no ip mroute-cache

no fair-queue

!

interface BRI0/0

no ip address

encapsulation hdlc

shutdown

!

interface Serial0/1

ip address 200.200.2.2 255.255.255.0

!

router ospf 1

log-adjacency-changes

redistribute bgp 200 subnets

network 192.168.1.32 0.0.0.31 area 0

network 200.200.1.0 0.0.0.255 area 0

network 200.200.2.0 0.0.0.255 area 0

!

router bgp 200

no synchronization

bgp log-neighbor-changes

redistribute ospf 1

neighbor 200.200.1.1 remote-as 100

neighbor 200.200.2.1 remote-as 100

neighbor 200.200.2.1 route-map med_test out

!

ip classless

ip route 0.0.0.0 0.0.0.0 200.200.1.1

ip route 0.0.0.0 0.0.0.0 200.200.2.1 2

no ip http server

!

!

access-list 1 permit 200.200.100.0 0.0.0.255

route-map med_test permit 10

match ip address 1

set metric 200

!

!

!

dial-peer cor custom

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

login

!

end

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Sun, 09/07/2008 - 19:19
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Charlie


There are some things in your description that do not match up with the configs that you have posted. For example your description talks about a T3 and a T1. But the config that you post for ISP has 2 serial interfaces and both have this:

clockrate 56000

and those interfaces are obviously directly connected to your router (based on the IP addressing). So where is the T3 and the T1?


But the biggest problem is that you have 1 (and only 1) router in AS100 and 1 (and only 1) router in AS200. You are attempting to act as if there are 2 BGP neighbor relationships but there are not. There is a single BGP neighbor relationship (and having 2 neighbor statements will not change this).


My suggestion is that if you have these 2 routers and have 2 serial links and want some redundancy that you do these steps:

- configure loopback interfaces on each router.

- change the BGP config to peer to the loopback interface of the other router.

- configure the bgp multihop to facilitate peering to a not directly connected interface.

- configure a static route and a floating static route on each router to the other routers loopback interface (not a static default route).

- if you want the ISP router to advertise a default route (and if it does not have a default route in its BGP table already) then configure default-information-originate on the ISP router for your router.


That should get you what you want.


HTH


Rick


Giuseppe Larosa Mon, 09/08/2008 - 00:14
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Charlie,

some notes:

You can use two eBGP sessions on physical interfaces between two routers.

However, the router acting as the customer router should advertise some IP subnets it is owning.

There is no use to try to advertise prefix 200.200.100/24 it is a connected subnet of router isp:

interface FastEthernet0/0

ip address 200.200.100.1 255.255.255.0

duplex auto

speed auto

!

and isp it is advertising it:

router bgp 100

network 200.200.100.0


so the second eBGP session is useless it is trying to advertise a prefix with MED 200 that has been received by the neighbor !

the neighbor will not accept a prefix containing its own AS number (eBGP loop prevention rule).


Try to use a prefix on customer router Sanjose1 if you miss a free physical interface use a loopback:


int loop 100

ip address 200.200.150.0 255.255.255.0


advertise this in router bgp 200


router bgp 200

network 200.200.150.0


modify the route-map accordingly:


access-list 15 permit 200.200.150.0 0.0.0.255


route-map med_test permit 10

no match ip address 1

match ip address 15

set metric 200


this time on router ISP a sh ip bgp 200.200.150.0 should show two paths:

now when you shut the primary link the secondary should be usable and used


Hope to help

Giuseppe




Actions

This Discussion