CiscoUnity_TSP

Unanswered Question
Sep 8th, 2008
User Badges:

I have 130 users who have voice mail only. I set up them up with a cti route point and a voice mail box in unity. Since I created these I have been receiving the following warnings in the event log on Unity server(version4.0(4)SR1):

Cisco Unity-CM TSP device 19 (Cisco Unity port 16): An attempt to turn ON the message waiting indicator (MWI) for extension 9124 received no response from Cisco CallManager. The MWI ON Extension setting is 8970.

How do I turn off the MWI on these mailboxes.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Rob Huffman Mon, 09/08/2008 - 08:57
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Cindy,


Have you looked at;


Subscribers > Subscriber Template > Messages Page


Use MWI for Message Notification


Check this box to have Cisco Unity use the message waiting indicator (MWI) on the phone to alert

the subscriber of new voice messages. MWIs are not used to indicate new e-mail, fax, or return

receipt messages.Cisco Unity uses the number listed in the table to activate a message waiting

indicator (MWI). By default, the table contains an “X” to indicate the primary extension assigned

to a subscriber.


http://www.cisco.com/en/US/docs/voice_ip_comm/unity/402/administration/guide/ex/SAG_0170.html#wp1150009


To Enable MWIs


Cisco Unity can use the MWI on the phone to alert the subscriber to new voice messages. MWIs are not used to indicate the receipt of new e-mail, fax, or return receipt messages.



--------------------------------------------------------------------------------


Step 1 In the Cisco Unity Administrator, go to the appropriate Subscribers > Subscribers > Messages page.


Step 2 Confirm that the Use MWI for Message Notification check box is checked.


Step 3 Click the Add button located beneath the MWI Extensions table to add a row to the table. By default, one row in the table contains an "X" to indicate the primary extension assigned to a subscriber. If necessary, you can also modify this row.


Step 4 Enter the appropriate extension in the Extension field of the table. When entering characters in the MWI Extensions table, consider the following:


•Enter digits 0 through 9.


•Enter letters a through z (SIP integrations only).


•Do not use spaces, dashes, or parentheses.


•Enter , (comma) to insert a one-second pause.


•Enter # and * to correspond to the # and * keys on the phone.


•If the extension that you enter is intended to light an MWI on a phone that requires a different lamp code than the phone associated with the primary extension, verify that your phone system is programmed to support multiple lamp codes.


•MWIs are enabled for all rows in the table.


Step 5 Click the Save icon.


Step 6 Repeat Step 3 through Step 5 as necessary.


Step 7 To disable an MWI for an extension, do the following procedure.



--------------------------------------------------------------------------------


To Modify or Disable MWIs



--------------------------------------------------------------------------------


Step 1 In the Cisco Unity Administrator, go to the appropriate Subscribers > Subscribers > Messages page.


Step 2 Do either of the following:


•To modify an extension, change the extension in the MWI Extensions table as appropriate.


•To delete extensions, check the boxes next the rows that you want to delete in the MWI Extensions table, and then click the Delete button.


Step 3 Click the Save icon.


Step 4 Repeat Step 2 through Step 3 as necessary.



Just a thought, hope this helps!

Rob

Cynth.Fair Mon, 09/08/2008 - 13:45
User Badges:

I tried deleting the extensions but then when I run db walker I get the following error:


1438:(error) No MWI devices found for this subscriber. This is an unusual error to encounter on a production system.

You will need to delete and recreate this subscriber. If you cannot delete the subscriber in the SA directly you can remove this subscriber's row from the Subscriber table in the UnityDB database in SQL.

If you are uncomfortable editng SQL directly, please contact TAC. Be sure to get a backup of your system using DiRT before editing anything in SQL on your own.


Any other suggestions?


I guess I should just put up with the TSP warnings.




eschulz Wed, 09/10/2008 - 12:35
User Badges:
  • Cisco Employee,

To keep DbWalker happy, you should have at least one MWI extension for each subscriber. You can then disable MWI for a given subscriber by unchecking the "Use MWI for Message Notification" box.

-Eric

Cynth.Fair Wed, 09/10/2008 - 13:00
User Badges:

I have unchecked use MWI for message notificaion to disable MWI, pressed the save button but when it saves the check mark appears again.

tim.giles Fri, 09/12/2008 - 02:19
User Badges:
  • Silver, 250 points or more

Hi,


Are you disabling MWI just to get rid of the error messages of because you don't want the notifications any more??


You may want to check the intergration to make sure all the ports are configured for notification and dialout MWI (START > Programs > Unity > Manage Intergrations).


Sounds like a weird one if the settings aren't saved!?..have you tried re-starting the AvNotifierMgr service or re-starting Windows?






Please rate useful posts....

bobsairam Sun, 09/28/2008 - 04:17
User Badges:
  • Bronze, 100 points or more

Hi,


How many users affected ? .If it more than one try to sync MWI


1.check the intergration to make sure all the ports are configured for notification and dialout MWI (START > Programs > Unity > Manage Intergrations).


2.And below that you can see a option to rsync MWI .Resync manully and see how it is working


3.have you tried re-starting the AvNotifierMgr service or re-starting Windows?



*Please rate it*


espereir Fri, 09/26/2008 - 21:56
User Badges:
  • Silver, 250 points or more

Cindy,


Use the Bulk Edit Tool in order to disable the MWI Notifications for a set of subscribers, that tool is available under the Cisco Unity Tools Depot.


You might want to have a Subscriber Template for the CTI VMOnly users with MWI disabled, just copy the one that you have been using and disable MWI notifications as Rob suggested.


In addition, I am not quite sure but I believe that I have seen an issue disabling MWI on old 4.X releases, what Unity version are you using, perhaps, we are hitting a bug.


Please let us know how it goes!

Actions

This Discussion