Vlan shutdown in C3548 xl cisco switches

Unanswered Question

I have a C3548 xl series switch.I can create Vlan, but the vlan are shutdown mode. I have tried giving "no shut" & "vlan active" cmd.


***************************************

Current configuration:

!

interface VLAN2

ip address 192.168.32.1 255.255.255.0

no ip directed-broadcast

no ip route-cache

shutdown

end


interface VLAN3

ip address 192.168.33.1 255.255.255.0

no ip directed-broadcast

no ip route-cache

shutdown

end

*****************************************


& whenever I try to coonfigure a new vlan the prompt goes to sub-interface mode.


*****************************************

Switch(config)#interface vlan 3

Switch(config-subif)#


*****************************************

Kindly guide me.Any help would be highly appreciated.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Mon, 09/08/2008 - 07:52
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

The 3548Xl is a layer 2 switch only so you can only have one L3 vlan interface active at any one time. This interface is used to manage the switch.


If you are not using vlan 1 as the L3 interface then you need to ensure that at least one port is a member of the vlan for which you have created the L3 interface and that port is up or you must make sure that you have a trunk port up.


Jon

glen.grant Mon, 09/08/2008 - 10:15
User Badges:
  • Purple, 4500 points or more

Also that does not create a layer 2 vlan on the switch as Jon said it only creates a layer 3 SVI to manage the switch . To create the layer 2 vlan you have to go into the vlan database.

matej.polak Mon, 09/08/2008 - 11:58
User Badges:

As the guys already mentioned, you cannot use more than one L3 interface on a L2 switch.


If you want to use other than VLAN 1 you have to shutdown the VLAN1 first and then no shutdown on the new VLAN (VLAN 2).


You already noticed that you are in (config-subif) when entering other than VLAN 1. But guess why..

This behavior is only on the old ones like XL.



Make sure that you have some port assigned to that VLAN so you'll be able to connect to the switch.

Actions

This Discussion