Please help with this wierd 3750 switch SFP port problem

Unanswered Question
Sep 8th, 2008
User Badges:

I have a 3750 48-port 10/100 switch with 4 SFP ports. I'm using one SFP port to connect to a Gigabit server running only autosensing. The physical cabling between SFP and server is Cat.6 copper.


There are two very wierd problems happening right now. I like to hear your suggestions.


The 3750 is a Layer 2 switch only. It's connected to a Layer 3 switch via dot1q trunk. The Layer 3 switch has the similar connections to other Layer 2 3750 switches. All the Layer 3 vlan interfaces are configured on the Layer 3 switch for routing.


Right now, if a PC connected to a different 3750 Layer 2 switch wants to download files from the server, downloading is very slow. If the PC uploads files to the server. It's normal.

If the SFP port is set to speed 100 and duplex full, both downloading and uploading become normal. The server NIC is always autosensing.


What could be reasons for this?


Thanks a lot

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
MUHAMMAD SHAHEEN Tue, 09/09/2008 - 01:56
User Badges:
  • Silver, 250 points or more

Hi Gary,


if you want to fix the speed/duplex then you should fix it both ends (switchport and the server nic).


If you fix both sides to 100/full then the problem will go away. If you have SFP capable of 1000 and the server nic is also capable of running at 1000 then make you should change both ends to auto/auto and if will work fine too.


HTH

Shaheen

Actions

This Discussion