Ping fail. Cellular interface on c1861(HWIC-3G-GSM)

Unanswered Question

I am trying to ping from fa0/0(inside nat) through cellular interface(outside nat)

to but it fails.

As far as I see the debug output, LCP and PPP establishes successfully but fails to obtain IP address using IPCP.

And also generates TERMREQ which indicates ISP has terminated the call.

I tried changing the NAT configution but in vain.

Can anybody help me with this?


chat-script GSM "" "ATDT*99*3#" TIMEOUT 300 "CONNECT"


interface FastEthernet0/0

ip address

ip nat inside

ip virtual-reassembly

duplex auto

speed auto


interface Cellular0/2/0

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

load-interval 30

dialer in-band

dialer idle-timeout 10

dialer string GSM

dialer-group 1

async mode interactive

no peer neighbor-route

ppp authentication chap callin

ppp chap hostname DUMMY

ppp chap password 0 DUMMY

ppp pap sent-username DUMMY password 0 DUMMY

ppp ipcp dns request


ip route Cellular0/2/0



ip http server

no ip http secure-server

ip nat source list 10 interface Cellular0/2/0


access-list 1 permit any

access-list 10 permit

dialer-list 1 protocol ip list 1


line 0/2/0

script dialer GSM


modem InOut

no exec

transport input all

transport output all

autoselect during-login

autoselect ppp

<debug output>

Router#ping source fastEthernet 0/0 repeat 3 size 64

Type escape sequence to abort.

Sending 3, 64-byte ICMP Echos to, timeout is 2 seconds:

Packet sent with a source address of

*Sep 9 10:48:23.751: %LINK-3-UPDOWN: Interface Cellular0/2/0, changed state to up


*Sep 9 10:48:23.763: Ce0/2/0 PPP: Phase is FORWARDING, Attempting Forward

*Sep 9 10:48:23.763: Ce0/2/0 PPP: Phase is ESTABLISHING, Finish LCP

*Sep 9 10:48:23.763: Ce0/2/0 PPP: Phase is UP

*Sep 9 10:48:23.763: Ce0/2/0 IPCP: O CONFREQ [Cl.

Success rate is 0 percent (0/3)


*Sep 9 10:48:28.163: Ce0/2/0 PPP: Sending Acct Event[Down] id[6]

*Sep 9 10:48:28.163: Ce0/2/0 IPCP: State is Closed

*Sep 9 10:48:28.163: Ce0/2/0 PPP: Phase is TERMINATING

*Sep 9 10:48:28.163: Ce0/2/0 LCP: O TERMREQ [Open] id 11 len 4

*Sep 9 10:48:30.155: Ce0/2/0 LCP: Timeout: State TERMsent

*Sep 9 10:48:30.155: Ce0/2/0 LCP: O TERMREQ [TERMsent] id 12 len 4

*Sep 9 10:48:32.171: Ce0/2/0 LCP: Timeout: State TERMsent

*Sep 9 10:48:32.171: Ce0/2/0 LCP: State is Closed

*Sep 9 10:48:32.171: Ce0/2/0 PPP: Phase is DOWN

*Sep 9 10:48:32.175: hwic_cell_async_term_ppp: PPP terminated in 3340 ms, state 1

*Sep 9 10:48:34.171: %LINK-5-CHANGED: Interface Cellular0/2/0, changed state to reset

*Sep 9 10:48:39.227: %LINK-3-UPDOWN: Interface Cellular0/2/0, changed state to down


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
aghaznavi Mon, 09/15/2008 - 12:39

1 After you create a modem data profile cellular profile create command and configuring DDR on the cellular interface, send a ping from the router to a host across the wireless network.

2 If the ping fails, debug the failure by using the following debug and show commands:

debug chat

debug dialer

debug ppp negotiation

show cellular all

show interface cellular

show running-config

show ip route

jefferybjohnson Fri, 07/03/2009 - 14:46

Did you ever find an solution to this problem, our company is using the verizon HWIC as well and our disconnects are coming from Verizon (Jul 20 19:15:31 UTC: Ce0/0/0 LCP: I TERMREQ [Open] id 68 len 4 ) this is the debug message the router is receiving that causes the Cell interface to disconnect. it looks like the solution is to nat and ACL the Cell interface. Did you have any luck??




This Discussion