cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
891
Views
30
Helpful
6
Replies

QoS on Cisco 3550

atrey2712
Level 1
Level 1

I have to configure QoS on 3550 to identify and tag voice traffic with real-time priority (dscp 46) and rest of the traffic with default priority (dscp 0), so just need two queues, one with 90% bandwidth for non-voice traffic and 10% for voice traffic. This is what I have so far...

mls qos

!

class-map match-any voipclass

match access-group 190

class-map match-any dataclass

match access-group 193

!

policy-map voipolicy

class voipclass

set ip dscp 46

class dataclass

set ip dscp 0

!

... ... ...

interface FastEthernet0/1

switchport mode dynamic desirable

wrr-queue bandwidth 90 10 1 1

wrr-queue cos-map 1 0 1 2 3

wrr-queue cos-map 2 4 5 6 7

spanning-tree portfast

service-policy input voipolicy

!

interface FastEthernet0/2

switchport mode dynamic desirable

wrr-queue bandwidth 90 10 1 1

wrr-queue cos-map 1 0 1 2 3

wrr-queue cos-map 2 4 5 6 7

spanning-tree portfast

service-policy input voipolicy

... ... ...

... ... ...

access-list 190 permit udp any range 16384 32768 any range 16384 32768

access-list 190 permit udp any range 10000 11281 any range 10000 11281

access-list 190 permit udp any range 49300 49309 any eq 1719

access-list 190 permit udp any eq 1719 any range 49300 49309

access-list 190 permit tcp any range 61440 61444 any eq 1720

access-list 190 permit tcp any eq 1720 any range 61440 61444

access-list 193 deny udp any range 16384 32768 any range 16384 32768

access-list 193 deny udp any range 10000 11281 any range 10000 11281

access-list 193 deny udp any range 49300 49309 any eq 1719

access-list 193 deny udp any eq 1719 any range 49300 49309

access-list 193 deny tcp any range 61440 61444 any eq 1720

access-list 193 deny tcp any eq 1720 any range 61440 61444

access-list 193 permit ip any any

Unfortunately this config is not matching and taggin any traffic. I am not an expert on QoS, just going through the documentation and trying different options. I was able to configure cisco 2651XM, 3725 and 7204-VXR successfully with the help of Cisco documentation.

6 Replies 6

satish_zanjurne
Level 4
Level 4

Hi,

1.As IP phone by default marks traffic with priority 5, you need map this to DSCP , so you need to define COS to DSCP map

mls qos map cos-dscp 0 8 16 26 32 46 48 56

2.Under interface where IP phone is connected

put 5/voice traffic in seprate queue, here queue 4.Also make that queue as strict priority queue.Also assign more bandwidth to this queue.

int fa0/1

switchport voice vlan xxxx

mls qos trust cos

wrr-queue cos-map 1 0 1

wrr-queue cos-map 2 2 3

wrr-queue cos-map 3 4 6 7

wrr-queue cos-map 4 5

wrr-queue bandwidth 10 10 10 70

priority-queue out

HTH..rate if helpful...

hi Satish

u were right about priority queue but

the thing is once u enable it with command

priority-queue out u dont need to give it bandwidth just put it as 1

according to cisco press

"with the Catalyst 3550 is that queue 4's WRR weight is set to 1 (indicating that it does not participate in the WRR scheduler because it is configured as a strict-priority queue) instead of 0 (as is the case on the Catalyst 2950)"

thank you

if helpful Rate

Marwan ALshawi
VIP Alumni
VIP Alumni

first of all

if u just trust the COS on the interface connected to the cisco IP phone the voice traffic will be marked by the phone as cos 5 and call signaling as cos 3

but first u need to ajust defualt cos-to-DSCP maping on the switch as the following:

(config)#mls qos map cos-dscp 0 8 16 24 32 46 48 56

this Maps CoS 5 to EF

in cat 3550 Q4 is the riority queue serviced first

mls qos

interface FastEthernet0/1

switchport mode dynamic desirable

wrr-queue bandwidth 90 10 1 1

wrr-queue cos-map 1 0 1 2 3

wrr-queue cos-map 4 4 5 6 7

priority-queue out

spanning-tree portfast

mls qos trust device cisco-phone

or

interface FastEthernet0/1

switchport mode dynamic desirable

wrr-queue bandwidth 90 10 1 1

wrr-queue cos-map 1 0 1 2 3

wrr-queue cos-map 4 4 5 6 7

priority-queue out

spanning-tree portfast

service-policy input voipolicy

ip access-list extended voice

permit udp any any range 16384 32767

permit tcp any any range 2000 2002

class-map match-any voipclass

match access-group voice

policy-map voipolicy

class voipclass

set ip dscp 46

u dont need a class for marking traffic to cos or DSCP 0 because all traffic by default will be set to 0 as it is the defualt marking unless u do the trust and the device mark its traffic like in first interface config above

good luck

if helpful Rate

@marwanshawi: fyi... We're testing Voice solution for three vendors - Cisco, Avaya and Nortel however we are not buying IP phones at all. We are going to utilize existing digital phone sets tied into our IP PBX and PBX will get connected to voice gateway from three vendors. Port ranges I have in ACLs are for all three vendors. Anyway that basically rules out using "trust device cisco-phone". You suggested "wrr-queue cos-map 4 4 5 6 7" instead of "wrr-queue cos-map 2 4 5 6 7" but mapping the cos 4 5 6 7 to qid 4 wouldn't require wrr-queue bandwidth be "90 1 1 10" instead of "90 10 1 1"?

hi Atrey

noe when u mention about those vendors it make more senes :)

ok about the queues

as i mentioned above when u enable priority queue on the interface

on the 3550 queue 4 is the PQ so it will not be part of the bandiwidth or limit assignment so it will be serviced first then other queues will start so u can for example assign 100% of the bandwidth to 3 queues and the 4th one put 1 because it will not be part of this prosses in cat2950 put 0 in cat4500 the PQ is Q 3

according to cisco press

"with the Catalyst 3550 is that queue 4's WRR weight is set to 1 (indicating that it does not participate in the WRR scheduler because it is configured as a strict-priority queue) instead of 0 (as is the case on the Catalyst 2950)"

i think this make senes now :)

thanks for rating and good luck

@marwanshawi: so that means just enabling strict priority queuing would put queue 4 in higher priority? but how about any kind of bandwidth allocation? I just want to make sure that non-voice traffic does not bleed into voice queue.

strict priority queuing does make lot of sense now and would make my life easier. thanks.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: