installing device updates cucm 6.1

Unanswered Question
Sep 9th, 2008

Hi i'm wondering how you go about getting a device update onto the appliance. I've followed a guide which said to use upgrade from within the OS management service on the appliance, but i'm having difficultly in getting it to work, particularly with regard to the correct syntax. The appliances used are remote from me. I messed about with the tftp installation facility, and found that if I used that I appeared to be able to install the cop.sgn file to the TFTP directory, certainly when I look for the file from the cli I see it, I then though I could run the upgrade using this path on the local appliance but no joy. How does everyone else get the files onto the appliance for installation?

thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (3 ratings)
Loading.
testeven Tue, 09/09/2008 - 09:53

Hi!

I guess you tried this link:

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/cucos/5_0_4/iptpch7.html#wp1017196

If you are trying to install a Device Pack or an ES, SR you need to use the Install/Upgrade from the OS admin. When you install an ES or SR you should do a switch versions first and reboot the server. DO NOT restart/switch versions on any server until you have

installed the new version on all the servers, you need to start on the PUB or primary server and once this is done you can upload/install this upgrade on the SUBs, once all servers have the same new version on the 'inactive' partition then you will have to choose Settings > Version; then, click Switch Version on the PUB, once the PUB comes back with the

new version then you can do the same on the SUBs.

The ">Upload TFTP Server File" will only upload the files to the TFTP folder on the CUCM.

HTH

Tere.

rob.huffman Tue, 09/09/2008 - 16:59

Hi Grant,

Just to build on the great info from Tere (+5 points for this Tere :)

This is done via OS Admin>Software Upgrades

Software Upgrades

--------------------------------------------------------------------------------

You can use the Software Upgrades options to perform the following types of installations and upgrades:

•Install/Upgrade-Use this option to upgrade the application software, install Cisco Unified Communications Manager Locale Installers and dial plans, and upload and install device packs, phone firmware loads, and other COP files.

•TFTP File Management-Use this option to upload various device files for use by the phones to the TFTP server. The TFTP server files that you can upload include custom phone rings, callback tones, and phone backgrounds.

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/cucos/6_0_1/cucos/iptpch7.html

When using Cisco Unified CallManager Release 5.0 or later

For Cisco Unified CallManager 5.0, you must do all software installations and upgrades by using the Software Upgrades menu options. The system can upload and process only software that Cisco Systems approved. You cannot install or use third-party or Windows-based software applications that you may have been using with a previous version of Cisco Unified CallManager with Cisco Unified CallManager 5.0.

Using your web browser, login to the Cisco IPT Platform Administration web page

Under the Software Upgrades menu, select Install/Upgrade.

Fill in the appropriate values in the Software Location section for the file you downloaded above, and click Next.

In the Available Software drop-down box, select the file you downloaded above, and click Next.

After validating the MD5 has the correct value, click Next.

In the Warning box, verify you have selected the correct firmware, then click Install.

Check that you received a Success message.

Here is an example of a Device Pak install;

Here is the ReadMe;

Cisco Unified CallManager Device Package 6.0.1 (2134-2)

Release Notes

http://www.cisco.com/web/software/282074299/18327/cmterm-devicepack-6_0_1_2134-2_readme.html

Installation Instructions

Note: Cisco recommends that you apply this Device Package during a maintenance window.

Procedure

NOTE: Apply this patch to all of your Cisco Unified CallManager servers, beginning with the publisher server and TFTP server.

When applying this Device Package to enable new device support, a cluster-wide reboot is required for those devices to register successfully. A clusterwide reboot IS NOT required when running to update existing firmware/support.

For Cisco Unified CallManager 6.0, you must do all software installations and upgrades by using the Software Upgrades menu options.

Using your web browser, login to the Cisco Unified Communications Operating System Administration web page

Under the Software Upgrades menu, select Install/Upgrade.

Fill in the appropriate values in the Software Location section for the file you downloaded above, and click Next.

In the Available Software drop-down box, select the file you downloaded above, and click Next.

After validating the MD5 has the correct value, click Next.

In the Warning box, verify you have selected the correct firmware, then click Install.

Check that you received a Success message.

Note: In order to change the loads manually, you do NOT need to reinstall this Device Package. The new files will be present in the TFTP folder. Go to CCMAdmin->Device->Device Settings->Device Defaults and manually change the name of the load file (for specific device(s)) to the new load and click UPDATE.

Note: If you are rebooting the cluster, the next step does not need to be done.

The Cisco TFTP service now must be stopped and restarted on the TFTP server, then reset the affected devices for them to upgrade to the new load.

Hope this helps!

Rob

reidg Wed, 09/10/2008 - 02:56

Rob, detailled reply as usual, thanks.

Unfortunately still no joy, i've tried running a sftp server app on my pc, but as soon as I try adding the Directory details to the Software Location fields, I get Error on page before I go any further.

reidg Wed, 09/10/2008 - 07:08

update on this;

can get the process to work when doing it with one of the subscribers, however as soon as I enter anything in the Directory field in the upgrade window, I get error on page.

Will reboot the pub to see if that makes any difference.

Clifford McGlamry Wed, 09/17/2008 - 13:24

Unfortunately, it isn't working at all for me.

I'm attempting to load the signed device pack files on a 6.1(2) system, and the system keeps telling me that no valid upgrade files are found. I can tell from the SFTPd logs that it's hitting the directory. I've validated the MD5 hash. But CCM will NOT pick up the device pack file.

Rebooted the pub, and still doesn't work.

Sub won't take it without the PUB being upgraded first.

I'm stuck. Any ideas anyone?

reidg Mon, 09/22/2008 - 02:29

Hi, have you tried just adding an individual device firmware, to see if that works?

The process we had to go through was:

download appropraite file.

run an ftp server on your local pc "we used a free one from CoreFTP.com mini-sftp-server version 1.1."

Then from the cucm software upgrade page select remote filesystem, and enter the appropraite info, pertaining to the files location.

Keep a note of the MD5 check sum, as you'll need it, when selecting the file.

Once you have the file on the server you might need to restart the tftp services.

Our problem was that the web server application seemed to have a problem, but once we reloaded the pub it was fine, and the process was reasonably smooth.

regards

Actions

This Discussion