CUPC Presence Information and IM

Unanswered Question
Sep 9th, 2008
User Badges:

We installed CUCM 6.1 a while back and now I'm playing with CUPS 6.0 and CUPC 1.2 but I'm having some issues that I just can't seem to get past.


My troubleshooter on CUPS is all green and my server health in CUPC is all green but I get no presence information, nor am I able to IM. I have the LDAP search working and my CTI call control works fine but my status on all CUPC clients is OFFLINE...


I have made several global changes in CUPS and have tried making changes to the SIP trunk more times than I would like to count but still no love.


I am using RTMT to watch the Cisco UP SIP Proxy and I have enabled detailed logging on the CUPC client and reported that way as well, but I don't really know what to look for.


I'm sure this is something simple, but it's about to make me shoot myself in the face!! Any ideas????


Thanks for any help....

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Graham Robinson Tue, 09/09/2008 - 22:34
User Badges:

Scott,


Have you checked the following;


1. The subscribe calling search spaces on the devices and/or DNs are configured?


2. That the devices and/or DNs are either in the same presence group or that you have configured the visibilities between the presence groups?


3. That the users are mapped to the devices (or the extension mobility profiles) correctly.


- GGR

3.

Scott_Barns_2 Wed, 09/10/2008 - 07:34
User Badges:

Thank you for the quick reply.


Yes, I have checked the subscribe CSS on the phone, the CUPC client and the SIP trunk. They are all correct.


The devices are in the same Presence group, AND I have the "Allow Subscription" checked between the standard presence group and the new presence group so that should be fine.


All users are mapped to their corresponding DN's.


Some more pertinent information on my situation...


We are running CUCMBE so I cannot synch LDAP with CUCM. I do have it synched with CUPC and the user names are the same in CUCM as they appear in LDAP. The LDAP is AD.


The Presence server is running in VMware which will not allow me to apply the license obtained from Cisco, but does automatically supply two Presence Engine and two Proxy Server licenses when it detects the VMware server. I could see this being an issue, but on the other hand, even though this wouldn't be supported by TAC it is a common way to set up a lab.




I'm wondering where the CUPC client is authenticated... the login server is the CUPS server, but even though it's logged into that server the client status has never shown anything other than offline.


Call control is good... even the IMAP integration with Unity Connection is working. It seems that I have everything working with the exception of the Instant Messaging and the Presence information.


My thinking is that it's somewhere in the SIP trunk, but I have tried so many things differently and still no success. I can see subscribe and publish messages in RTMT looking at the SIP Proxy but don't know where to look for issues there.


I can't be the only one having trouble with a VMware lab can I? Someone must have faced the same challenges here....


Thanks for the help!


Scott

Graham Robinson Wed, 09/10/2008 - 12:44
User Badges:

I'm running CUCM7 and CUPS7 in the lab but am in offiste meetings all day. Let me check out the SIP trunks, enterprise params (around the DNS and BLFs, etc) and service parameters.


Question - Does the presence on the handset work (BLF in the directory, etc)?

Scott_Barns_2 Wed, 09/10/2008 - 13:58
User Badges:

I am getting device state from CUCM at the phone/AC. When I have the Attendant Console open I get the line state for each user.

Graham Robinson Wed, 09/10/2008 - 20:39
User Badges:

Still @ meetings, however it sounds like your def on the right track.


One thing I remember that stumped me when I did a CUPS 1.0 install a while back was ensuring the Security ACLs in CUPS (inbound and outbound) were set to permit. By default CUPS has a deny for incoming and outgoing traffic.


Apart from that, DNS sounds like the most obvious issue but I'll check it out when I get back to the office.


Scott_Barns_2 Fri, 09/12/2008 - 17:03
User Badges:

OK, I made a couple of changes that fixed this issue. I wanted to post the resolution so others in my situation might benefit from my hours of frustration....


First, and most importantly, I changed the proxy domain field (System > Service Parameters > Presence server > Cisco UP SIP Proxy) from the suggested value of domain.local to the FQDN of my Presence server... so CUPS-6. NOT CUPS-6.domain.local... just the server name. Then after having the non-returnable IM issue, I changed that name to cups-6 and resolved all IM issues.


Second, I changed from using the SIP PUBLISH model between the CUCM 6.1 and the CUPS 6.0 and went with a standard SIP trunk. I need to go back and investigate this one because the PUBLISH model should work so I'll play with it until it does. In the mean time, I have a working system!


Graham, thanks for working with me on this. The support of the NetPro community with it's massive knowledge base is very important as we move into the fully converged IP world. It's impossible to be an expert on every subject yet sometimes our customers and/or employers expect it. After all, it's all just IT right? ;)

Actions

This Discussion