Permission Denied Upgrading IOS

Unanswered Question
Sep 10th, 2008

I received a replacement switch from Cisco. There wasn't enough memory to hold the current IOS and the IOS I needed to upgrade to so I deleted the old IOS from flash. At the end of the TFTP of the new IOS it errored out saying the file was corrupted. I tried this with different IOS versions with no luck. The switch locked up and I had to reboot it. Of course there is no IOS so it booted to ROMON mode. When I try to use xmodem I get the error message "permission denied."

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
atrey2712 Wed, 09/10/2008 - 05:08

have you tried using a .tar file instead of .bin for the IOS code on that switch with xmodem? copy xmodem: flash:cxxxx.xxx.xxx.tar

gdrandles Wed, 09/10/2008 - 05:30

The switch is a 3550 so I downloaded c3550-ipservicesk9-tar.122-44.SE2.tar to try with xmodem with the same results. If I use "copy xmodem: flash:c3550-ipservicesk9-tar.122-44.SE2.tar" it prompts me with the "Begin the Xmodem or Xmodem-1K transfer now..." I then click send file, choose the tar file, select xmodem as the protocol. The xmodem file transfer window opens and I get 1 packet and then the retries count from 1 to 9 when it times out with an error "error limit exceeded." The prompt on the CLI is I/O error. I have tried from 2 different computers and different roll over cables.

Mark Yeates Wed, 09/10/2008 - 06:02

Try deleting existing images in rommon before the transfer. It seems that the flash is full and will not accept a transfer. Also .tar files are not bootable images. TAR files are meant to be extracted into flash because there are multiple files and the IOS in .bin format is included in the tar file. You will need to copy an IOS that has the .bin format.

Mark Yeates Wed, 09/10/2008 - 06:05

Is this a 3550 or 3550XL? There is a big difference between the two.

atrey2712 Wed, 09/10/2008 - 10:34

if that is the case then try erasing flash and get a binary file for the Catalyst 3550 code and try the same thing.

Actions

This Discussion