Routing question (net diag attached)

Answered Question
Sep 10th, 2008

Hi,

I have a small lab setup, below (see network diag) I have the settings of my 2 Cisco 2610 routers connected via serial and a switch and LAN where my laptop is (192.168.2.14). I was wondering how I can get "router 0" to be able to ping 10.10.10.1 on "router 1". If I add "ip route 10.10.10.0 255.255.255.0 172.30.1.2" to "router 0" then all works and I'm sure if I add "ip route 192.168.2.0 255.255.255.0 172.30.1.1" to router 1 then that will make that subnet able to be pinged from "router 1".

I will add another 1 or 2 routers later, but is there away I don't have to add these static routes and get these 2 routers to advertise (no neighbours) there subnets/interface IP ranges? If I add router 2 and 3 on from router how can I make R0, R1,R2 and R3 talk to each other?

LAN is 192.168.2.0/24

RO-2610 (Router 0 Cisco 2610)

interface Ethernet0/0

ip address 192.168.2.225 255.255.255.0

full-duplex

!

interface Serial0/0

ip address 172.30.1.1 255.255.255.0

!

interface Serial0/1

no ip address

shutdown

R1-2610 (Router 1 Cisco 2610)

interface Ethernet0/0

ip address 10.10.10.1 255.255.255.0

full-duplex

!

interface Serial0/0

ip address 172.30.1.2 255.255.255.0

!

interface Serial0/1

no ip address

shutdown

Attachment: 
I have this problem too.
0 votes
Correct Answer by Giuseppe Larosa about 8 years 2 months ago

Hello Andy,

>> do I just add the Ethernet range and not the serial?

it is the opposite to have the routers talk RIP between them and use it to build the routing table they need to share a common segment so if it is the serial you need the network command for net 172.30.0.0

router rip

net 172.30.0.0

network 10.0.0.0

no auto-sum

and

router rip

net 172.30.0.0

network 192.168.2.0

no auto-summary

otherwise the RIP messages are not exchanged among them.

I would suggest to read

http://www.cisco.com/en/US/tech/tk365/technologies_white_paper09186a008014f8a9.shtml

Hope to help

Giuseppe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Giuseppe Larosa Wed, 09/10/2008 - 10:11

Hello Andy,

static routes are local info that is not advertised to other routers.

So if you are going to add other routers you have two options:

a) use only static routers you need to manually configure all the needed static routes on all routers

b) use a dynamic routing protocol

let's suppose both R2 and R3 are in the lan with R1.

R1 can advertise its own connected interfaces and can be configured to redistribute static routes on the routing protocols

R0 will need a default static route pointing to R1

ip route 0.0.0.0 0.0.0.0 172.30.1.2

Hope to help

Giuseppe

whiteford Wed, 09/10/2008 - 10:31

Thanks.

So to make all routers dynamic I will need to add "ip route 0.0.0.0 0.0.0.0 " to all routers?

What is this dynamic updating known as?

Giuseppe Larosa Wed, 09/10/2008 - 13:30

hello Andy,

the ip route 0.0.0.0 0.0.0.0 is a static default route but don't do this on all routers because it can lead to problems!

when I was meaning dynamic I was pointing to routing protocols

example

router rip

network 10.0.0.0

network 192.168.x.0

no auto-summary

or

router eigrp 100

network 10.0.0.0

network 192.168.x.0

no auto-summary

you do this on all routers including network commands for the subnets in other major networks (class A,B,C) and this is dynamic routing and you don't need any static route in your lab

Sorry I didn't provide an example in previous post.

I hope now it is more clear

Hope to help

Giuseppe

whiteford Wed, 09/10/2008 - 13:45

Thanks Giuseppe, you are very helpful and I will rate this.

I noticed your example above, are these based on my network and which router 0 or 1? As I noticed you used 10.0.0.0 where I have been using 10.10.10.x/24 and you use 192.168.x.0 and I used 192.168.2.0/24? I just want to make sure I'm not missing something, if I have the example for R0 and R1 then I'm done and own you a big thanks.

Giuseppe Larosa Thu, 09/11/2008 - 03:02

Hello Andy,

in router rip only major network are accepted so 10.10.10.0 will be seen as 10.0.0.0.

about the x is because while writing I couldn't see your first post with the exact value.

I've forgotten to edit the post to replace the x with 2.

However, in the forum we use letters as variables placeholder for any value, it is a common use but I should have advised of this convention.

Hope to help

Giuseppe

whiteford Thu, 09/11/2008 - 06:41

Giuseppe,

Thanks again, I'm going to try the rip now using your example.

On each router itself do I just add the IP ranges on the router itself, so on router 0 if E0/0 is 192.168.2.x/24 and S0/0 is 172.30.1.x/24 do I just add the Ethernet range and not the serial?

Do I add for Router 0:

router rip

network 192.168.2.0

no auto-summary

and Router 1:

router rip

network 10.0.0.0

no auto-summary

Correct Answer
Giuseppe Larosa Thu, 09/11/2008 - 08:04

Hello Andy,

>> do I just add the Ethernet range and not the serial?

it is the opposite to have the routers talk RIP between them and use it to build the routing table they need to share a common segment so if it is the serial you need the network command for net 172.30.0.0

router rip

net 172.30.0.0

network 10.0.0.0

no auto-sum

and

router rip

net 172.30.0.0

network 192.168.2.0

no auto-summary

otherwise the RIP messages are not exchanged among them.

I would suggest to read

http://www.cisco.com/en/US/tech/tk365/technologies_white_paper09186a008014f8a9.shtml

Hope to help

Giuseppe

whiteford Thu, 09/11/2008 - 08:47

Does tis look ok to you:

Router 0#sh ip protocols

Routing Protocol is "rip"

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Sending updates every 30 seconds, next due in 15 seconds

Invalid after 180 seconds, hold down 180, flushed after 240

Redistributing: rip

Default version control: send version 1, receive any version

Interface Send Recv Triggered RIP Key-chain

Serial0/0 1 1 2

Automatic network summarization is not in effect

Maximum path: 4

Routing for Networks:

10.0.0.0

172.30.0.0

Routing Information Sources:

Gateway Distance Last Update

Distance: (default is 120)

Router 1#sh ip protocols

Routing Protocol is "rip"

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Sending updates every 30 seconds, next due in 22 seconds

Invalid after 180 seconds, hold down 180, flushed after 240

Redistributing: rip

Default version control: send version 1, receive any version

Interface Send Recv Triggered RIP Key-chain

Serial0/0 1 1 2

Automatic network summarization is not in effect

Maximum path: 4

Routing for Networks:

172.30.0.0

192.168.2.0

Routing Information Sources:

Gateway Distance Last Update

Distance: (default is 120)

Giuseppe Larosa Thu, 09/11/2008 - 08:53

Hello Andy,

I don't like the empty gateway field in both routers.

To have a more consistent scenario auto-summary is a RIPV2 feature enable version 2:

router rip

version 2

on both routers

then clear ip route *

sh ip route rip must show on each router the lan IP subnet of the other one this is the target of this exercise.

Hope to help

Giuseppe

whiteford Thu, 09/11/2008 - 12:30

Think That did it! Here is part of the configs, hope they look ok:

Router 0:

interface Ethernet0/0

ip address 192.168.2.225 255.255.255.0

full-duplex

!

interface Serial0/0

ip address 172.30.1.1 255.255.255.0

encapsulation ppp

!

interface Serial0/1

no ip address

shutdown

!

router rip

version 2

network 172.30.0.0

network 192.168.2.0

#sh ip route rip

R 10.0.0.0/8 [120/1] via 172.30.1.2, 00:00:20, Serial0/0

#sh ip route

Gateway of last resort is not set

172.30.0.0/16 is variably subnetted, 2 subnets, 2 masks

C 172.30.1.2/32 is directly connected, Serial0/0

C 172.30.1.0/24 is directly connected, Serial0/0

R 10.0.0.0/8 [120/1] via 172.30.1.2, 00:00:24, Serial0/0

C 192.168.2.0/24 is directly connected, Ethernet0/0

Router 1:

interface Ethernet0/0

ip address 10.10.10.1 255.255.255.0

full-duplex

!

interface Serial0/0

ip address 172.30.1.2 255.255.255.0

encapsulation ppp

no fair-queue

clock rate 64000

!

interface Serial0/1

no ip address

shutdown

!

router rip

version 2

network 10.0.0.0

network 172.30.0.0

#sh ip route rip

R 192.168.2.0/24 [120/1] via 172.30.1.1, 00:00:24, Serial0/0

sh ip route

Gateway of last resort is not set

172.30.0.0/16 is variably subnetted, 2 subnets, 2 masks

C 172.30.1.1/32 is directly connected, Serial0/0

C 172.30.1.0/24 is directly connected, Serial0/0

10.0.0.0/24 is subnetted, 1 subnets

C 10.10.10.0 is directly connected, Ethernet0/0

R 192.168.2.0/24 [120/1] via 172.30.1.1, 00:00:26, Serial0/0

Giuseppe Larosa Thu, 09/11/2008 - 12:37

Hello Andy,

I did the exercise more difficult then what I wanted (actually I did a mistake mixing RIPv2 auto-summary feature with RIPv1 that is the default) but you now should be able to ping from lan to lan.

Welcome to the dynamic routing world !

Best Regards

Giuseppe

Actions

This Discussion