Configuring Sticky TCP Connections on ACE

Unanswered Question
Sep 10th, 2008
User Badges:

I have 6 ACE configuration guides/case study example configurations and all have a slightly different way of configuring sticky connections in the admin context. What is the right way to configure it?

Thanks!

Matt

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Syed Iftekhar Ahmed Wed, 09/10/2008 - 18:16
User Badges:
  • Blue, 1500 points or more

Here is the 7th config :)

You didnt mention which persistence method you are interested in. Following is an example for source ip based stickiness




rserver host APP1-SERVER1

ip address 10.10.10.101

inservice


rserver host APP1-SERVER2

ip address 10.10.10.102

inservice



serverfarm host APP1-SFARM

probe http80

predictor leastconn

failaction purge

rserver APP1-SERVER1

inservice

rserver APP1-SERVER 2

inservice



Sticky ip-netmask 255.255.255.255 address source APP1-STICKY-GP

timeout 60

replicate sticky

server-farm APP1-SFARM



class-map match-any APP1-VIP-CLASS

description class-map for APP1

match virtual-address 192.168.0.100 tcp eq 80




policy-map type loadbalance first-match APP1-POLICY

class class-default

sticky-serverfarm APP1-STICKY-GP



policy-map multi-match VIPS

class APP1-VIP-CLASS

loadbalance vip inservice

loadbalance policy APP1-POLICY

loadbalance vip icmp-reply




interface vlan 20

ip address 192.168.0.1 255.255.255.0

access-group input anyone

access-group output anyone

service-policy input VIPS

no shutdown


HTH

Syed Iftekhar Ahmed


Actions

This Discussion