ata186 FAX

Answered Question
Sep 11th, 2008

Hi. I have CCM6, ATA 186 and 2821 with fxo port.

My ata configuration

S/W Version 3.02.03(051201A)

AudioMode - 0x00350035

ConnectMode - 0x90000400

My router configuration.

!

voice service voip

h323

modem passthrough nse codec g711ulaw

!

!

dial-peer voice 2000 voip

preference 2

destination-pattern ...

modem passthrough nse codec g711ulaw redundancy

session target ipv4:10.10.18.5

dtmf-relay h245-alphanumeric

fax rate disable

no vad

!

I can call from fax connecting to ata186.

I want send fax, but fax not work, in handset i heard remote fax ready for connect.

You can help my, with my problem.

I have this problem too.
0 votes
Correct Answer by stuart.pannell about 8 years 2 months ago

Have you checked the speed that the fax is set to, it should be at a maximum baud of 14400

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (3 ratings)
Loading.
Correct Answer
stuart.pannell Thu, 09/11/2008 - 13:52

Have you checked the speed that the fax is set to, it should be at a maximum baud of 14400

sun_sazanov Tue, 09/16/2008 - 02:59

Hi. I change "fax rate disable" on "fax rate 14400", but it not resolve problem. You can help me?

MARTIN STREULE Thu, 09/18/2008 - 22:45

This does not work with ATA:

modem passthrough nse codec g711ulaw redundancy

"redundancy" sends all the RTp packets twice.

Try this:

dial-peer voice

modem passthrough nse codec g711ulaw

fax rate disable

Fax rate 14400 is only good for fax relay which the ATA does not support.

Cheers,

Martin

MARTIN STREULE Thu, 09/18/2008 - 22:49

Hi,

With the following config you should have less - not "no" fax problems:

Configure the following on the gateway (H323)

dial-peer voice xxx voip

! ....the usual peer stuff

modem passthrough nse codec g711ulaw

fax rate disable

...

On the ISDN interface configure this:

isdn reject vod ! (solves some magic fax problems)

You can check the modem passthrough operation: (look for "MODEMPASS")

Code: Select all

Router#show call active voice brief

1493 : 369 1303346870ms.1 +5330 pid:1999 Answer 5551234 active

dur 00:00:10 tx:525/88044 rx:526/83692

Tele 0/2/0 (369) [0/2/0.1] tx:8790/8790/0ms g711ulaw noise:-38 acom:6 i/0:-11/-79 dBm

1493 : 370 1303346880ms.1 +5310 pid:2000 Originate 5554321 active

dur 00:00:10 tx:439/1236069320 rx:525/83844

IP 10.50.3.155:16384 SRTP: off rtt:0ms pl:6120/0ms lost:0/0/0 delay:75/65/75ms g711ulaw TextRelay: off

media inactive detected:n media contrl rcvd:n/a timestamp:n/a

long duration call detected:n long duration call duration:n/a timestamp:n/a

MODEMPASS nse buf:0/0 loss 0% 0/0 last 1225s dur:0/0s

Change the following in the fax machine:

- Change the fax speed to 9600 bps (the recommended speed for "no issues").

- Set the protocol to G3.

- Disable the Error Correcting Mode (ECM) BTW: this also disables SG3. If the fax has no "disable SG3" then disable ECM - does the same.

If the above actions do not work, consider an FXS interface. :-)

Configure the following on the ATA-186 if you still have problems:

AudioMode 0x00150015 (1st 0015= port1; 2nd 0015=port2)

Good luck - and lets hope that the VG20x will be released soon...

/Martin

Actions

This Discussion