Which routing protocol?

Unanswered Question
Sep 11th, 2008

Hi,

I have a couple of 2600 series routers and in my lab I want to test a routing protocol setup so I don't have to add static routes.

What is the best one to test with? I know there is the common RIP, but is this best?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
satish_zanjurne Thu, 09/11/2008 - 07:00

It depends on what you want to achieve out of the setup.

1.You can try each protocol one by one , backing up the earlier configuration for each protocol.

2.You will understand, how exactly routing protocols works !!!

3.Finally , still it is a lab, the weired problem which occurs on production networks in real world , will not be simulated.

4.But you will learn a lot out of it.

5.Finally CCIE Lab is also a lab!!!

ALL the Best!!!

Richard Burts Thu, 09/11/2008 - 07:30

The original post asks which is the best one to test with. Since there are multiple ways to measure what is best, we need some clarification before we can provide really good answers. If best means supported on the widest variety of platforms, then RIP (by default RIP version 1) is probably the best. But if best means supporting VLSM then RIPv1 is no longer the best. You might use RIPv2 which does support VLSM. But for support of VLSM you might be better off with OSPF or with EIGRP.

If best means supported by multiple vendors then the best protocol is probably OSPF. OSPF is based on open standards, is supported by many vendors, and does support VLSM. But it can be a bit complex to set up (with backbone areas, non-backbone areas, stub areas, restrictions on where you can summarize, etc). And if best means easy to configure then perhaps OSPF is not the choice and you might want to think about EIGRP. EIGRP is supported on almost all Cisco gear, is easy to configure, does support VLSM, and does allow you to summarize at any point in the network where you want.

So if you can clarify what you meant by best, then we can help you to pick the best protocol.

HTH

Rick

whiteford Thu, 09/11/2008 - 13:03

Hi,

I managed to just get RIP v2 working between 2 routers.

OSPF and EIGRP interest me now, however I'm struggling to find a simple example of each IP Protocal for 2 routers, unless you can example it? sorry to ask, but it's probably like a second language to you :)

Richard Burts Thu, 09/11/2008 - 13:17

Yes, when you have done it for a while it does become much easier. So for some simple examples lets assume 2 routers with the following interfaces and addresses:

R1

Fa0/0 172.16.1.1 255.255.255.0

Ser1/1 192.168.1.1 255.255.255.0

R2

Fa0/0 172.17.2.2 255.255.255.0

Ser1/1 192.168.1.2 255.255.255.0

To configure OSPF with R1 Fa0/0 in area 1 and serial in area 0 and with R2 Fa0/0 in area 2 and serial in area 0 this would work:

R1

router ospf 1

network 172.16.1.0 0.0.0.255 area 1

network 192.168.1.0 0.0.0.255 area 0

R2

router ospf 2

network 172.17.2.0 0.0.0.255 area 2

network 192.168 1.0 0.0.0.255 area 0

And for EIGRP

R1

router eigrp 1

network 172.16.0.0

network 192.168.1.0

R2

router eigrp 1

network 172.17.0.0

network 192.168.1.0

HTH

Rick

jamesgonzo Thu, 09/11/2008 - 23:17

Rick thanks for this, so much help. I see many labs guys use routers with WIC-2T cards. My routers (2620's) only have WIC-1T with an ethernet port, I have yet to learn why I need 2 serials :S, but can I simply use a DTC-DCE crossover cable to each router to save money?

At the moment I have been using the ethernet port to setup RIPv2, and I suppose it's no different if I user ethernet ports or serial for theroy...

Hi James

In a home lab, if it is just to avoid having to enter static routes on all routers, then it really does not matter which routing protocol you use.

Be aware that if you are routing subbets then you will need to use RIPv2.

Personally for my home lab, unless I am going through RIP labs I would always run OSPF or maybe EIGRP, as these are the LAN routing protocols I would see mostly with work.

HTH

Best Regards,

Michael

paul.matthews Thu, 09/11/2008 - 23:11

What do you fancy starting with? You don't tell us anything about your addressing, so we cannot comment on that. If you want simple configuration, with fewer caveats, I would start with RIP V2.

If your aim is to learn about routing protocols, start with RIP V1, then change it to V2 and look for what is different, then try IGRP/EIGRP, and then OSPF. Then try a couple at the same time and see what happens!

Actions

This Discussion