VPN between ASA and router

Unanswered Question
Sep 11th, 2008
User Badges:

Hello,


I had a working vpn configuration between a local and a remote router; the remote router is not under my administration.

Now I moved the vpn termination from my side to an ASA5540 software version 8.0(3). The tunnel is up but there is no reachability. The "show crypto ipsec sa" on the ASA shows encapsulated packets but NO decapsulated packets! Routing and no_nat are properly configured.


Any idea?


Many thanks.



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
georges.merhej Thu, 09/11/2008 - 11:21
User Badges:

Hi Joe,


They didn't change anything from there side! It was fully working exactly before I've migrated to the ASA!

Have you used the packet tracer feature in the ASDM?


I would run a packet from source to destination using your adsm and see if it is fully going out as planned.


I suspect a stale xlate on the firewall, perhaps the other side that didnt change is hearing a different source that it wants?


Another option to consider is since the other side is using IOS (right?) they may be using GRE/IPSEC of some type and need to re-config to work with the ASA.


-Joe

georges.merhej Thu, 09/11/2008 - 11:54
User Badges:

I've attached the old router configuration.


Using the packet tracer:

inside-outside -> everything is fine

outside-inside -> ipsec-spoof detected! it's a normal behavior right?



Attachment: 
francisco_1 Thu, 09/11/2008 - 12:12
User Badges:
  • Gold, 750 points or more

For traffic that enters the security appliance through a VPN tunnel and is then decrypted, the sysopt connection permit-vpn command in global configuration mode to allow the traffic to bypass interface access lists.


can you do some debug on the ASA.


debug crypto ipsec and debug crypto isakmp and send us the output


francisco

francisco_1 Thu, 09/11/2008 - 12:18
User Badges:
  • Gold, 750 points or more

try "no crypto isakmp nat-traversal"



francisco

francisco_1 Thu, 09/11/2008 - 12:27
User Badges:
  • Gold, 750 points or more

try from global"clear crypto ipsec sa" and "clear xlate". Also get them to do the same on the other side.


do a continous ping to the other side

going back over the notes your provided;


see the issue now?


DE-DC-INT-FW01# show crypto ipsec sa


Crypto map tag: IPSec-VPN, seq num: 40, local addr: 213.184.187.98




and now...


interface GigabitEthernet0/1

description $ES_WAN$$FW_OUTSIDE$

bandwidth 1000

ip address 213.184.187.98 255.255.255.240

ip access-group 101 in

ip verify unicast reverse-path

no ip redirects

no ip unreachables

no ip proxy-arp

ip virtual-reassembly

ip route-cache flow

ip tcp adjust-mss 1200

crypto map VPN


so, my question,


what is in front of the asa, and does it arp reach the ASA to get to 213.184.187.98?


where does the ASA has this addr config'd?


-Joe

georges.merhej Thu, 09/11/2008 - 12:33
User Badges:

the 213.184.187.98 was the ip address of the outside interface of the router, now the router is removed and the same ip is configured on the outside interface of the ASA.

francisco_1 Thu, 09/11/2008 - 12:36
User Badges:
  • Gold, 750 points or more

I noticed you dont have crypto isakmp enable [Inside Interface]

georges.merhej Thu, 09/11/2008 - 12:37
User Badges:

the vpn is terminated on the outside interface, so there is no need for isakmp on the inside, right?


francisco_1 Thu, 09/11/2008 - 12:47
User Badges:
  • Gold, 750 points or more

mmm yeah. i checked on my lab ASA 5520 on a working tunnel and i have it enable on the inside/outside as well.

georges.merhej Thu, 09/11/2008 - 12:54
User Badges:

I have tunnels configured and the same interface and working perfectly

francisco_1 Thu, 09/11/2008 - 12:57
User Badges:
  • Gold, 750 points or more

you mean you have other tunnels active on the ASA?



georges.merhej Thu, 09/11/2008 - 13:01
User Badges:

yeah other tunnels are active! the 213 is the outside ip of the asa; the conncetion is like this now:


asa (public 213.184.187.98) -> sw (layer2)-> router (private IP with no security controls)->ISP

francisco_1 Thu, 09/11/2008 - 13:03
User Badges:
  • Gold, 750 points or more

joe's got a point here. according to the logs

DPD (Dead Peer Discovery).

IPSec has a mechanism for a peer to send a notification to its peer when it is deleting a SA. This notification is sent via IKE. However, there can be situations in which this notification never gets sent. A usual reason for this is that the peer goes dead too abruptly e.g. system crash, unplugging the Ethernet cable, etc. Due to such events, one peer could keep sending data to the dead peer and it results in data loss. For this, a Dead Peer Discovery (DPD) mechanism is used. Make sure nothing is blocking the ipsec traffic between your ASA/Router





georges.merhej Thu, 09/11/2008 - 13:08
User Badges:

There's only a layer 2 switch between the router and the ASA and no security controls are configured on the router:(

my next educated guess;


turn off nat-t on the ASA the other side may not support it, not have it configured or UDP 4500 may filtered somewhere in the path


no crypto isakmp nat-traversal


now clear ipsec sa on the sa, and continue testing... send interesting traffic to bring the tunnel back up

francisco_1 Thu, 09/11/2008 - 22:45
User Badges:
  • Gold, 750 points or more

Georges/Joseph, Is this sorted?


Please let me know


Francisco

georges.merhej Fri, 09/12/2008 - 00:43
User Badges:

Guys,


It's resolved by editing the crypto/no_nat access-lists to match only host by host! It's really weird that it was not working with subnet to subnet access-list.

jimmyc_2 Wed, 05/29/2013 - 07:33
User Badges:

Thanks for posting the solution.  Any future info on this?   jimmyc

Actions

This Discussion