7937 stuck at "Configuring CM List"

Unanswered Question
Sep 11th, 2008
User Badges:

Hello all,


I recently purchased a 7937 Conference Phone to set up in our boardroom. It came yesterday so I unboxed it and plugged it in. The phone will boot up, but has been stuck at "Configuring CM List" since I plugged it in.


I left it over night because I had other things to take care of, then came in this morning to see if anything had changed. Still stuck in the same place. If I reset the phone, it starts up, says Configuring VLAN, then right back to Configuring CM List.


The phone is defined in our Callmanager and we have enough DLUs to support it. I have also checked the network configuration on the phone and that is all just fine, but the phone will not ever finish booting.


Other phones work just fine plugged into the same switch port.


I also installed the latest firmware for the 7937 onto the CM to see if that would fix the problem. The phone downloaded and installed the firmware, but then went right back to Configuring CM List.


Any thoughts? I can go into Settings and ping the callmanager, so I know they can communicate. I am stumped. The callmanager version is 6.1(a) if that makes a difference.


Thanks for any thoughts,


Chris

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Tommer Catlin Thu, 09/11/2008 - 14:02
User Badges:
  • Green, 3000 points or more

Restart the TFTP service. Maybe its hung and not delivering everything to the phone that is needed.

olighec Thu, 09/11/2008 - 14:14
User Badges:

Already tried that I'm afraid. I had to restart the TFTP service to get the phone to see the new firmware.




Tommer Catlin Thu, 09/11/2008 - 14:19
User Badges:
  • Green, 3000 points or more

Sure it's in the right device pool with the CUCM servers listed?

olighec Thu, 09/11/2008 - 14:25
User Badges:

Yup. Same device pool as all servers and phones at this location. It is very odd. I can ping the callmanager from the phone by IP address as well as by name. I can ping the phone from the callmanager as well.


I did read something about multicasting causing 7937s to unregister, but I don't believe that is an issue here as the phone never registered in the first place.


I do know that it is communicating with the CM server, as when you go into services and look at Callmanager 1, it shows the DNS name of our callmanager server. I also know that if I delete the registration from the callmanager server, the 7937 immediately goes to "File not Found." When I recreate the registration and reset the phone, it is back to "Configuring CM List"

olighec Thu, 09/11/2008 - 14:26
User Badges:

I forgot to mention -- we are not doing any multicasting to my knowledge, and the only other devices on this VLAN are two other phones that are working fine. They are 7940s.

Tommer Catlin Thu, 09/11/2008 - 14:27
User Badges:
  • Green, 3000 points or more

If you had another 7937 out of the box doing the same thing, I would say bounce the CUCM service on each server, because its probably not the phone.


Another test,, duh... just thought of it. Put a static IP address on the phone and also the CUCM server in the list and see if it connects. if it still does not, it's for sure the servers not letting it.

olighec Thu, 09/11/2008 - 14:37
User Badges:

Unfortunately, we only have one 7937 so I can't see if another would have the same problem. But I will try assigning a static IP and static callmanager address in the phone and see what happens.


Thanks,


Chris

ahochau_2 Thu, 09/11/2008 - 14:48
User Badges:

You verified all the settings are there for the network? Sounds like you are missing your TFTP server.

olighec Thu, 09/11/2008 - 15:04
User Badges:

Tried statically assigning the network settings -- same result.


Yup, checked the TFTP server -- 10.100.209.2 (the IP address of the callmanager).


Very odd...

Tommer Catlin Thu, 09/11/2008 - 15:10
User Badges:
  • Green, 3000 points or more

are you out of licenses? have you checked the license count?


You would probably get errors in licensing.


I would pull up RTMT and check the log files on CUCM to see what it is saying about that SEP phone not registering. It must not like something??

olighec Thu, 09/11/2008 - 15:45
User Badges:

Licenses are fine. We have 29 DLUs remaining. I also checked the logs in RTMT, but can't find anything out of the ordinary. The only thing that references the 7937 are normal DHCP messages.

jcain1031 Wed, 09/17/2008 - 13:42
User Badges:

I just received some 7937's for a new implementation (first time working with the 7937) and I am seeing the same thing you are.


I saw the correct voice VLAN (20) being displayed on the phone, but the phone was receiving an IP address on the data VLAN (50). I changed the switchport "access vlan" configuration to VLAN 50 and did away with the "voice vlan" configuration and it correctly registered with CCM.

olighec Wed, 09/17/2008 - 13:56
User Badges:

Interesting...


So when the phone was on vlan 20 it wouldn't work, but when it was on vlan 50 it did?


I don't actually use "switchport voice vlan xx" in my switch config. All of my phones are on a separate VLAN from the data devices, but I just use "switchport access vlan xx" to configure the ports.


I did notice that my 7937 was getting an IP address from the correct VLAN, but that was the access VLAN. No voie VLAN was configured on the port. Is that wrong?



jcain1031 Wed, 09/17/2008 - 14:02
User Badges:

Sorry about that, it should have read as follows...


"I saw the correct voice VLAN (20) being displayed on the phone, but the phone was receiving an IP address on the data VLAN (50). I changed the switchport "access vlan" configuration to VLAN 20 and did away with the "voice vlan" configuration and it correctly registered with CCM."


Basically, when the port was configured to support voice and data it would not work, when it was configured strictly as an access port on the voice VLAN it worked. The following is a sample of the switchport configuration before and after. Note that all other IP phones are using the "BEFORE" configuration.


**BEFORE**

interface FastEthernet3/0/42

switchport access vlan 50

switchport mode access

switchport voice vlan 20

switchport port-security maximum 2

switchport port-security

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust device cisco-phone

mls qos trust cos

macro description cisco-phone

auto qos voip cisco-phone

spanning-tree portfast

spanning-tree bpduguard enable


**AFTER**

interface FastEthernet3/0/42

switchport access vlan 20

switchport mode access

switchport port-security maximum 2

switchport port-security

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust device cisco-phone

mls qos trust cos

macro description cisco-phone

auto qos voip cisco-phone

spanning-tree portfast

spanning-tree bpduguard enable


olighec Wed, 09/17/2008 - 14:05
User Badges:

Thanks for the clarification. Unfortunately, my switchport config already looks like your after state but no dice on the phone.


What version of CM are you running? I am planning on upgrading to 6.2 to correct an extension mobility bug and I was hoping that upgrading would also solve this problem. I hate to stab in the dark like that, but I am running out of things to check.

olighec Wed, 09/17/2008 - 14:21
User Badges:

Thanks! 6.1.2 is what I meant -- not 6.2. I am running 6.1 so I will just upgrade and see what happens.



olighec Wed, 09/17/2008 - 14:02
User Badges:

I checked one other thing: I can access the corporate directory as well if I press the directories key while the phone is "configuring CM List", but the phone will not register. I've left it for 4 days before with no change.


I am going to start monkeying with the switch configuration. Should I be using switchport voice vlan xx instead of switchport access vlan xx in the config?

cjoseph23 Wed, 09/17/2008 - 15:14
User Badges:

I was having the same issue with a new 7937 phone we were trying to install. When I had the switchport access vlan on my data VLAN i was getting an IP address on the data VLAN and the phone would never register. I changed the switchport mode to trunk and the native vlan to my voice vlan and the phone registered. I also tried putting the switchport access in my voice vlan and that worked as well.

dbasterash@cco-... Thu, 09/18/2008 - 09:55
User Badges:

I am having the same issues with the 7937 and the voice and date vlans. My problem is that the phone is not always in the conference room and sometimes the need to plug a laptop in is there. If i take the data vlan off the switchport this is impossible. Has anyone found a solution?

robwu2006 Mon, 06/20/2011 - 15:24
User Badges:

This may sound a bit silly, but I managed to fix this issue by reboot the ccm version 4, as we did not do this after apply the new devices patch.


Also just a tip, if you sniff the phone/conference phone's packets, it will be fairly obvious which end is having the issue (assuming all the switchport settings have been setup etc).


hope this helps,


Cheers

robwu2006 Thu, 05/05/2011 - 07:46
User Badges:

I know this post was a while ago, but i'm having the exact same problem, cisco 7937

stuck between "Registering" and "Configuring CM List".




I have got my switchport setup as a normal switchport with the voice vlan as its access vlan as per below:



interface FastEthernet0/12
no ip address
switchport
switchport access vlan 222
switchport mode access
spanning-tree portfast


Any ideas?


Cheers,


Rob

dlcharville Mon, 06/20/2011 - 11:33
User Badges:

Rob/All - Upgrade the 7937 software to whatever the lastest compatible version with CUCM/CME.  Although I don't know the bug ID It appears to be bug with 1.2(1) 7937 software.  Ran into this with one of our customers running CUCM 6.1(1) which contains stocked 1.2(1) software for 7937.  Upgraded just 7937 software to 1.4(3) and problem fixed.


HTH,

Dan

Brian Lavallee Mon, 06/20/2011 - 17:07
User Badges:

Because you're not getting 'registration rejected' it looks like networking. It can't reach the CUCM.


I'd recommend setting the switch port for 'only voice' to test.


switchport access vlan V

switchport voice vlan V


Make sure the device received the CM (tftp address) in the menu or web page. Using option 66 or 150?


Force all static settings.


If you reach registration rejected...


Check the device name in the menu or web page. Should match the barcode, but check anyway.


Verify the device name in the CUCM matches. I always use a barcode reader to avoid typos. Or you can copy and paste into CUCM from the 7937 web interface.





Sent from Cisco Technical Support iPhone App

Miguel Angel Es... Mon, 09/09/2013 - 15:17
User Badges:

You must try to look the MAC address across your Switch (show cdp neighbor detail) and verify that is the same that you have configured it in the CUCM, I did that and I recognize that the mac is different that the phone screens I settings button or in the hard phone.

Actions

This Discussion