IP Helper-address across MPLS

Unanswered Question
Sep 11th, 2008
User Badges:

Hi All,


My quetsion is to do with sending DHCP requests across the WAN using the IP Helper-address command.


Our networks located in Australia and our WAN circuits are MPLS provide by Telstra, the national telco. We connect to Telstra by an ethernet link so we do not have any MPLS configuration on our WAN routers.


When I configure the IP Helper-address on our remote site routers and attempt to renew or reboot a PC at the remote site we are not able to get a new IP address. Also, Ip accounting does not show any connections to the DHCP server.


If anyone knows of any MPLS restrictions concerning DHCP requests I'd be grateful if you would let me know.


Cheers


Neil

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
kradjesh13 Thu, 09/11/2008 - 19:44
User Badges:

I have worked in the similar scenario and I never came across any issues which relates to MPLS. Possibly the issue might be because of some other thing.


Try pinging the DHCP server from the remote router.

Check whether a DHCP scope is crated for the remote sites on the DHCP server ???


Do some troubleshooting and I guess this is not some thing related to MPLS.


Thanks


Rajesh


jpoplawski Fri, 09/12/2008 - 09:52
User Badges:
  • Bronze, 100 points or more

Any reason you can't put it on the router or switch at the remote site? You might lose some functionality over using Windows DHCP, but for a remote site, you really don't have much to lose.


HTH,

JB

Jon Marshall Fri, 09/12/2008 - 10:49
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Neil


I agree with Rajesh. The last place i worked we had an MPLS network and all our remote sites got IP addresses from our data centres.


The remote site router receives the DHCP broadcast from the client and then sends a unicast packet to the configured IP helper-address(es). So it is just another IP packet across the MPLS network.


It's not clear where you are running the IP accounting, could you perhaps run a network monitor on the DHCP server to see if requests are being received.


Jon

ullasupendran Fri, 09/12/2008 - 11:20
User Badges:

Check whether you added the ip helper address on the correct vlan interface on the L3 switch .


HTH


Ullas

cisco_lad2004 Sun, 09/14/2008 - 05:27
User Badges:
  • Gold, 750 points or more

same as Rajesh, I am using the set up u described without any issues.


if u can ping DHCP but not getting PC to boot, check:


1-IP helpe is on right VLAN as per previous poster.

2-Check DHCP is configured correctly as per previosy poster.

3-Check FW is allowing DHCO Discovery packets.

4-Check DHCP and FW logs for additional help.


HTH


Sam

Actions

This Discussion