7921g and wlc 4404 oneway voice problem

Unanswered Question
Sep 12th, 2008

Hi,

I have a metwork with 35 AP 1242 (only 2.4ghz band) and 30 7921g.

I'm using a WLC 4404 version 4.2.61 7921G version 1.1.1, CCME version 4.1, AP IOS 123-7JX.

The coverage seems to be good and also the overlap.

The problem is: some times casually and also not walking we lost voice (one way o both way) for 10 or more seconds the call is still active. I tried to improve roaming, I have enable WMM support, DTCP and all the features racomanded on the wlc docs. I have analised RF interfernce with wy-spy and not seems to be relevant interference. The AP profiles are all in pass (if you check on the WLC) I can ping the CCME with a PC on the WiFi VoiceVLAN.

It very stange and a can't find a solution because the problem is not localised in an area. It is more evident when we have a conversation between 2 wifi phones.

I can't find a way to solve the problem.

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
gracianogardunojr Fri, 09/12/2008 - 09:13

I am having the same problem. CCME 4.1

WLC-4402 1100 seires ap. Your problem sounds

indentical to mine. I worked TAC we have yet

to find a resolution.

Scott Fella Fri, 09/12/2008 - 12:25

Did you verify the QoS setting on the switch port the LAP is connected to, the trunks on the switch and the port channel the WLC is on.

migilles Tue, 09/16/2008 - 13:29

If the issue is between 2 7921, ensure that P2P blocking (PSPF) is not enabled on the WLC, otherwise will always get no way audio between 2 wireless phones.

What is the current firmware of the 7921?

We released 1.2(1) a little while back and would suggest to use that version.

There was an issue a while back where if it got deauthenticated using WEP (believe version 1.0(4)), it could lead to a 10 second voice gap. I also would recommend to use 4.2.130.0 or even better 5.1.151.0, which has TCLAS support and will use port info vs DSCP to put the packets into the correct queues.

Not sure if you are doing layer 3 roaming or not, but if so, enable symmetric tunneling.

Since it's a long gap, I wouldn't be so quick to point to RF here.

I would suggest trying open authentication and see if you can reproduce it. If so, what triggered it, roaming event, etc.

Capture the wlan sniffer trace and can then see what's happening. Cisco TAC should be able to help you there.

See the 7921G Deployment Guide for more info.

http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/7921g/6_0/english/deployment/guide/7921dply.pdf

This sounds like a near far issue, if there are no interference sources around Use the following list to identify possible causes for the problem:

•Check the access point to see that the transmit power setting matches the transmit power setting on the phone. One-way audio is common when the access point power setting is greater (100mW) than that of the phone (20mW).

Cisco Unified Wireless IP Phone 7921G Firmware supports dynamic transmit power control (DTPC). The phone uses the transmit power that the access point advertises upon association.

--------------------------------------------------------------------------------

Note With DTCP, if Client Transmit Power is set in the access point, the phone automatically uses the same client power setting. If the access point is set for the maximum setting (Max), the access point uses the Transmit Power setting on the phone.

--------------------------------------------------------------------------------

•Check that the access point is enabled for ARP caching. When the Cisco Unified Wireless IP Phone 7921G is in power save mode or scanning, the access point can respond to the wireless IP phone only when ARP caching is enabled.

See the "Voice Over IP Wireless Network Configuration" section on page 2-28 for more information.

•Check your gateway and IP routing for voice problems.

•Check if a firewall or NAT is in the path of the RTP packets. If so, you can use Cisco IOS and PIXNAT to modify the connections so that two-way audio is possible.

•Check that the Data Rate setting for the phone and the access point are the same. These settings should match or the phone should be set for Auto.

•Check the phone hardware to be sure the speaker is functioning properly.

•Check the volume settings in the Phone Settings menu.

fabriziop Wed, 09/17/2008 - 00:29

Hi thanks all for you support.

I can't understand how to proceed: the problem is Qos? WLC configuration?

The DTCP is enabled, with ping on the VLAN wifii can reach the CCME, no nat or firewall, hardware ok,WMM is on, platinum Qos is enabled on the voice SSID

Now I will check the datarate, and how can enable ARP caching?

Now I'mstaring the TAC.

fabriziop Wed, 09/17/2008 - 03:58

I don't complitely understand your question but, I'm using full tx power by derault on the wlc auto power RF in global management and as anttenna the 2.2dBi rubberduck and four outdoor the 5.2 dBi omni dipole.

As you are using full power the ap is transmitting at 100mW. The 7921 only transmitts at 20mW. Is the on way voice that you hear to the phone or from the phone. Turn the power down so the max tX on the WLC is 10mW. 10mW is 10dBm + 2.2dBm from the antenna is about 17mW. then tha AP and the 7921 will always hear each other

fabriziop Wed, 09/17/2008 - 04:16

I have enable ccx extensions.

One way spech is not so frequent, the frequent problem is that I can't hear the voice in both ways. The comunication is still up and i'm not walking.

But I will check the power setup.

Thanks

migilles Mon, 09/22/2008 - 10:40

That is not true. The 7921 can tx up to 17 dBm (50 mW) for 802.11b and up to 16 dBm (40 mW) for 802.11g and 802.11a. Yes the 7921 supports DTPC, so will use the closest supported txp power per the client power advertised from the AP.

But if you are using max power on the AP, then the max would be 100 mW for 802.11b and 50 mW for 802.11g and 802.11a.

I believe you are getting confused with the 7920 phone, which is end of sale. It had a default tx power of 20 mW and didn't support DTPC until firmware version 1.0(8), so would have to manually configure the tx power higher if necessary (i.e. 50 or 100).

g.rienstra Tue, 09/23/2008 - 06:35

Depending on the version you are running: telnet/ssh to the controller do a show network (summary) and look for

ARP Unicast Mode.......... Enabled

in the newer versions (5, late 4) it seems to be hidden.

FYI there is also a new 7921 firmware load (don't think this will reslove your issue, but you could try it)

Goen

Goen, are you sure about the "ARP Unicast Mode Enabled"?

According to the 7921G deployment guide, it should be disabled

---------- Snip from 7921dply.pdf---------

When configuring your access points, use these guidelines:

• Set the QoS policy to “Platinum”.

• Enable WMM to enable QoS and the ability to use U-APSD.

• Disable DHCP address assignment required.

• Ensure “Aggressive Load Balancing” is disabled

• Ensure ARPUnicast is disabled

• Disable Peer to Peer Blocking / Public Secure Packet Forwarding (PSPF)

• Ensure Client Management Frame Protection (MFP) is set to disabled or optional

• Enable “Symmetric Tunneling” if Layer 3 mobility is enabled

When using 802.1x authentication, it is recommended to implement CCKM.

Note: If you have clients from other regions that will attempt to associate with the WLAN, then ensure that World Mode

(802.11d) is enabled.

The SSID to be used by voice clients can be configured to only apply to a certain 802.11 radio type.

--------------- Snip end ------------------

Also, in the Enterprise Mobility Design Guide v4.1, Chapter 2, ARP paragraph, it is suggested to keep it disabled to avoid ARP broadcast storms, which can lead to a DoS situation. This was a vulnerability in earlier versions of the WLC software.

It is even suggested to enable DHCP required on the WLAN in order to prevent exploitation of such vulnerabilities, but I am not aware of the full impact of this setting, since it is against the 7921 deployment guide instruction.

Anyway, we experience similar problems, WLC 4402, 4.2.130.0, with 7921G running 1.2.1.

Michael

g.rienstra Tue, 09/23/2008 - 06:37

Depending on the version you are running: telnet/ssh to the controller do a show network (summary) and look for

ARP Unicast Mode.......... Enabled

in the newer versions (5, late 4) it seems to be hidden.

FYI there is also a new 7921 firmware load (don't think this will reslove your issue, but you could try it)

Goen

migilles Tue, 09/23/2008 - 12:50

Hi "g.rienstra", that is an incorrect statement about ARPunicast. If proxy ARP is enabled then ARPUnicast is disabled as I have put into the 7921G Deployment Guide. If you enable this, it may cause problems. Also battery life for the 7921 will not be optimal (80 hrs vs 150 hrs with standard battery if no proxy ARP support on the AP).

The "config network arpunicast disable" has been removed in 5.1, so proxy ARP will always be enabled.

I would suggest to use 5.1.151.0 as this also has TCLAS support.

g.rienstra Wed, 09/24/2008 - 00:42

oepsss.... You are correct. I was looking at an old system (config) from a customer using Polycom wireless phones. the this statement is applicable.

My apologies.

Goen

alig.norbert Mon, 09/29/2008 - 01:36

Hi all,

I have the same problem:

- 98 pc. 1242 (2.4, 5GHz)

- 5 pc.7921G (CP7921G-1.1.1.LOADS)

- 2 pc. WLC 4404 (4.2.130.0) with LAG to the

switch

- CCME 4.2(0), IOS 124-11.XW6.bin

Could it be, that the LAG is trying to "balancing" the RTP-Stream?

Greets,

Norbert

gracianogardunojr Mon, 09/29/2008 - 08:30

We seem to have solved our problem.

Make sure your QOS is set correctly.

Set your AP on the switch to auto duplex speed 100. On the WLC on the switch auto auto.

Good luck

fabriziop Mon, 10/13/2008 - 06:59

Hi I hope I'm quite near a solution of the original problem.

I changed the authentication type to wpa/TKIP + ccmk and It seems working well.

Before I was using dinamic WEP with LEAP.

Bye

migilles Mon, 10/13/2008 - 09:48

FYI....there are no known issues on the 7921G side in regards to 802.1x+WEP using LEAP. Ensure you are using version 1.2(1) for the 7921G. We recommend 4.2.130.0 or later for the WLAN controller, preferably 5.1.151.0.

s.henrot Mon, 11/24/2008 - 04:20

Hi,

I can't find this issue, can you tell us what's the bugID ?

Thks.

migilles Mon, 11/24/2008 - 21:24

There was no bug for this issue. Which issue are you referring to?

fabriziop Thu, 11/27/2008 - 14:16

Hi all,

I see that my post is very intersting.

In the last days I closed the TAC with the solution: do not use dinamicWEP+LEAP on the WLC.

I changed the auth type in WPA+CCKM and the situation is chenged radically!

No the voice quality is very good an no probles.

If you whant I can post the mail of the TAC.

BYE

Actions

This Discussion