Citrix Session Reliability and WAAS

Unanswered Question
Sep 12th, 2008
User Badges:

I'm not having any luck getting my Citrix traffic to be reduced between my WAE devices. I've ensured that compression and encryption is disabled at the client and server, but I'm finding that the packets are even increasing in size, and users are complaining of extra sluggishness with their sessions. I notice that the Citrix traffic is using port 2598. My WAEs are running 4.1.1.


Thanks

Richard

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
huangedmc Sat, 09/13/2008 - 07:43
User Badges:

We've tried WAAS w/ our Citrix environment, and the result wasn't very good either.


I believe that's just the nature of Citrix - you can't really optimize it.

Zach Seils Sun, 09/14/2008 - 18:51
User Badges:
  • Cisco Employee,

Hi Richard,


It almost sounds like compression/encryption are still enabled. Can you provide a packet capture of a session where you see this behavior?


Thanks,

Zach



lofek Wed, 10/01/2008 - 07:33
User Badges:
  • Cisco Employee,

Richard

What version of Citrix are you running on the server side and the client side? There are different ways to disable the Citrix compression and encryption on different versions. I have attached instructions to disable compression/encryption for various versions.




richianaj Wed, 10/01/2008 - 07:51
User Badges:

Hi, I don't think the attachment worked.


Thanks,

Richard



JHaynes4 Fri, 02/06/2009 - 09:12
User Badges:

I believe the default Citrix policy for WAAS is port 1494. I editied the classifier for Citrix to include port 2598. We are only using TFO as the Citrix group does not want to shut off compression and encryption.

Volker Janusch Thu, 03/05/2009 - 00:08
User Badges:

We have the same problem on customer site. The citrix consultant means: It is impossible to disable the encryption completely. After the logon-encryption the data-encryption falls back to "basic" which is the simple citrix-encryption.

Volker Janusch Thu, 03/12/2009 - 08:19
User Badges:

Thank you.

It works with the instructions of this document: compression off. Encryption 128bit for authentication and basic for data. Presentation-Server 4.5, Client 10.x, WAAS 4.1.1c b16 with TFO, DRE, LZ.

Volker Janusch Tue, 03/17/2009 - 09:24
User Badges:

No, we did not tried this. But I monitored all changes on customers environment to be sure that all settings are active.

One difference was:

"EncryptionLevelSession=EncRC5-0" was unknown and configured as "EncryptionLevelSession=2".

Actions

This Discussion