Callers stranded in queue via AC; no MOH

Answered Question
Sep 12th, 2008

Platform = UCCM 6.1.2; Unity 4.0.4

I'm having an issue in which callers get stranded in an attendant console queue, do not get MOH, and are left in queue even when designated agent extension becomes available.

Here are the details:

- Caller 1 calls DID which is associated to a CTI RP

- CTI RP forwards all Caller 1 to Unity Call Handler

- Unity CH plays greeting and forwards Caller 1 to Pilot Point

- Pilot Point rings directory number of sole hunt group member

- Caller 1 is connected to agent/hunt group member

- Caller 2 calls in; follows same process and reaches Pilot Point queue with MOH

- Caller 3 calls in; hears initial Unity CH greeting, then gets silence after Unity appears to have sent call to Pilot Point; Caller 3 is not disconnected and believes to be onhold in queue

- Callers 1 & 2 complete their call and hunt group member ext does not ring for Caller 3, but Caller 3 is still connected

- Max calls for Pilot Point DN is set to 5000 with busy trigger of 1

- Max calls for Hunt Group DN is set to 1 with busy trigger of 1

Am I missing something here? Any info would be most appreciated. Thx.

I have this problem too.
0 votes
Correct Answer by rob.huffman about 8 years 4 months ago

Hi Lamar,

Can you try changing the Busy Trigger on 3195 to something like 5 :)

Hope this helps!

Rob

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
ckltd7401 Mon, 09/15/2008 - 05:09

- Checked Application event log on Unity and found the following entry for each time a caller was left stranded in the queue with dead air (no MOH)

<<>>

CiscoUnity_TSP

Event ID = 109

Type = Warning

Cisco Unity-CM TSP device 4 (Cisco Unity port 1): Failed blind transfer to extension 3195. Busy tone detected. If this is a persistent problem, it may indicate a problem on the Cisco Unity and/or Cisco CallManager. Verify that transfers are working.

<<>>

- Max calls is set to the default (5000) on the DN (3195) associated to the AC pilot point with a busy trigger of 1

Correct Answer
rob.huffman Mon, 09/15/2008 - 05:13

Hi Lamar,

Can you try changing the Busy Trigger on 3195 to something like 5 :)

Hope this helps!

Rob

ckltd7401 Mon, 09/15/2008 - 05:42

I tried setting the busy trigger to a higher value (5) and the AC will not register or is taking a rather long time. Could it be that someone is stuck in queue causing the AC not to complete re-registration?

ckltd7401 Mon, 09/15/2008 - 06:44

Rob,

After setting the busy trigger to 5 and restarting the CTI Mgr service, I was able to get the AC to re-register. However, if there is one active call on the hunt group member DN, all I hear is a fast ticking sound when Unity is attempting to forward my call to the AC. The ticking continues until the previous call on the hunt group member DN is terminated, then the 2nd call is forwarded. In short, it doesn't appear the queuing is working, I'm not getting MOH, but I'm not getting the dead air as I was getting before changing the busy trigger to 5. I'm guessing the ticking sound is Unity attempting to contact the AC, but for some reason, the AC is not queing the call.

ck

rob.huffman Mon, 09/15/2008 - 07:59

Hi Lamar,

A couple of questions here;

Is this AC Hunt using the "Broadcast" algorthym?

If so, what is the setting for Max number of calls in queue?

Rob

ckltd7401 Thu, 09/18/2008 - 08:00

Rob,

We found a bug with our UCCM ver in regards to change notification failures and database replication issues that affected both of our subscriber servers. I had previously tried increasing the busy trigger on the AC pilot shortly before starting this conversation, but it didn't work so I was lead to believe the trigger setting had no effect. We were able to resolve the bug issues and I increased the trigger as you suggested; it's working fine now. Thanks for your response on this. Sometimes, it's good to hear it from someone you know to be a reliable resource just to sustain confidence you're on the right track.

rob.huffman Thu, 09/18/2008 - 15:41

Hi Lamar,

Well, we didn't see that coming did we ;-)

I was reading about that bug the other day thinking what a bummer it was that something like this happens. Nice troubleshooting on your part to find this and get it fixed. +5 points for so kindly posting back with your results.

Cheers!

Rob

ckltd7401 Fri, 09/19/2008 - 03:33

No problem Sir, the pleasure was all mine! I find this forum very helpful as I learn so I'd encourage everyone to update their posts.

Actions

This Discussion