Trouble with VLAN's...

Answered Question
Sep 12th, 2008
User Badges:

Hi,


I am trying to get a 2106 controller (latest firmware) and 3 1252 access points in to our network. We have 3560 core switches with a few VLAN's. I can set it all up fine on its own with my laptop on the WAC itself, but plugging in to a swtich port in our server VLAN doesn't work at all. Its not reachable via ping, telnet, HTTP.


I have since got it kind of working. I set up a switchport in trunk mode, and I ALSO HAD TO TAG the management/ap interfaces. This is the only way I can telnet/HTTP in to the WAC. BUT, I can only seem to do so now from within that server VLAN. I can't reach the device from our client VLAN, nor can I reach from the WAC to our client VLAN. Even with the trunkport set, if I set the interfaces on the WAC to untagged, I can't do anything on the WAC at all! Any ideas what I am missing?


Thanks

Correct Answer by Scott Fella about 8 years 7 months ago

Make sure you have all the vlans defined on the switches. Make sure all switch to switch connections are set to trunk. Each vlan will need a layer 3 interface also. the management and ap-manager should be on the same vlan and the dot1q trunk port should be set to native vlan X. X being the vlan the management and ap-manager ip is on. On the WLC, you should set the vlan tag "0" untagged. That should get you going.


Place the AP's on the same subnet as the management and ap-manager and make sure there is a dhcp scope for that subnet so the ap's can obtain an ip address and be able to join the WLC. Then you can move the ap to another subnet if you wish.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Scott Fella Fri, 09/12/2008 - 16:41
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

Make sure you have all the vlans defined on the switches. Make sure all switch to switch connections are set to trunk. Each vlan will need a layer 3 interface also. the management and ap-manager should be on the same vlan and the dot1q trunk port should be set to native vlan X. X being the vlan the management and ap-manager ip is on. On the WLC, you should set the vlan tag "0" untagged. That should get you going.


Place the AP's on the same subnet as the management and ap-manager and make sure there is a dhcp scope for that subnet so the ap's can obtain an ip address and be able to join the WLC. Then you can move the ap to another subnet if you wish.

adrian.h Fri, 09/12/2008 - 18:08
User Badges:

Ahh I had to change the trunk to native vlan 10 and undo the tagged options. Looks ok so far from my remote access, but I think I hit my next problem. I added a dynamic interface that is vlan 11 - our client vlan already set up on our network. I can ping other vlan's with hosts from the WAC but it won't let me ping that VLAN. Do I need to make all WLAN's a completely unique VLAN that doesn't exist on the network?

Scott Fella Fri, 09/12/2008 - 18:10
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

Any wireless subnet should be seperate from the wired subnets. So for wireless data for example, should not be on the same subnet as the wired data.

adrian.h Fri, 09/12/2008 - 18:12
User Badges:

I see what you are saying, but I am just testing and wondering if it will work for now. Thanks for the tip on the native VLAN command though!

Actions

This Discussion