UNITY 5.X and IIS

Answered Question
Sep 13th, 2008
User Badges:
  • Bronze, 100 points or more

Guys


just did a deployment and everything seems to be working as expected. one issue ive encountered though is that everyime i log into the system admin page the website takes a long time to load although it says website found. my workaround is to issue and iisreset and that works perfectly. thhe page will be up and functional however if i close the page off and attempt to reopen after about 1/2 hour i need to do the reset again.


today is the first day of cutover. the system was on test for the past week with no issues. only change was the addition of the voice recognition. thats probably a coinciedence.


i also, did NOT run a windows live update for latest fixes and patches but ran only what came on the UNITY CD.


we are running


W2K3 SP1, EXCHANGE2003 SP2 UNITY UM 5.0


thanks in advance for the responses.



Correct Answer by Rob Huffman about 8 years 6 months ago

Hi Arvind,


This bug was nicely provided by Michael from Cisco;


CSCsc86904 Bug Details


WS03: Cannot log back in to SA after timeout

Symptom:


Cisco Unity administrators are unable to access the Cisco Unity System Administrator via Internet Explorer.


Conditions:


Seen occasionally with Unity servers that run on Microsoft Windows Server 2003, typically after an SA session has timed out. Seen with Cisco Unity 4.2(1) and Unity 5.0(1).


Workaround:

1) Restart the WWWP service.


or


2) Increase the SA Session Timeout value in Internet Information Services (IIS) Manger from the default of 20 minutes to 180 minutes, or more. Additionally, there is evidence that the issue can be worked around by setting the Idle Timeout to a value lower than the SA Session Timeout.

This doesn't prevent the problem, but it does decrease the chances of running into the problem.


Following are detailed steps to increase both the session and the idle timeout values, and to set the idle timeout to a value less than the session timeout.


To Increase the Session Timeout

1. Go to Start->Programs->Administrative Tools->Internet Information Services (IIS) Manger.

2. In the left-hand pane, expand the tree for the local computer.

3. Right-click the Default Web Site and select Properties.

4. Click the Home Directory tab.

5. Click the Configuration button.

6. On the Application properties sheet, click the Option tab.

8. Increase the session timeout from the default 20 minutes to the desired number (180 minutes or more, is fine).


To Change the Idle Timeout

9. In IIS Manager, expand the "Application Pools" folder.

10. Right-click on "DefaultAppPool" and select Properties.

11. Select the "Performance" tab.

12. Change the value in "Idle timeout" to a couple of minutes less than the session timeout for the SA.

13. Press "Apply".

14. Restart the "DefaultAppPool"


The result will be that after the timeout fires, the browser window will either close on its own or a dialog box will appear asking if you wish to close the window. A new SA session can be opened by the Unity icon in the System Tray.


If you don't see the Application Pools container in IIS Manager, do the following steps to display Application Pools and then adjust the Idle Timeout. (See CSCsi42693 for additional problems that happen when the Application Pools is not displayed in IIS Manager.)


To Display Application Pools

1. Open IIS Manager (Click Start > All Programs > Administrative Tools > Internet Information Services (IIS) Manager.)

2. Expand the tree in the left pane.

3. Right-click Web Sites and select Properties.

4. Click the Service tab.

5. In the Isolation Mode section at the top of the page, uncheck the check box "Run WWW service in IIS 5.0 isolation mode".

6. Click OK on the message box to restart IIS. The Application Pools container should now be displayed

7. Close IIS Manager.



1st Found-In

4.2(0.58)

4.2(0.66)


Fixed-In

4.2(0.103)

5.0(0.79)

7.0(0.71)

4.2(1.0)ES115

4.2(1.0)ES116

4.2(1.0)ES43

5.0(1.0)ES15

5.0(1.0)ES16

5.0(1.0)ES20

4.2(1.0)ES125

5.0(1.0)ES21

5.0(1.0)ES22

5.0(1.0)ES23

5.0(1.0)ES25

5.0(1.0)ES31

5.0(1.0)ES32

5.0(1.0)ES33

5.0(1.0)ES34

5.0(1.0)ES35

5.0(1.0)ES38

5.0(1.0)ES39

4.2(1.0)ES153

4.2(1.0)ES155

4.2(1.0)ES158

5.0(1.0)ES48

5.0(1.0)ES50

5.0(1.0)ES51

4.2(1.0)ES159

4.2(1.0)ES160

5.0(1.0)ES52


Hope this helps!

Rob

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Rob Huffman Sat, 09/13/2008 - 15:56
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Arvind,


This bug was nicely provided by Michael from Cisco;


CSCsc86904 Bug Details


WS03: Cannot log back in to SA after timeout

Symptom:


Cisco Unity administrators are unable to access the Cisco Unity System Administrator via Internet Explorer.


Conditions:


Seen occasionally with Unity servers that run on Microsoft Windows Server 2003, typically after an SA session has timed out. Seen with Cisco Unity 4.2(1) and Unity 5.0(1).


Workaround:

1) Restart the WWWP service.


or


2) Increase the SA Session Timeout value in Internet Information Services (IIS) Manger from the default of 20 minutes to 180 minutes, or more. Additionally, there is evidence that the issue can be worked around by setting the Idle Timeout to a value lower than the SA Session Timeout.

This doesn't prevent the problem, but it does decrease the chances of running into the problem.


Following are detailed steps to increase both the session and the idle timeout values, and to set the idle timeout to a value less than the session timeout.


To Increase the Session Timeout

1. Go to Start->Programs->Administrative Tools->Internet Information Services (IIS) Manger.

2. In the left-hand pane, expand the tree for the local computer.

3. Right-click the Default Web Site and select Properties.

4. Click the Home Directory tab.

5. Click the Configuration button.

6. On the Application properties sheet, click the Option tab.

8. Increase the session timeout from the default 20 minutes to the desired number (180 minutes or more, is fine).


To Change the Idle Timeout

9. In IIS Manager, expand the "Application Pools" folder.

10. Right-click on "DefaultAppPool" and select Properties.

11. Select the "Performance" tab.

12. Change the value in "Idle timeout" to a couple of minutes less than the session timeout for the SA.

13. Press "Apply".

14. Restart the "DefaultAppPool"


The result will be that after the timeout fires, the browser window will either close on its own or a dialog box will appear asking if you wish to close the window. A new SA session can be opened by the Unity icon in the System Tray.


If you don't see the Application Pools container in IIS Manager, do the following steps to display Application Pools and then adjust the Idle Timeout. (See CSCsi42693 for additional problems that happen when the Application Pools is not displayed in IIS Manager.)


To Display Application Pools

1. Open IIS Manager (Click Start > All Programs > Administrative Tools > Internet Information Services (IIS) Manager.)

2. Expand the tree in the left pane.

3. Right-click Web Sites and select Properties.

4. Click the Service tab.

5. In the Isolation Mode section at the top of the page, uncheck the check box "Run WWW service in IIS 5.0 isolation mode".

6. Click OK on the message box to restart IIS. The Application Pools container should now be displayed

7. Close IIS Manager.



1st Found-In

4.2(0.58)

4.2(0.66)


Fixed-In

4.2(0.103)

5.0(0.79)

7.0(0.71)

4.2(1.0)ES115

4.2(1.0)ES116

4.2(1.0)ES43

5.0(1.0)ES15

5.0(1.0)ES16

5.0(1.0)ES20

4.2(1.0)ES125

5.0(1.0)ES21

5.0(1.0)ES22

5.0(1.0)ES23

5.0(1.0)ES25

5.0(1.0)ES31

5.0(1.0)ES32

5.0(1.0)ES33

5.0(1.0)ES34

5.0(1.0)ES35

5.0(1.0)ES38

5.0(1.0)ES39

4.2(1.0)ES153

4.2(1.0)ES155

4.2(1.0)ES158

5.0(1.0)ES48

5.0(1.0)ES50

5.0(1.0)ES51

4.2(1.0)ES159

4.2(1.0)ES160

5.0(1.0)ES52


Hope this helps!

Rob

a.gooding Sat, 09/13/2008 - 16:25
User Badges:
  • Bronze, 100 points or more

Whaaa, did NOT expect to get a resolution this fast. ill probably have to start paying you :)


thanks a million



Actions

This Discussion