Marwan ALshawi Sun, 09/14/2008 - 02:40
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

EtherChannel is a Cisco-proprietary technology that, by aggregating links into a single logical link, provides incremental trunk speeds ranging from 10 Mbps to 160 Gbps (full duplex). EtherChannel comes in four flavors:

Standard EtherChannel

Fast EtherChannel (FEC)

Gigabit EtherChannel (GEC)

10-Gigabit EtherChannel

The term EtherChannel encompasses all these technologies. Ether-Channel combines up to eight standard Ethernet links (160 Mbps on a Catalyst 3000), up to eight Fast Ethernet links (1.6 Gbps), up to eight Gigabit Ethernet links (16 Gbps), and up to eight 10-Gigabit Ethernet links (160 Gbps).


EtherChannel bundles segment into groups of two to eight links. This lets links scale at rates between 100 Mbps and a healthy fraction of 1 Tbps. Remember when T1 or 1.544 Mbps was the fastest WAN link available. Now it is at least 16 Tbps for up to a 50-kilometer stretch with single-mode fiber, using the Catalyst 6500 10GBASE-EX4 Metro 10-Gigabit Ethernet module. EtherChannel operates as either an access link or trunk link. For example, EtherChannel can be deployed between the wiring closet and the data center


Some of the benefits of EtherChannel are:


EtherChannel does not require any changes as it is transparent to networked applications. For support of EtherChannel on enterprise-class servers and network interface cards, smart software drivers can coordinate distribution of loads across multiple network interfaces.

When EtherChannel is used within the campus, switches and routers provide load balancing transparently across multiple links to network users. Unicast, multicast, and broadcast traffic is distributed across the links in the channel.

EtherChannel provides automatic recovery for loss of a link by redistributing loads across remaining links. If a link does fail, EtherChannel redirects traffic from the failed link to the remaining links in less than a second. This convergence is transparent to the end user. No host protocol timers expire, so no sessions are dropped.


EtherChannel uses two methods for negotiating bundles:

Port Aggregation Protocol (PAgP) - Cisco Proprietary

Link Aggregation Control Protocol (LACP) - 802.1ad


those L2:


interface FastEthernet0/7

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 2 mode desirable

!

interface FastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 2 mode desirable


or u could make it L3:


interface FastEthernet0/11

no switchport

no ip address

channel-group 3 mode desirable

!

interface FastEthernet0/12

no switchport

no ip address

channel-group 3 mode desirable



interface Port-channel2

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Port-channel3

no switchport

ip address 10.0.0.1 255.255.255.0


good luck


if helpful Rate

Actions

This Discussion