OSPF issues

Unanswered Question
Sep 14th, 2008
User Badges:
  • Gold, 750 points or more

I am sending 192.168.254.0/24 route to R1 using route-map from R2. I dont understand why R1 is seeing the route via it ethernet0/0 after changing the ip ospf cost on the ethernet 0/0 to 10000. even after changing the BW on ethernet lower than the serial interface, doesnt make any diference. it's sunday evening and very tired :). I'm i missing something ?


Also i beleieve when connecting to multiple areas from a router, area 0 should always be the preffered path! not in my case


R1


interface Loopback0

ip address 150.1.4.4 255.255.255.0

!

interface Ethernet0/0

ip address 183.1.45.4 255.255.255.0

ip ospf cost 10000

half-duplex

no cdp enable

!

interface Serial1/0

ip address 183.1.0.4 255.255.255.0

encapsulation frame-relay

ip ospf network broadcast

serial restart-delay 0

cdp enable

!

router ospf 1

router-id 150.1.4.4

log-adjacency-changes

network 183.1.0.4 0.0.0.0 area 0

!

router ospf 45

log-adjacency-changes

network 183.1.45.4 0.0.0.0 area 45

!



R2


interface Loopback0

ip address 150.1.5.5 255.255.255.0

!

interface Loopback10

ip address 192.168.254.1 255.255.255.0

!

interface Ethernet0/1

ip address 183.1.45.5 255.255.255.0

ip ospf cost 10000

half-duplex

no cdp enable

!

!

interface Serial1/0

ip address 183.1.0.5 255.255.255.0

encapsulation frame-relay

ip ospf network broadcast

serial restart-delay 0

cdp enable

!

router ospf 1

router-id 150.1.5.5

log-adjacency-changes

redistribute connected subnets route-map CI

network 183.1.0.5 0.0.0.0 area 0

!

router ospf 45

log-adjacency-changes

redistribute connected subnets route-map CI

network 183.1.45.5 0.0.0.0 area 45


ip prefix-list 192>OSPF seq 5 permit 192.168.254.0/24

!

route-map CI permit 1

match ip address prefix-list 192>OSPF

!



R4#SH IP ROUTE

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route


Gateway of last resort is not set


183.1.0.0/24 is subnetted, 2 subnets

C 183.1.45.0 is directly connected, Ethernet0/0

C 183.1.0.0 is directly connected, Serial1/0

O E2 192.168.254.0/24 [110/20] via 183.1.45.5, 00:01:56, Ethernet0/0

150.1.0.0/24 is subnetted, 1 subnets

C 150.1.4.0 is directly connected, Loopback0

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Richard Burts Sun, 09/14/2008 - 11:19
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Franco


You post partial configs from R1 and R2 and then the output of show ip route form R4. Where does R4 fit into your issue? Can you clarify this for us?


It would help us to understand your issue if you would post the output of show ip ospf data from R1 (and perhaps from R2)


HTH


Rick

francisco_1 Sun, 09/14/2008 - 12:08
User Badges:
  • Gold, 750 points or more

Rick,


My mistake. The output is R1.


R1#SH IP ROUTE


183.1.0.0/24 is subnetted, 2 subnets

C 183.1.45.0 is directly connected, Ethernet0/0

C 183.1.0.0 is directly connected, Serial1/0

O E2 192.168.254.0/24 [110/20] via 183.1.45.5, 00:01:56, Ethernet0/0

150.1.0.0/24 is subnetted, 1 subnets

C 150.1.4.0 is directly connected, Loopback0


R1 and R2 connected via a switch (Same Vlan). Also R1 and R2 also connected via frame-relay. The preffered link should be the serial interfaces and the ethernet as backup. After making the ip ospf cost 10000, ethernet is still choosen as the primary link.


Is that ok?

Richard Burts Sun, 09/14/2008 - 13:53
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Franco


Please post the output of show ip ospf interface and of show ip ospf data from both routers.


Also can you explain the reasons for running two OSPF processes on each router, especially when both processes neighbor with the same router?


HTH


Rick

Giuseppe Larosa Sun, 09/14/2008 - 22:11
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Francisco,

the answer is in the type of external route you have.

with a redistribution command on R2 R2 becomes an ASBR and the route is injected as O E2 so the route has just a default seed metric.

You cannot influence the path used by changing the ip ospf cost because that is an internal metric that with O E2 is not added to the seed metric.

If you want to have this type of control add metric-type e1 in the redistribute connected or inside the route-map.


Second note:

You are using two different OSPF routing processes one in area 0 and one in area 45 be aware that they are working as ships in the night and each of them will propose its own routing entry to the process that manage the routing table and will be in competition to install routes.

If you want to emulate an OSPF multi-area context I would use only a single OSPF process with multiple network area statements.


see

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00801069aa.shtml


this is for redistribution between ospf processes.


In your case if you issue a

clear ip ospf proc 45

on R1 the route from ospf process 1 could get installed during process ospf 45 restarting.


If both ospf processes offer a route with AD 110 and metric 20 the first one to converge has its route installed this happens when dealing with multiple ospf processes.


the area info is confined within the ospf process.


If you try to change to E1 type on only one ospf process, the other process's route will be installed because now two routes with AD 110 and different metric are proposed to the routing table.



Hope to help

Giuseppe


francisco_1 Mon, 09/15/2008 - 03:03
User Badges:
  • Gold, 750 points or more

Rick/Giuseppe


There is no interaction betweeen different OSPF processes running on the same router. OSPF will not take in to account the metric or route type, the tie-breaker is the administrative distance. Thus, since both OSPF processes have a default administrative distance of 110, the first process trying to install that route makes it into the routing table.


Giuseppe explained it well and the link also.


Giuseppe, Your rating is 5. enjoy it.


Thanks


Francisco

Giuseppe Larosa Mon, 09/15/2008 - 03:54
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Francisco,

thanks for your high remark I enjoy it !

Actually, 3 years ago I took part in project of merging two ISP backbones and we had to deal with this scenario of multiple OSPF processes and redistribution and we saw this in the lab tests.


Best Regards

Giuseppe





sdoremus33 Mon, 09/15/2008 - 06:47
User Badges:
  • Bronze, 100 points or more

Giuseppe


I really enjoy reading your posts it makes it worth coming to this site to learn from Pros like yourself. You are the man and I learn quite a bit a bit from you. Thanks and keep up the awesome posts

Actions

This Discussion