URGENT:BAT tool:Cannot have an empty pattern when no Partition is specified

Unanswered Question
Sep 14th, 2008
User Badges:

Hi Guys,

Can someone please help me with the following BAT issue in CUCM 6.1.2


I am trying to update the “call waiting busy trigger” and “Call Forward Busy” for only those UDP's which has line 2 starting with 65XXXX. In order to achieve this I went to Bulk Administration > User Device Profile > Add/Update Line > Update Lines and tried to list the above information but was unable to after applying some filters, hence I took following steps to perform the same task.

1) Exported UDP for 7971 phone models (All Details)

2) Downloaded exported UDP text file to local machine and saved it in CSV format

3) Run the excel filter to show only those UDP's which has 65XXXX line 2

4) Updated the busy trigger and Call Forward Busy in CSV file

5) Uploaded CSV file to CUCM

6) Inserted UDP with 'All Details' and checked the box “override the existing configuration” and hit submit

7) Went to Job Scheduler and found the errors in the logs: rhdtcg33 LINE :: Error : 25140 Cannot have an empty pattern when no Partition is specified

Not sure what that error means. I raised a TAC case but TAC engineer doesn't have a clue.

Please see attached CSV file and error logs. Above procedure for other phone models seems to work fine


Any input would be highly appreciated



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
ivillegas Fri, 09/19/2008 - 13:37
User Badges:
  • Silver, 250 points or more

This may be because the system is currently unable to distinguish between the different UDP based on number of lines.

MICHAEL CARTER Wed, 10/08/2008 - 04:01
User Badges:

Dear Aamir,

Did you solve this problem? I have exactly the same problem here and would like to hear how you solved it.

Thank you!

Yours sincerely,


MICHAEL CARTER Thu, 10/23/2008 - 23:34
User Badges:

Dear Voss,

I did not get a specific answer to this issue from Cisco. What I did try though, was the latest Engineering Special (ES). I seem to remember there were some BAT related bugs in 6.1(1) or 6.1(2) and the latest ES fixed some of them. Once I applied this ES I could run the BAT.

Hope this helps - let me know if it works for you!

Yours sincerely,


mfondoum2000 Wed, 09/04/2013 - 07:27
User Badges:

Dear Aamir,

I had the same issue this morning and I finally sorted it after multiple attempts.

You have to create a Line Template by clicking on the line buttoms on the left of the phone template

created to importe each phone type.

Once I did that, I selected the default partition for imported phones and I just had to put in the BAT file

each phones MAC address, Description and Line display names.

Then I exported in BAT format and loaded it on the call manager without any issue.

Phones are now inserted to my call manager with that file without the above mentione error.

I believe the line you are trying to insert absolutely needs a partition even the None partition and this has to be selected

within the line template.

Hope this helps



This Discussion