bridging over G.SHDSL on Cisco 878 routers

Answered Question
Sep 15th, 2008
User Badges:

Hi,


I have connected two cisco 878 back to back and can ping between routers when I assign an IP address to the dialer interface.


I am testing out bridging over the dialer interfaces and have no connectivity. Here is the relevant config. What am I missing


SITE 1

----------


controller DSL 0

mode atm

line-term cpe

line-mode 2-wire line-zero

dsl-mode shdsl symmetric annex A

line-rate auto


interface ATM0

no ip address

no atm ilmi-keepalive

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

bridge-group 1


interface Dialer0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

encapsulation ppp

ip route-cache flow

dialer pool 1

dialer-group 1

no cdp enable

bridge-group 1


interface Vlan1

description *** Management ***

ip address 192.168.1.2 255.255.255.0


dialer-list 1 protocol ip permit

bridge 1 protocol ieee




SITE 2


------------

controller DSL 0

mode atm

line-term co

line-mode 2-wire line-zero

dsl-mode shdsl symmetric annex A

line-rate auto


interface ATM0

no ip address

no atm ilmi-keepalive

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

bridge-group 1


interface Dialer0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

encapsulation ppp

ip route-cache flow

dialer pool 1

dialer-group 1

no cdp enable

bridge-group 1


interface Vlan1

description *** Management ***

ip address 192.168.1.1 255.255.255.0


dialer-list 1 protocol ip permit

bridge 1 protocol ieee


Correct Answer by Giuseppe Larosa about 8 years 9 months ago

Hello Chris,

in this kind of config the dialer is not needed


I would do the following:


remove any reference to the dialer in the atm0 interface


change the pvc 8/35 encapsulation to


enc aal5snap

and retry probably the ppp session is not coming up and so it is disturbing.



Hope to help

Giuseppe


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Giuseppe Larosa Mon, 09/15/2008 - 10:54
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Paul,

what is missing here are the lan segments that should take part in the bridge.


you can try this:


int vlan 1

no ip address

bridge-group 1


int BVI1

ip address 192.168.1.2 255.255.255.0


bridge 1 route ip


I'm not sure if this is supported on this platform but the idea of bridging is this you create a virtual lan bridge between the two lans at the two sites but each router provides two arms the lan segment and the wan segment.


However, routing is to be preferred in a production network for several reasons including performance, broadcast control and security.


Hope to help

Giuseppe


p.holley Mon, 09/15/2008 - 11:40
User Badges:

Thanks Giuseppe,


I will try it and let you know how I make out. Routing works, but the customer is just trying to extend their LAN over Cat3.

p.holley Mon, 09/15/2008 - 12:13
User Badges:

Hi Giuseppe,


I added those commands to my existing configs, but still cannot ping between routers.


Here is output of sh bridge group from one of the routers


SHP-CO-RTR#sh bridge group


Bridge Group 1 is running the IEEE compatible Spanning Tree protocol


Port 14 (Vlan1) of bridge group 1 is forwarding

Port 16 (ATM0 RFC 1483) of bridge group 1 is forwarding

Port 17 (Dialer0) of bridge group 1 is forwarding


From a laptop connected to one of the router, i can ping the router but not across to the other side.


Any ideas are welcome.


Chris

Correct Answer
Giuseppe Larosa Tue, 09/16/2008 - 07:01
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Chris,

in this kind of config the dialer is not needed


I would do the following:


remove any reference to the dialer in the atm0 interface


change the pvc 8/35 encapsulation to


enc aal5snap

and retry probably the ppp session is not coming up and so it is disturbing.



Hope to help

Giuseppe


Actions

This Discussion