EIGRP redistribution

Answered Question
Sep 16th, 2008
User Badges:

Hi All!


Basically, there are three routers with EIGRP enabled. Router A is a neighbor to Router B, Router B is a neighbor to Router C. Router A and Router C are not neighbors.

I have noticed, that Router B does not distribute networks learned from Router A to Router C. And vice versa.

What is the problem with configuration?


Thank you in advance

Correct Answer by Richard Burts about 8 years 9 months ago

It looks to me like Paul is on the right track. Quoting from the original post by Fuad:

"Router A is a neighbor to Router B, Router B is a neighbor to Router C. Router A and Router C are not neighbors"


It appears that all three routers are in the same subnet. Normally each router would form a neighbor relationship with all other EIGRP routers in the subnet. It looks like the manual specification of neighbors is preventing the neighbor relationship between router A and router C. router B is not advertising router A routes to router C because it believes that router C should be learning them directly from router A.


HTH


Rick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
lgijssel Tue, 09/16/2008 - 05:10
User Badges:
  • Red, 2250 points or more

The two pairs may be placed in different AS.

Redistribution between AS' is not automatic.

Please post the output of 'sh ip prot' from router B.

Posting the configs would be helpful too.


Regards,

Leo

Richard Burts Tue, 09/16/2008 - 05:16
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Fuad


You ask "What is the problem with configuration?" but you do not give us the configuration to analyze. Leo has identified a possible problem. I would add that it might be a problem with auto summarization, or it might be an issue with distribute lists, or it might be something else. Without seeing the configs it is difficult for us to tell what the issue is.


While I agree with Leo that the output of show ip protocol might be helpful (especially if it is an issue with multiple EIGRP AS numbers) I believe that seeing the configs would be the most helpful thing.


HTH


Rick


fgasimzade Tue, 09/16/2008 - 05:25
User Badges:

Router B:



Routing Protocol is "eigrp 2007"

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Default networks flagged in outgoing updates

Default networks accepted from incoming updates

EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

EIGRP maximum hopcount 100

EIGRP maximum metric variance 1

Redistributing: connected, eigrp 2007

EIGRP NSF-aware route hold timer is 240s

EIGRP NSF disabled

NSF signal timer is 20s

NSF converge timer is 120s

Automatic network summarization is not in effect

Maximum path: 4

Routing for Networks:

10.254.252.0/27

192.168.0.0/23

192.168.2.0/23

192.168.15.0

192.168.16.0/23

192.168.18.0/23

192.168.55.0

192.168.100.0

192.168.101.0

192.168.106.0

192.168.139.0

192.168.213.0

192.168.254.0

Routing Information Sources:

Gateway Distance Last Update

192.168.254.2 90 1d03h

192.168.254.1 90 1d03h

192.168.254.10 90 6w3d

192.168.254.11 90 1d03h

192.168.254.48 90 1d11h

192.168.254.38 90 1d03h

192.168.254.46 90 1d03h

192.168.254.70 90 5w1d

Distance: internal 90 external 170

fgasimzade Tue, 09/16/2008 - 05:29
User Badges:

Network 192.168.11.0 is directly connected on Router C.


Network 192.168.22.0 is learned by Router A from another router.


Router B knows everything about both networks. However, router A knows nothing about 192.168.11.0 and router C knows nothing about 192.168.22.0

Richard Burts Tue, 09/16/2008 - 05:37
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Fuad


The output of show ip protocol shows that there is only a single AS number. And it show that auto summarization is turned off - at least on router B. If auto summarization were on for routers A and C it could still be an isse with automatic summarization.


I believe that seeing the configs is even more important. I would also request the output of show ip eigrp topology from A or C (or both)


HTH


Rick

fgasimzade Tue, 09/16/2008 - 20:08
User Badges:

Here is iegrp config from Router C:


router eigrp 2007

redistribute connected

network 192.168.11.0

network 192.168.12.0

network 192.168.254.0

neighbor 192.168.254.1 Vlan1

neighbor 192.168.254.14 Vlan1

no auto-summary

eigrp stub connected summary


Show ip eigrp topology:


P 192.168.110.0/24, 1 successors, FD is 3072

via 192.168.254.14 (3072/2816), Vlan1

P 10.254.252.0/27, 1 successors, FD is 3072

via 192.168.254.14 (3072/2816), Vlan1

via 192.168.254.1 (3072/2816), Vlan1

P 192.168.102.4/30, 1 successors, FD is 3072

via 192.168.254.14 (3072/2816), Vlan1

P 11.11.11.0/24, 1 successors, FD is 3072

via 192.168.254.14 (3072/2816), Vlan1

P 192.168.100.0/24, 1 successors, FD is 3072

via 192.168.254.14 (3072/2816), Vlan1

P 192.168.101.0/24, 1 successors, FD is 3072

via 192.168.254.14 (3072/2816), Vlan1

P 10.31.0.0/24, 1 successors, FD is 3072

via 192.168.254.14 (3072/2816), Vlan1

P 192.168.44.0/24, 1 successors, FD is 3072

via 192.168.254.14 (3072/2816), Vlan1

P 192.168.55.0/24, 1 successors, FD is 3072

via 192.168.254.14 (3072/2816), Vlan1

P 192.168.11.0/24, 1 successors, FD is 2816

via Connected, Vlan40

P 192.168.12.0/24, 1 successors, FD is 2816

via Connected, Vlan41

P 192.168.15.0/24, 1 successors, FD is 3072

via 192.168.254.14 (3072/2816), Vlan1


Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

r - reply Status, s - sia Status


P 192.168.0.0/23, 1 successors, FD is 3072

via 192.168.254.14 (3072/2816), Vlan1

P 192.168.2.0/23, 1 successors, FD is 3072

via 192.168.254.14 (3072/2816), Vlan1

P 192.168.16.0/23, 1 successors, FD is 3072

via 192.168.254.14 (3072/2816), Vlan1

P 192.168.18.0/23, 1 successors, FD is 3072

via 192.168.254.14 (3072/2816), Vlan1

P 192.168.254.0/24, 1 successors, FD is 2816

via Connected, Vlan1

P 192.168.200.0/24, 1 successors, FD is 3072

via 192.168.254.1 (3072/2816), Vlan1

P 192.168.213.0/24, 1 successors, FD is 3072

via 192.168.254.14 (3072/2816), Vlan1

ozzyosbu1 Tue, 09/16/2008 - 23:41
User Badges:

neighbor 192.168.254.1 Vlan1

neighbor 192.168.254.14 Vlan1



Hello


its the EIGRP split horizon issue.

both the neighbors are on the same interface



HTH


jp

fgasimzade Tue, 09/16/2008 - 23:56
User Badges:

I am afraid I dont understand.


neighbor 192.168.254.14 Vlan1 is Router B


neighbor 192.168.254.1 has nothing to do with my problem, it is complitely another router.


Router C advertises its table to Router B (192.168.254.14). Router B does not advertise it further to Router A


fgasimzade Tue, 09/16/2008 - 23:58
User Badges:

Router A config:


router eigrp 2007

redistribute connected

redistribute static

redistribute bgp 65525 metric 10000000 200 255 1 1500 route-map BGP-EIGRP

network 192.168.254.0

neighbor 192.168.254.1 Vlan1

neighbor 192.168.254.38 Vlan1

neighbor 192.168.254.14 Vlan1

neighbor 192.168.254.11 Vlan1

neighbor 192.168.254.46 Vlan1

no auto-summary

ozzyosbu1 Wed, 09/17/2008 - 00:34
User Badges:

ohh..i thought it was router B s config..

and the 192.168.254.1 and 192.168.254.14 are router A and C

could you please post the configs of router B

fgasimzade Wed, 09/17/2008 - 01:20
User Badges:

No, Router A is 192.168.254.1 and Router B is 192.168.254.14, router C is 192.168.254.70


I posted Router B config before, take a look please

ozzyosbu1 Wed, 09/17/2008 - 01:35
User Badges:

hello

u had pasted sh ip protcols

could u give 'sh run | begin router eigrp'..?

if possible pls give the complete config..and one thing eigrp split horizon was a hint for u to look in to what could be your problem, this can be one reason for updates from C not getting passed to A and vice versa.

fgasimzade Wed, 09/17/2008 - 01:38
User Badges:

sh run | begin router eigrp


router eigrp 2007

redistribute connected

network 10.254.252.0 0.0.0.31

network 192.168.0.0 0.0.1.255

network 192.168.2.0 0.0.1.255

network 192.168.15.0

network 192.168.16.0 0.0.1.255

network 192.168.18.0 0.0.1.255

network 192.168.55.0

network 192.168.100.0

network 192.168.101.0

network 192.168.106.0

network 192.168.139.0

network 192.168.213.0

network 192.168.254.0

neighbor 192.168.254.48 Vlan1

neighbor 192.168.254.46 Vlan1

neighbor 192.168.254.70 Vlan1

neighbor 192.168.254.11 Vlan1

neighbor 192.168.254.38 Vlan1

neighbor 192.168.254.2 Vlan1

neighbor 192.168.254.1 Vlan1

neighbor 192.168.1.11 Vlan2

neighbor 192.168.1.254 Vlan2

no auto-summary



I have checked other neighbors and other routers which are being advertised on the same interface - everything works fine

ozzyosbu1 Wed, 09/17/2008 - 01:46
User Badges:

hello

you may need to try this

int vlan 1

no ip split-horizon eigrp 2007


careful, this will bring down your adjacencies.


fgasimzade Wed, 09/17/2008 - 01:53
User Badges:

I have checked another router, which is a neighbor to Router B as well, and networks from Router C are listed in its table. The interface is the same - Vlan1, so the issue is not with split horizon.

Giuseppe Larosa Wed, 09/17/2008 - 02:07
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Fuad,

if you do


sh ip route 192.168.11.0 on RouterA

what is the result ?


I wonder if there is any other possible routing source for the prefix with a lower AD that is preferred over the EIGRP route



Hope to help

Giuseppe


Giuseppe Larosa Wed, 09/17/2008 - 03:50
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Faud,

this was a basic check.


I see something I don't like in RouterA config:


you say that 192.168.254.1 is routerA if it is so the command

neighbor 192.168.254.1 inside router eigrp 2007 on RouterA is not needed it can't become neighbor of itself.


This can be unrelated with your issue but I would fix it


Hope to help

Giuseppe


fgasimzade Wed, 09/17/2008 - 03:53
User Badges:

No, no ))


Router A is 192.168.254.2


Router 192.168.254.1 is another router and everything is fine with it.


Router B is 192.168.254.14


Router C is 192.168.254.70

paul.matthews Wed, 09/17/2008 - 07:11
User Badges:
  • Silver, 250 points or more

All three are in the same subnet, right? In that case router B is right not to tell A about C and vice versa. The problem to me looks like A & C are not becoming neighbours properly. Can they ping each other?

Correct Answer
Richard Burts Wed, 09/17/2008 - 11:12
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

It looks to me like Paul is on the right track. Quoting from the original post by Fuad:

"Router A is a neighbor to Router B, Router B is a neighbor to Router C. Router A and Router C are not neighbors"


It appears that all three routers are in the same subnet. Normally each router would form a neighbor relationship with all other EIGRP routers in the subnet. It looks like the manual specification of neighbors is preventing the neighbor relationship between router A and router C. router B is not advertising router A routes to router C because it believes that router C should be learning them directly from router A.


HTH


Rick

Richard Burts Thu, 09/18/2008 - 05:30
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Fuad


I am glad that my response was helpful in resolving your issue. Thank you for using the rating system to indicate that your issue was resolved (and thanks for the rating). It makes the forum more useful when people can read about an issue and can know that there was a response which did lead to resolution of the issue.


The forum is an excellent place to learn about Cisco networking. I encourage you to continue your participation in the forum.


HTH


Rick

fgasimzade Thu, 09/18/2008 - 10:11
User Badges:

Thank you very much! I really appreciate your help! It is not the first time I request help here and I always get a qualified responce

Actions

This Discussion