Do Not Disturb indication in Personal Communicator

Unanswered Question
Sep 16th, 2008

Is it possible to have the DND status show in CUPC? I'm running CUCM 6.1, CUPS 6.0 and CUPC 1.2

I already have line presence working but if I put the phone into DND it still shows as "Available" in CUPC. I set the service parameter "BLF Status Depicts DND" to True which shows DND status within the CUCM presence but not in CUPC.

I'm trying to provide an "Away" status for the user that will show in CUCM and CUPC so that they could toggle that away status from either the CUPC or the phone since not everyone will use CUPC.

I am also getting the following message in RTMT on the SIP Proxy:

|<CLID::StandAloneCluster><NID::CUPS-6><LVL::All><MASK::ffff>

09/16/2008 10:51:20.100 ESP|ID(21766) Response dropped, reason: Message is incomplete or not properly terminated

|<CLID::StandAloneCluster><NID::CUPS-6><LVL::All><MASK::ffff>

09/16/2008 10:51:21.231 ESP|PID(23303) sip_protocol.c(5685) First line of message is Bad

Does anyone know what the issue is there?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
jvweigand Tue, 09/16/2008 - 11:54

There was a new "Do Not Disturb" status added to the 7.0 version of CUPC, which prevents you from receiving any IMs when you have it enabled. I'm not sure if this ties back to the CUCM setting, since we're running on 5.1, but you might want to test it out. I would be curious to know if it does in fact work.

Scott_Barns_2 Wed, 09/17/2008 - 09:57

Thanks for the tip. I looked and the DND feature in 7.0 is exactly what I was looking for. If you enable or disable DND on any device it enables it globally accross all linked devices.

So... you could set DND on your phone and turn it off on your CUPC or vice versa. Perfect...

Thanks again!

Scott

How do I mark your post to show that it solved my problem?

jvweigand Wed, 09/17/2008 - 12:40

I'm really glad to hear they are tied together, looking forward to upgrading and testing that out.

Can't remember exactly how to mark that it solved the issue, it's either a checkbox, or a dropdown I believe. Glad I could be of help!

francois.staiesse Wed, 04/22/2009 - 01:49

Hi,

Do you mean that, if you activate the DND on your desk phone, it's automatically updated on the Personal Communicator or vice versa?

I'm using CUPC 7 with CUPS 7 and CUCM 6.1.3. Extension Mobility is used too.

When I configure the DND on the CUPC, nothing change on my desk phone.

Are there special parameters to configure somewhere for that?

Thanks in advance.

François

Jaime Valencia Wed, 04/22/2009 - 07:09

there are many bugs for this so you might be hitting one

CSCsq03982

DND does not disable when IP phone has 2 users having different DN

CSCsq46621

Set DND from IP Phone and clear from CUPC, does not clear DND on phone

CSCsq46662

CUPC fails to propagate DND to 7961G-GE phones, inconsistent behavior

CSCsq97520

DND status is not updating on the phone if changed using CUPC

CSCsr38660

Inconsistent DND presence status between CUPC and IP Phone

CSCsq29651

CUPC 7.0(1) Setting DND on associated phone does not update on CUPC

HTH

java

if this helps, please rate

francois.staiesse Thu, 04/23/2009 - 06:33

I think that I found something...

I added the user in “Users Associated with Line” at the bottom of the Line configuration (“Device Profile” => “Line” configuration) and then it worked directly.

I checked and that field is not available in the “BAT.xls” file or in the Bulk Administration…

That parameter is in the “Line configuration” but, when I update it for the Device Profile, it's not automatically updated for the associated IP Communicator… I also had to update it manually for the IPC to be able to use the DND synchro with it too.

Do you know a way to update easily the “Users Associated with Line” for all my IPC, UPC and Device Profiles?

All these devices are associated to the user under "End User" configuration.

Thanks in advance.

François

Actions

This Discussion