WS-C2960-24TC-L Bug

Unanswered Question
Sep 16th, 2008

Hi,

I'm trying to configure the GigabitEthernet interface of the WS-C2960 switch to have a full duplex. Unfortunately, there is no option to configure this neither is the speed of that interface. But these options are present in FastEthernet ports. Is there a bug in SW version 12.2(35)SE5 that explains this abnormality?

Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Tue, 09/16/2008 - 17:05

Gig is full duplex by default and generally do not have to hardcode speed and duplex on a gig port it will negotiate it by itself. What you are seeing is by design.

patricia20 Tue, 09/16/2008 - 17:10

Hi,

Thanks for your reply. That is also my understanding. But how come when I check the status of the interface, the duplex is a-half even though the other port linked to it is configured as full duplex. Any thoughts on this?

Thanks!

patricia20 Wed, 09/17/2008 - 13:21

Hi,

These details might help, the module inserted in the gig port is GLC-FE-100FX (100BaseFX-FE SFP). And a 100BaseFX on the other link, module type for this is WS-X4124-FX-MT. Do you think this will cause the gig port to be half duplex?

Thanks,

Patricia

jimenez.reuben Thu, 06/28/2012 - 15:19

On the 2960 switch the "dual purpose" uplinks need to be manually configured with "media-type" to be able to set speed/duplex. Default would not allow setting these 2 attributes.

interface GigabitEthernet0/1

switchport mode trunk

media-type rj45

speed 100

duplex full

end

GigabitEthernet0/1 is down, line protocol is down (notconnect)

  Hardware is Gigabit Ethernet, address is

  Description: Uplink to Cat01

  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive not set

  Full-duplex, 100Mb/s, link type is auto, media type is 10/100/1000BaseTX

http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_55_se/configuration/guide/swint.html#wp2219831

Leo Laohoo Thu, 06/28/2012 - 16:00
I'm trying to configure the GigabitEthernet interface of the WS-C2960 switch to have a full duplex.  Unfortunately, there is no option to configure this neither is the speed of that interface.

It's not a bug.

You cannot configure the speed and duplex setting of an fibre optic SFP port.  Fibre optic SFP will negotiate to FULL Duplex and 1000Base, period.

amikat Fri, 06/29/2012 - 14:40

Hi,

Will you please try to configure "duplex full" interface configuration at the WS-X4124-FX-MT module (other end) as the default setting is "half" for the Cat4000/4500 100-Mbps fiber modules and see if there is any progress.

Best regards,

Antonin

Actions

This Discussion