Silent Monitoring - UCCX 5

Unanswered Question

I have a client that use Broadcom NetXtreme 57xx Gigabit NICs for their desktops. Is this NIC card supported for UCCX 5.0 Silent Monitoring & Recording?? All their PCs are WinXP without any firewalls.

I have tried everything. When i tried to use silent monitoring on supervisor desktop, i can't hear anything.... and when i tried to use Recording, i can't hear anything either.

Is there any special setup that i need to do on my SW config?? Currently, their VLAN 1 is data and VLAN 15 is Voice...

interface GigabitEthernet4/0/17

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 15

speed 100

duplex full

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

priority-queue out

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

storm-control broadcast level 5.00

I have spent a lot of time on this already but couldn't get it to work. Would appreciated any help.

Cheers,

Hunt

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
Chuck Smith Fri, 09/19/2008 - 09:39

Make sure in the Desktop Administrator that the phone is set to Desktop Monitoring and you have selected the right monitoring server.

Chuck Smith Fri, 09/19/2008 - 20:30

If there is no server specified next to the phone it will use the default at the top.

sturcott9891 Mon, 09/22/2008 - 11:30

I'm a noob and have no idea what I'm doing but do you have Span to PC Port enabled on all of your phones? This is done in the CM device configuration.

Chuck Smith Mon, 09/22/2008 - 11:37

Yes in order for desktop monitoring to work you have to span the voice traffic to the PC port on the phone. If you don't want to do that you have to SPAN the Vlan to the IPCC servers second port and disable desktop monitoring.

jalsman Thu, 01/29/2009 - 14:51

any clue on what fixed it? Having same issue, no sound when monitoring or recording.

iftikharsyed_2 Thu, 01/29/2009 - 23:46

Hi,

You can do it via workflow - > user interface.

You can add two custome buttons one for start recording and one for stop recording by defining actions against these buttons.

HTH

Regards,

Iftikhar

jalsman Fri, 01/30/2009 - 00:37

no I was referring to the no sound when monitoring and or recording. any thoughts on that?

mikram Fri, 01/30/2009 - 02:03

Hi

Do you have sound card installed on your pc where you want to hear voice recording?

Anthony Holloway Fri, 01/30/2009 - 07:18

If there is no sound, one of two things is happening.

1) The audio stream is getting to the Supervisor's desktop, but the audio is just not heard.

2) The audio stream is not getting to the Supervisor's desktop.

In situation #1, you need to troubleshoot that desktop computer's sound. Volume?

In situation #2, you would actually receive an error message pop up on the CSD application stating that no audio packets were received.

If #2 is what you are experiencing then check the following:

1. While the Agent is on a call, double press the ? button on the phone and note the codec in use. Only G711 and G729 can be monitored (or recorded). Alternatively you can browse to the phone IP and select Stream 1 from the left navigation. This will also tell you the codec in use.

If the codec is G722, you will need to disable G722 globally in CCM or just for agent phones. Just because it says in the region to use G711 or G729, G722 auto negotiates, and will override the region setting.

2. Check the agent's CCM phone config for the following:

- Span to PC port (Enabled)

- PC port (Enabled)

3. Run postinstall.exe on the agent desktop, and reselect the NIC in the drop down list. Even if it was correct, the act of reselecting it actually does something to fix this.

4. Check the NIC binding order on the UCCX server. The monitor/recording NIC should be on top. If you are only using one NIC, then the disabled, unused NIC should be on bottom.

5. Check the administrator desktop app, and make sure the phone devices are using the correct monitor/recording server. A blank entry means that device uses the default one at the top of the list.

Additionally, I have used Broadcom NetExtreme 57XX Gigabit NICs right out of the box, on brand new machines, and monitor/recording works every time. You don't even need the "work arounds."

jalsman Fri, 01/30/2009 - 13:49

got it to work. thanks for all the detailed info. Juts got a linksys nic from the list and it worked.

jalsman Fri, 01/30/2009 - 14:12

what drivers have you used with your broadcom 57xx gig nic? Have a few of those and cant' get it to work.

Thanks

destiny6366 Thu, 06/18/2009 - 12:48

Can you tell me where to locate the Span to PC port and NIC binding on the UCCX server. My problem is situation 2, receiving the pop error. I am monitor some agents but not all. Any advise would be helpful. Thanks

Actions

This Discussion